Jump to content
MaMontreAutomatique

Problèmes D'urls 404 Étranges Deux Fois De Nom De Domaine

Recommended Posts

Bonsoir,

 

Gérant de la boutique MaMontreAutomatique.com, je rencontre un problème insoluble... Enfin tout au moins, que je n'arrive pas à résoudre.

 

La boutique était en version 1.3 jusqu'en juillet 2015, depuis, j'ai effectué une migration vers Prestashop 1.6.1

 

Depuis cette migration, je rencontre des problèmes d'urls 404 signalées dans webmaster tools de Google. Voici le type de liens qu'il signale :

http://www.mamontreautomatique.com/www.mamontreautomatique.com/13-nouvelles-montres

http://www.mamontreautomatique.com/home/www.mamontreautomatique.com/home/163-montre-automatique-flyingtimeb.html

 

 

En gros, mon site génère des liens en ajoutant le nom de domaine au nom de domaine, bref, le nom de domaine est présent deux fois... Je ne comprend pas pourquoi.

 

J'avais à l'époque des modules d'url canonique que j'ai désactivé car ces derniers me généraient encore plus ce type de mauvais liens mais malgré celà, ça continue...

L'url canonique est définie dans prestashop (interface admin) mais je suppose qu'il manque quelque chose, peut être devrais-je toucher à mon fichier header.php????

 

Bref je ne sais plus comment faire pour sortir de cette situation qui est pénalisante sur le plan du référencement.

 

J'espère que vous saurez m'aider.

 

Cordialement

Antony PEREZ

 

Ci-dessous, des captures d'écran de la configuration actuelle du SEO dans Presta et de Webmaster Tools et de ces liens étranges.

post-126164-0-28704100-1448398306_thumb.jpg

post-126164-0-56192500-1448397918_thumb.jpg

post-126164-0-87610500-1448397906_thumb.jpg

post-126164-0-23560900-1448398318_thumb.jpg

Edited by MaMontreAutomatique (see edit history)

Share this post


Link to post
Share on other sites

Re: après analyse, je pense que vous êtres victime de la cache.
 

Alors vidé la cache du navigateur , aussi un nettoyage complet avec CCleaner pour la cache.

Aussi appuyer la touche "windows + R" , vous taper : " cmd"  ensuite dans la fenêtre tous noir vous taper  : "ipconfig /flushdns "

 

Cette commande va effacé votre cache de résolution , redemarer votre routeur et essayer de nouveau pour verifier votre site . 

 

Chez moi tous est nickel .

 

 

Share this post


Link to post
Share on other sites

Bonjour,

Il serait interressant de savoir sur quoi ces url sont référencées... dans votre image c'est l'onglet d'a coté "reférencé sur" :

 

post-126164-0-56192500-1448397918.jpg

Share this post


Link to post
Share on other sites

Merci, 

 

je viens de faire ça mais les erreurs persistent dans webmaster tools, google continue de les détecter.

 

dans mon navigateur tout est correct, je ne vois pas ces liens étranges, c'est google qui les détecte lors de l'exploration...

Share this post


Link to post
Share on other sites

apres analyse de la cat 52-les-montres-du-mois il n y a pas d erreur 404 présentent dans le code source, ce qui est étonnant c'est de faire ressortir la categorie home dans les url... peu etre que le site est en multiboutique...

Share this post


Link to post
Share on other sites

pour ma part je met ca dans mon header.tpl pour gérer l'url canonique:

{if $page_name == index}
	<link rel="canonical" href="{$base_dir}" />
		{elseif $page_name == product}
	<link rel="canonical" href="{$base_dir}{$request_uri|substr:1}" />
		{else}
	<link rel="canonical" href="{$base_dir}{$request_uri|substr:1|regex_replace:'/\/(.*)/':''|regex_replace:'/\?(.*)/':''}" />
	{/if}

Share this post


Link to post
Share on other sites

Non, le site n'est pas en multi-boutique, mais peut être que les paramètres de réécriture d'url définis dans l'admin de presta ne sont pas bons... Je n'y ai pas touché lors de la mise à jour en version 1.6, j'ai laissé ceux par défaut. 

 

Voir capture d'écran :


je vais essayer d'intégrer ce code au header dés demain matin, je verrai le résultat.

 

Merci en tout cas c'est trés gentil à vous.

post-126164-0-61824600-1448400893_thumb.jpg

Share this post


Link to post
Share on other sites

oui en tout cas ca n a pas grand chose a voir avec vos erreurs 404 detectés par google... peu etre regenerer le .htacess qui fait les regles de redirection... dans Configuration des URL mettre url simplifié à NON puis enregistrer, ensuite remettre url simplifié à OUI et cliquer sur enregistrer ca va regenérer le .htaccess du site

Share this post


Link to post
Share on other sites

 

ce qui est étonnant c'est de faire ressortir la categorie home dans les url...

 

en fait c'est parce que vos produits ont comme categories par défaut la categorie accueil du site....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More