Jump to content
vanessa.SLM

(RESOLU) erreur lors de la création de l'image supplémentaire

Recommended Posts

Bonjour, (et pardon si je ne suis pas dans la bonne section)

 

après avoir installé une boutique neuve 1.6.0.11 sur mon hébergement 1and1, j'ai importé ma base de donnée que j'avais préparé sur mon site en local... seule façon pour moi de réussir à faire fonctionner l'ensemble après mainte reprise

 

tout fonctionne parfaitement bien, sauf au niveau des fiches produits, il est impossible d'ajouter une seconde image, je me retrouve avec l'erreur suivante: erreur lors de la création de l'image supplémentaire

 

cette erreur apparait uniquement lorsque j'ajoute une seconde image après avoir tout écumé aujourd'hui je ne sais plus où regarder pour régler ce soucis, j'ai l'impression que c'est une de ces deux tables qui ne fonctionne pas correctement ps_image ou ps_image_shop

 

de même sur le ftp les dossiers p où devrait se trouver les images semble ne pas se créer

 

si j'active le mode debug j'ai ce message à la place de celui ci-dessus JSON Parse error: Unrecognized token '<' 

 

tout mon dossier image est en 777 récursif

 

j'utilise le thème de base ou j'ai uniquement modifié du css et la page product.tpl donc je ne pense pas que ça puisse être en cause

je n'utilise aucun module hormis atos qui n'était pas intégré dans la solution

 

je vois absolument pas de où cela pourrait provenir et comment résoudre le soucis, je serais vraiment reconnaissante si quelqu'un pouvait avoir une idée du problème

de même qu'en local je n'ai aucun soucis avec la même base de donnée je peux ajouter autant d'image que je souhaite sur la fiche produit

 

merci pour votre aide

 

sachant que j'avais importé mes produits existants via un fichier csv je ne sais pas si il y a pu avoir un conflit au niveau des images, je l'ai toutes supprimés hormis celles déposées sur cette dernière version lors de l'installation en local

 

pour faire bref si cela peut aider car j'ai vu plusieurs fois ce soucis plusieurs fois, de mon côté c'était un soucis dans la base de donnée sur les tables ps_image_shop et ps_image

 

une colonne id_product n'avait rien à faire dans la table ps_image_shop

pour la table ps_image je l'ai simplement recrée

 

je comprends pas trop ce qu'il s'est passé sachant qu'en local je n'avais pas rencontré ce problème mais si jamais ça peut aiguiller certains...

 

 

Edited by nuagedeperles (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

c'est ce que j'ai fait lors de mes premiers essais mais c'était pire, j'avais exprès acheté un module d'exportation pour le catalogue, les clients etc... 

j'ai passé je ne sais combien de temps avec 1and1 ce matin, je n'avais même plus la possibilité de toucher à la base de donnée manuellement

j'ai fait comme ça simplement car tout le reste a planté :/

en local tout marche impeccable, en ligne maintenant je n'ai que ce soucis d'image

Share this post


Link to post
Share on other sites

quelle est l url du site ?

Pardon est ce que tu as un accès au log d'erreurs du serveur ?

as tu un accès a phpmyadmin ?

 

Ce mec a résolu ton erreur:

 

http://forge.prestashop.com/browse/PSCFV-5756

 

"Maybe you have no rights to write in php temp folder."

Edited by Alexandre-KM (see edit history)

Share this post


Link to post
Share on other sites

je suis effectivement tombé sur ce sujet, j'ai ouvert le fichier en question mais la ligne dont il parle est introuvable dedans :(

 

j'ai accès à la base de donnée oui mais je ne sais pas où trouver les logs d'erreurs

 

la configuration elle semble correcte puisque j'ai

 

Informations sur votre serveur Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux

Version du logiciel serveur Apache

Version de PHP 5.5.30

Limite de mémoire 128M

Temps d'exécution maximal (max_execution_time) 30

Edited by nuagedeperles (see edit history)

Share this post


Link to post
Share on other sites

je pense qu'il y a un soucis du côté de la table ps_image_shop car lorsque dans un premier lieu j'ajoute une image la colonne id_product se met systématiquement à 0 et donc il faut que je la modifie manuellement

Share this post


Link to post
Share on other sites

il y a surtout un souci avec 1&1, fuyez cet hébergeur !

Espace disque limité

Nombre de fichiers limités

Mémoire à 128Mo on croit rêver... Presta1.6 a besoin de 512 au minimum pour fonctionner correctement

Share this post


Link to post
Share on other sites

pourtant la configuration requise est celle-ci non?

 

 

  • Dans la configuration PHP, demandez à votre fournisseur de fixer memory_limit à "64M" et upload_max_file_size à "16M"

Share this post


Link to post
Share on other sites

ouep, cette doc remonte à la 1.4, mais dans les faits ce n'est plus vrai.

Avec votre configuration actuelle l'affichage des pages et les enregistrements en BO ne doit pas être bien rapide...

Share this post


Link to post
Share on other sites

j'ai aucun soucis particulier je suis chez eux depuis 2009 pourtant 

mais bon pour le coup je pense pas trop que ça vienne de là? le seul bug que je remarque c'est dans le fonctionnement des deux tables de la base de donnée, mais je sais pas comment savoir si c'est lié, on dirait qu'elles ne s'incrémentent pas correctement

Share this post


Link to post
Share on other sites

je me demande si je n'ai pas vu juste concernant les tables de la base je pense que j'ai une colonne en trop quelque part... si c'est ça je ne sais pas comment cela est arrivé

 

combien doit-il y avoir de colonnes dans ps_image_shop et ps_image?

 

pour ma part j'ai:

 

pour ps_shop_image

id_product (en trop?)

id_image

id_shop

cover

 

id_image

id_product

position

cover

 

 

du coup je viens de faire une installation test il n'y a bien que 3 colonnes apparemment dans ps_image_shop mais du coup si je dois la supprimer quelle est la meilleure façon de procéder? j'ai un peu peur de toucher à la base de donnée pour ça

 

(bon eh bien non la suppression de cette colonne ne change rien au problème je désespère)

Edited by nuagedeperles (see edit history)

Share this post


Link to post
Share on other sites

enfin résolu en recréant la table ps_image et en insérant à nouveau les données

je peux ajouter autant d'images que je veux maintenant

merci à ceux qui ont essayé de m'aider

Edited by nuagedeperles (see edit history)

Share this post


Link to post
Share on other sites

enfin résolu en recréant la table ps_image et en insérant à nouveau les données

je peux ajouter autant d'images que je veux maintenant

merci à ceux qui ont essayé de m'aider

Bonjour,

vous avez réinseré les données à l'identique dans la table image ?

 

j'avais le même probleme que vous, j'ai donc viré la colonne de trop dans ps image shop.

Par la suite j'ai essayé de créer un nouveau produit mais au bout de 2 images le message d'erreur apparait de nouveau.

Et en rajoutant une image à un produit existant, l'image s'ajoute en back office mais pas en front office (ni meme dans les déclinaisons en backoffice le choix de l'image rajoutée n'est pas possible).

 

C'ets pour cela que je voulais savoir si vous avez recrée la table image à l'identique ou faut il modifier quelque chose ?

 

Cordialement,

bonne journée

Share this post


Link to post
Share on other sites

Bonjour à tous !

je viens de passer de V5 en V6.

j'ai eu le même problème qui prend bien la tête ....

 

mon erreur à moi été de copier de table (V5) à Table (V6) via phpmyadmin

la table ps_image il faut la copier par requête en stipulant NULL pour la V6 à la place des  zéros en V5.

idem pour la table ps_image_shop qui doit recevoir de NULL et non de 0

voila si cela peux aider...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More