Jump to content
Meliso

Rendre images non cliquables

Recommended Posts

Bonjour à tous,

 

Quand on clique sur une vignette produit dans la boutique, l'image s'ouvre seul sur une nouvelle page. Il faut faire un back pour revenir à la page précédente. Donc en gros les visiteurs sortent du site et vont donc partir très vite.

 

Je cherche tout simplement à ce que ces vignettes ne soient plus cliquables du tout, puisqu'elles s'affichent en grand par le mouse-over.

 

Qui peut me dire quel fichier il me faut bidouiller, et quels termes (je suppose un "_blank" quelque part) remplacer par quels autres svp ?

 

Un grand merci d'avance : MON SITE

 

Share this post


Link to post
Share on other sites

Bonjour,

 

site en maintenance donc impossible de consulter le soucis.

 

mais il n'est pas normal que votre image s'ouvre sur une autre page elle devrait s'ouvrir en grand dans le site sous forme de popup.

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci d'avoir regardé. Effectivement en mode normal ce sera plus simple. Je viens de la passer en visible.

Ce que je souhaiterais c'est que les images ne s'ouvrent pas du tout, ni dans un onglet new ni dans une pop up.

Merci d'avance.

Share this post


Link to post
Share on other sites

Perso sur firefox pas le moindre soucis, l'image n'est pas cliquable et le zoom au survol n'apparait même pas.

Share this post


Link to post
Share on other sites

Merci, je n'ai pas encore testé sous firefox. Je suis sous Chrome.

Ca signifie que le navigateur interprète l'action à suivre comme il le veut, ou bien cela signifie que l'action est paramétrée dans le thème différemment selon le type de navigateur ? Et si c'est le cas dans quel fichier à votre avis ?

 

J'ai l'habitude de manipuler des sites wordpress, mais prestashop est nouveau pour moi et l'architecture des fichiers me laisse encore perplexe pour le moment ;)

Share this post


Link to post
Share on other sites

Bonjour Meliso,

 

Sur cette page http://www.argos-urnes-animaux.com/13-fermoirs, sur Chrome, en cliquant sur la photo on aboutit sur la fiche produit. Le comportement est donc normal.

 

De quelle page parles-tu par exemple ? page d'une catégorie ?

 

Il n'y a pas dans les fichiers du thème prestashop un comportement différent selon le navigateur. 

 

Bonne journée

 

Denis

Share this post


Link to post
Share on other sites

j'ai testé le lien dans le premier message et effectiement sur chrome, FF et IE ça ne fonctionne pas correctement, quand on clique sur une miniature on arrive sur l'image (exemple : http://www.argos-urnes-animaux.com/99-thickbox/solaris-blanc-email.jpg ).

 

Quand je regarde la console sur chrome j'ai le message : Uncaught TypeError: $(...).jqueryzoom is not a function 

Share this post


Link to post
Share on other sites

il doit y avoir un souci dans l'ordre de chargement des scripts, jquery est chargé trop tard

 

Désactivez la compression et le déplacement des fichiers js en bas de page pour voir...

Share this post


Link to post
Share on other sites

Bonjour

DD-DD2 : c'est quand on est sur la fiche produit. On a ensuite des miniatures qui sont censées s'ouvrir dans une lightbox, or les miennes sous chrome s'ouvrent simplement dans un nouvel onglet. Mais merci pour le renseignement, je sais maintenant qu'il n'y a pas de comportement différent selon les navigateurs normalement.

 

COEOS.PRO : 

Oui c'est exactement ça. Mais grâce à ton intervention je sais maintenant que y a un truc avec le jquery. Je vais pouvoir creuser en ce sens.

 

Merci à tous. Si quelqu'un a une idée plus précise encore, je suis toujours preneuse ;)

 

Belle journée.

Share this post


Link to post
Share on other sites

Bonjour Meliso,

 

Ok, je vois sur quelles photos il y  a un problème. 

 

Si tu as besoin de précisions sur la solution de Eolia, voici quelques infos.

 

Dans Paramètres avancés / performance

a)

section réglages CCC : 

- désactiver les réglages  (sauf optimisation apache).

 

B)

section smarty

En complément bien sûr des réglages ci-dessus, aller dans la section smarty "forcer la compilation" et Cache "Non"

 

c)

en haut de page, bouton "vider le cache".

 

 

Puis recharger la page produit front office, et enfin remettre tous les réglages comme avant.

 

@bientôt

Denis

Share this post


Link to post
Share on other sites

Résolu !

 

Il s'agissait simplement d'un réglage dans le back office.

Voici comment procéder, si certains ont besoin de le faire  : 

 

Préférences>Produits : Page Produit :

" Activer JqZoom au lieu de Fancybox sur les pages produits" : Régler sur "NON">ENREGISTRER

 

Merci à tous malgré tout !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More