Jump to content
BDohmen

[Solved] CMS - category cannot be loaded

Recommended Posts

Op dit moment heb ik een probleem met mijn CMS omgeving, zowel in de front- als de back office.

Back office: daar krijg ik de category cannot be loaded melding

Front office: daar krijg ik een 404 of pagina bestaat niet.

 

Het probleem is ontstaan doordat ik mijn site heb willen updaten naar een nieuwe versie, daarna zijn een aantal zaken omgevallen, waaronder CMS.

 

Servergegevens
Servergegevens Linux #1 SMP Tue May 12 18:07:50 MSK 2015 x86_64
Server softwareversie Apache/2
PHP versie 5.5.24
Geheugenlimiet 128M
Maximale uitvoeringstijd 60
MySQL versie 5.6.23
MySQL server localhost
Tabellen voorvoegsel ps_
MySQL-engine InnoDB
Winkel informatie
Prestashop versie 1.6.0.11
Winkel-URL http://handelsondernemingdohmen.nl/
Huidig gebruikte thema default-bootstrap​

 

 

post-935083-0-31294300-1442734693_thumb.jpg

post-935083-0-14045000-1442734692_thumb.jpg

post-935083-0-06386800-1442857655_thumb.jpg

Edited by BDohmen (see edit history)

Share this post


Link to post
Share on other sites

Hoi Maconl,

 

bij Controleer uw configuratie staan de onderstaande waarden.

- Verplichte parameters Oké

- Optionele parameters Oké

Ik zie op deze pagina wel een aantal missende bestanden staan. ik weet niet waar ik deze vandaan kan halen, want deze meeste backups welke ik heb, staan deze niet in.

Missende bestanden (15)

  • CONTRIBUTING.md
  • CONTRIBUTORS.md
  • README.md
  • js/admin-dashboard.js
  • js/admin-dnd.js
  • js/admin-products.js
  • js/admin-scene-cropping.js
  • js/adminImport.js
  • js/admin_carrier_wizard.js
  • js/admin_order.js
  • js/attributesBack.js
  • js/login.js
  • js/notifications.js
  • js/price.js
  • js/tinymce.inc.js

De debug info had ik al​ meegestuurd.

Edited by BDohmen (see edit history)

Share this post


Link to post
Share on other sites

de info welke je hierboven vermeld is van je configuratie , niet de debug ;)

 

maar die missende bestanden kan je weer aanvullen

 

download de versie die je nu hebt

 

open de mappen en zoek de missende files

 

upload deze naar je hosting wel in de juiste mappen uploaden !

 

deze vind je in de root

  • CONTRIBUTING.md
  • CONTRIBUTORS.md
  • README.md

 

de rest vind je in de map JS

 

indien het nog niet naar wens werkt

dan even je debug aanzetten kijken of hier wat uit komt

Share this post


Link to post
Share on other sites

in het plaatje van de 1e post zit de debug

 

Die is erg lastig te lezen , kon dus niet zien dat deze van de debug is  ^_^

Share this post


Link to post
Share on other sites

Ik heb nieuwe debug screenshots gemaakt en deze aan het 1e bericht gekoppeld.

een vanuit BE en 1 vanaf de shop

Share this post


Link to post
Share on other sites

ok nu is het duidelijk  ;)

 

kijk in je database of :

ps_cms_lang bestaat en of het de  id_shop heeft 

 

kijk in je database of :

ps_cms_category_language bestaat en of het de  id_shop heeft 

Share this post


Link to post
Share on other sites

@mdekker: ik heb jouw werkwijze geprobeerd, maar ik denk dat ik iets verkeerd doe. want ik krijg een 404 error.

Het kan natuurlijk ook zijn dat ik de verkeerde oude versie hebt genoemd.

Het probleem is dat ik niet meer weet welke versie dit is geweest. 1.6.0.9 of 1.6.0.10 of een andere.

Share this post


Link to post
Share on other sites

Als ik de aangepaste link gebruik dan krijg ik de volgende melding:

 ?xml version="1.0"?
action error="35" result="fail"

Share this post


Link to post
Share on other sites

helaas zelfde melding.

daarnaast kreeg ik een beveiligingsmelding betreffende de install map.

 

Ik heb deze even verwijderd, want ik denk dat ik ook versie 14 moet instaleren, aangezien die upgrade fout ging.

Share this post


Link to post
Share on other sites

mocht het niet lukken kijk dan in je db of je shop id is ingevuld bij cms gebeuren

Share this post


Link to post
Share on other sites

@mdekker: helaas daar kom ik niet bij, ik zal het even bij mijn hosting partij navragen.

 

@maconl: ik heb te weinig kennis van DB, ga me maar eens inlezen, hoe ik dit het makkelijkste kan bekijken en aanpassen

Share this post


Link to post
Share on other sites

Ik zie dat je PHP 5.5 hebt. Is de ingebouwde OPCache ingeschakeld?

opcache.enable = 1; staat in dat geval dan in php.ini

 

sommige hosters geven idd helaas geen toegang tot de php.ini

op 1 hosting heb ik dit ook maar kan middels de hoster binnen een uur aangepast worden

Share this post


Link to post
Share on other sites

Ik heb even met PHPmyadmin gekeken, maar volgens mij staan beide waarden er niet in.

 

Het plaatje is aan het 1e bericht gekoppeld

 

Nu is de vraag wat moet er ingevuld worden?

Edited by BDohmen (see edit history)

Share this post


Link to post
Share on other sites

Ik heb geprobeerd om bij beide Waarden (ps_cms_category_lang & ps_cms_lang) de kolom id_shop toe te voegen.

Ik heb hier phpmyadmin voorgebruikt.

 

Als ik de waarde toevoeg en op SQL voorbeeld klik, dan krijg ik de onderstaande regel te zien.

ALTER TABLE `ps_cms_lang` ADD `id_shop` INT(10) UNSIGNED NOT NULL AFTER ;

Druk ik echter op opslaan, dan krijg ik de melding: MySQL meldt: #1064 - you have an error in your SQL syntax

Share this post


Link to post
Share on other sites

ik heb in beide tables de kolom id_shop toegevoegd.

 

Maar als ik in de BackEnd ga kijken bij de CMS knop, dan krijg ik nog steeds dezelfde melding.

wat zie ik over het hoofd?

Share this post


Link to post
Share on other sites

Ok, dan moet ik even kijken hoe we dit kunnen vullen.

 

de php.ini aanpassing is aangevraagd, en dan vooral de 2e optie.

Share this post


Link to post
Share on other sites

Ik ga de upgrade nogmaals proberen.

Het enige wat ik niet weet, is het versienummer van de vorige versie (voor 1.6.0.11).

 

maakt het iets uit als er een ander maar ouder versienummer staat?

Share this post


Link to post
Share on other sites

Ik heb de upgrade uitgevoerd, hij lijkt iets te doen want na het uitvoeren van de link staat het versienummer van

_PS_VERSION_ weer op 1.6.0.11 in het bestand settings.inc.php.

Ik krijg alleen een XML file als uitvoer, deze is gekoppeld.

 

Ik zie de volgende error, te weten (even kijken of ik de error goed interpreteer):

- 34: Versie bestaat niet.

 

results_upgrade.txt

 

 

Ik heb de 1.6.0.14 install ook klaar staan, deze kan ik eventueel ook runnen

Edited by BDohmen (see edit history)

Share this post


Link to post
Share on other sites

De CMS pagina in de backend, werkt nog niet, dat is jammer. deze kan ik nog niet aanpassen

 

Ik ben aan het kijken om de template aan te passen, zodat alles mooi verdeeld wordt, maar eerst wilde ik de fouten eruit halen.

 

Ik wil de categorieën eruit laten zien zoals het blok overtuigen, voor nu is dit ok, dan lijkt er iets op de site te staan.

Share this post


Link to post
Share on other sites

Zojuist even een nieuwe debug gemaakt.

 

Als ik het goed lees, dan mis ik nog een tabel genaamd: ps_cms_category_shop

 

post-935083-0-39613500-1442988909_thumb.jpg

 

Ik ga de 3 genoemde mappen even kopiëren.

Edited by BDohmen (see edit history)

Share this post


Link to post
Share on other sites

Na het kopiëren van de genoemde mappen, lijkt het CMS panel in de back end ineens te werken.

 

Ik heb de betreffende pagina's even bijgewerkt en getest, alleen de algemene voorwaarden doen het niet, ga ik ff uitzoeken.

 

maconl en mdekker: bedankt voor de hulp

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More