Jump to content
pandorrah

[1.6.0.9] upgrade fouten en backup fouten

Recommended Posts

Ik heb gisteren de 1-click upgrade weer eens geprobeerd (dezelfde die problemen gaf van de upgrade van 1.5 naar 1.6):

  • 1-click upgrade gekozen van 1.6.0.9 naar 1.6.0.14
  • upgrade tot 6 maal toe opnieuw moeten uitvoeren omdat hij tijdens de upgrade tijdens het backuppen steeds crashte
  • uiteindelijk is de upgrade (en backup) gelukt. resultaat: site weer onherkenbaar verknoeid
  • tot 4 maal toe geporbeerd om de 1.6.0.9 backup terug te zetten, maar de knop Terugzetten verwijst naar de url die boven in de adresbalk staat.
  • uiteindelijk heb ik de backup van de server gekopieerd, offline uitgepakt en handmatig via ftp weer geupload
  • oude sql kopie ook weer netjes teruggezet
  • resultaat: helemaal geen website meer te zien, bij controle slechts op de pagina:

        <html>
            <head></head>
            <body data-pinterest-extension-installed="ff1.35">
            </body>
        </html>
     
  • resultaat: ik kan ook niet meer in de backend inloggen wegens dezelfde error. ik heb geprobeerd om nóg oudere backups terug te zetten van zowel de site als de sql, maar met hetzelfde resultaat.
     

Iemand enig idee? Ik heb ook al online Prestashop error checkers geprobeerd, maar die zeggen standaard:
 

Website Availability

Website isn't available

Please check your website. Contact your hosting provider or system administrator if needed.

 

Share this post


Link to post
Share on other sites

Update:

  • cache gewist, CTRL + [F5] gedaan en nu ein-de-lijk: iéts op mijn scherm:

Fatal error: Class declarations may not be nested in .../classes/Tools.php on line 525

Share this post


Link to post
Share on other sites

Heb je geen backup via je control panel van je hosting account ?

Ik maak dagelijks automatisch  via DirectAdmin  en Installatron een backup van de complete PS installatie, zodat je altijd kan terugvallen op een complete backup.

 

Aan de html-code te zien wordt er een plugin van printerest ergens geladen.en niet de PS pagina

 

<body data-pinterest-extension-installed="ff1.35">

 

je standaard index.php  is dus waarschijnlijk niet degene die het zou moeten zijn

Share this post


Link to post
Share on other sites

Hoi racemaniac,

 

thanx voor je reply. :)

De back-up blijkt dus ook niet langer te functioneren, dat is het hele probleem. Zowel de teruggezette (gedowngrade) 1.6.0.9 versie werkt niet (wit scherm), en ook een handmatig teruggezette backup geeft geen resultaat.

 

Die pinterest is een add-on voor firefox, die kun je negeren

Share this post


Link to post
Share on other sites

Hoi

die backup werkt wellicht wel

als je een backup ( van server en database, dus niet van prestashop !

terug wilt zetten , dien je eerst alle bestanden van  je hosting en database te verwijderen

daarna zet je de back up terug

 

reden is als je een backup terug plaatst en foute bestanden laat staan worden deze uiteraard overschreven

echter nieuw aangemaakte tabellen en bestanden blijven staan , deze staan immers niet in je oude backup

aangezien hier dus ook de fout inzit blijft de fout terugkomen

Share this post


Link to post
Share on other sites

Ik ga er nog eens mee aan de slag, ik heb nog wel een belegen backup, ik zal eerst even overal alles verwijderen en een schone, oude backup terugzetten; ben zo terug met het resultaat.

Share this post


Link to post
Share on other sites

is prima ,,

dus gewoon de bestanden en inhoud van de database verwijderen

dan de backup terug plaatsen , als je directadmin hebt kan je gewoon de backup terug zetten met deze dan hoef je niet alles los uit te voeren

Share this post


Link to post
Share on other sites

heb je alle bestanden van je hosting verwijderd ?

in sommige gevallen blijven er bestanden evengoed achter ivm GID deze staat dan op Apache ipv de naam van de server

en ook de gehele database verwijderd alvorens je weer de backup terug plaatste ?

 

en is de backup vanuit je hosting gemaakt of vanuit prestashop ?

 

normaal als je alles verwijderd hebt en je zet de backup terug moet alles weer bij het oude zijn (anders zou het geen zin hebben om een backup te maken  ;) )

Share this post


Link to post
Share on other sites

Ik begrijp het backuppen en plaatsen volledig. In dit geval heb ik mijn eigen backup (niet van PS) en ook de SQL weer volledig teruggezet, na dat ik eerst de site volledig (ook de SQL) had verwijderd. Het probleem duurt nu al 2 dagen en is erg frustrerend:

 

de index.php heeft wel inhoud, maar de pagina levert niets op en blijft blanco:

html>

    <head></head>
    <body>
    </body>

</html>

Share this post


Link to post
Share on other sites

Opgelost: als in

 

de hoster heeft een 5 dagen oude backup teruggezet en die werkt gelukkig weer feilloos, meteen weer een goed werkende backup van gemaakt en we gaan vrolijk verder met versie 1.6.0.9.

In de 2 jaar dat ik met Prestashop werk, heb ik één ding geleerd:

 

als je site goéd werkt, niéts meer bijwerken upgraden of uitbreiden, maar braaf je artikelen toevoegen voor de verkoop.

 

:D B) :D B) :D B) :D B)

 

Wat de oorzaak was/is, geen flauw idee, maar als je hoster naast je publieke map(site) ook nog andere, niet toegankelijke mappen heeft, uitsluitend voor jou en hen bedoeld (bijv. map webstats, wiki, etc.) laat die dan altijd zoals het is, m.a.w. niet bijwerken, opnieuw uploaden, etc.

Edited by pandorrah (see edit history)

Share this post


Link to post
Share on other sites

Zeer bekend probleem. ben zelf ook weken bezig geweest met het terugzetten van de backups, wissen van cache en zo door.
(wit scherm? delete via FTP de inhoud van cache/smarty/compile en de file cache/class-index.php. werkt in 9 van de 10 gevallen)

had mede door enkele modules die in het verleden n keer geinstalleerd waren ook fouten in de database. dan wordt upgraden helemaal n ramp!

uiteindelijk heb ik het toch voor elkaar gekregen een schone upgrade te maken van 1.6.0.6 naar 1.6.0.14

ik heb eerst lokaal een kopie van de site gemaakt, deze helemaal kaal gemaakt, dus alle modules die niet echt nodig zijn gewist. in de database alle regels verwijderd van deze modules. Toen een upgrade gedaan naar de laatste versie. dan n heleboel aanpassen om alles weer toonbaar te krijgen en de modules opnieuw te installeren. zo heb ik, na veel proberen en testen een goede nieuwe versie gekregen. deze toen terug geplaatst op mijn hostingprovider. 

Al die tijd wel je site offline zetten. anders ben je alles kwijt wat je klanten doen op je site. daarom is het goed om eerst n tijdje te kl*ten op je testsite om de procedures goed door te krijgen.

Een upgrade naar 1.6.0.14 is wel de moeite waard. er zitten een hoop verbeteringen in!

Share this post


Link to post
Share on other sites

Bij mijn hoster (30 Gb ruimte, 5 SQL databases) heb ik op één subdomein mijn werkende website, op een ander subdomein heb ik nu een draaiende kopie, waarmee ik vrijelijk kan experimenteren online. Deze 2 bijten elkaar niet (settings!) en als de 2e vastloopt is er nu niets meer aan de hand, gelukkig.

 

Prestashop is -mits het werkt- fantastisch, maar upgraden zit nog steeds vol kinderziektes helaas. Bouwen en niet meer upgraden is het veiligst op dit moment.

Edited by pandorrah (see edit history)

Share this post


Link to post
Share on other sites

Wie kan mij helpen?

 

Gisteren update uitgevoerd met 1-Click van 1.6.0.9 naar 1.6.0.14.

 

Frontend werkt wel, maar niet beveiligd (HTTPS).

Backend heeft alleen maar tekst, geen template, maar werkt wel.

Alle tekst staat gewoon onder elkaar, geen menuknoppen e.d.

 

Backup van 1-Click ga ik niet terugzetten, zolang dit nog werkt.

 

www.luchtfilteronline.nl

www.persluchtfilteronline.nl

Share this post


Link to post
Share on other sites

Ter aanvulling onderstaande, debug werkt niet of geeft niets aan:

Controleer uw configuratie

Verplichte parameters Oké

Optionele parameters Oké

 

Overzicht van aangepaste bestanden
Controle van bestanden...

Share this post


Link to post
Share on other sites

Wie kan mij helpen?

 

Gisteren update uitgevoerd met 1-Click van 1.6.0.9 naar 1.6.0.14.

 

Frontend werkt wel, maar niet beveiligd (HTTPS).

Backend heeft alleen maar tekst, geen template, maar werkt wel.

Alle tekst staat gewoon onder elkaar, geen menuknoppen e.d.

 

Backup van 1-Click ga ik niet terugzetten, zolang dit nog werkt.

 

www.luchtfilteronline.nl

www.persluchtfilteronline.nl

Beide sites staan in onderhouds modus dus niets te zien

Wellicht mis je het css in je template ?

 

wat je kan proberen is

htaccess opnieuw genereren + eventueel handmatig uit een download van betreffende versie de template uploaden ( als je eea mist uit de template )

Share this post


Link to post
Share on other sites

Beide winkels zouden gewoon ingeschakeld moeten zijn volgens de instellingen en 1-Click  :huh:

 

Welk CSS zou dat moeten wezen? Veranderd dit dan met een upgrade?

 

htaccess opnieuw genereren heeft niet geholpen.

 

Het menu Thema/Thema blijkt niet meer toegankelijk:

The requested URL /web/admin9008/index.php was not found on this server.

Share this post


Link to post
Share on other sites

het css welke bij je theme zit oa , global.css etc

en sites staan in onderhouds mode

Share this post


Link to post
Share on other sites

global.css staat er in de css-map bij.

alle bestanden zijn in augustus 2014 voor het laatst gewijzigd.

 

sites zijn alleen via mijn eigen ip-adres bereikbaar, volgens backend zijn de winkels gewoon ingeschakeld!

Share this post


Link to post
Share on other sites

Ik heb een Prestashop 1.6.0.14 opnieuw geïnstalleerd in een aparte directory.

Resultaat: precies hetzelfde probleem in de backend  :huh:

 

shop.gjdroogtechniek.nl/admintest

Share this post


Link to post
Share on other sites

als deze sites alleen via je ip adres bereikbaar zijn 

staan ze voor andere offline in onderhoudsmodus :-)

Share this post


Link to post
Share on other sites

Maar er staat niets in de onderhoudsmodus volgens de backend.

 

Maakt ook niet uit welke instelling ik kies, er veranderd niets.

 

Algemeen
Schakel winkel in
JaNee
Activeer of deactiveer uw winkel. Het is een goed idee om uw winkel te deactiveren als u onderhoud pleegt. Let op, de webservice zal niet uitgeschakeld worden.

Share this post


Link to post
Share on other sites

Ik heb een Prestashop 1.6.0.14 opnieuw geïnstalleerd in een aparte directory.

Resultaat: precies hetzelfde probleem in de backend  :huh:

 

shop.gjdroogtechniek.nl/admintest

 

 

 

frontend werkt

backend shop.gjdroogtechniek.nl/admintest die verwijst naar 

http://www.gjdroogtechniek.nl/shop.gjdroogtechniek.nl/admintest/index.php?controller=AdminLogin&token=7b4ddf332de9411c8db16d5ab5eb568f

 

dit moet je even corrigeren in je BO 

denk dat je met het installeren toch iets fout doet url moet gewoon /shop zijn

met de twee andere sites

kijk maar met een ander ip adres :-) krijg onderhoudsmodus te zien

Edited by maconl (see edit history)

Share this post


Link to post
Share on other sites

Deze URL klopt.

De shop staat in een subdomein.

 

In 1.6.0.9 heeft alles gewoon gewerkt, tot na de upgrade naar 1.6.0.14.

 

Originele webshop backend:

webshop.gjdroogtechniek.nl/admin9008

Share this post


Link to post
Share on other sites

gebruik je voor dit subdomein dezelfde database als voor je 'echte' shop?

zo ja, dan zit je probleem in de database. waarschijnlijk is deze dan niet goed geupdate.
geen idee hoe je dat het beste kan oplossen. denk toch je oude backup terugschrijven

 

Ook al geprobeerd je totale cache te legen? delete via FTP de inhoud in cache/smarty/compile en de file cache/class_index.php

dit kan ook n hoop ellende oplossen. de file class_index.php word opnieuw aangemaakt door de shop

Share this post


Link to post
Share on other sites

Deze URL klopt.

De shop staat in een subdomein.

 

In 1.6.0.9 heeft alles gewoon gewerkt, tot na de upgrade naar 1.6.0.14.

 

Originele webshop backend:

webshop.gjdroogtechniek.nl/admin9008

Ook al zet je de shop in een subdomein, als je bij voorkeuren/seo&url de juiste url van het subdomein niet invult, ga je toch naar jou andere shop toe. 

dus voor de shop in het subdomein /webshop/, moet de url zijn webshop.gjdroogtechniek.nl en voor de shop in subdomein /shop/ moet de url zijn shop.gjdroogtechniek.nl

dit wordt verwerkt in je database, dus kun je voor beide shops niet dezelfde database gebruiken!!! dus voor elk subdomein een eigen database aanmaken.

exporteer je database, maak een nieuwe database aan, en importeer je database hierin

de naam en wachtwoord van je nieuwe database kun je vervolgens aanpassen in config/settings.inc.php van je testshop.

corrigeer dan je url in de backend bij seo&url en je testshop zou moeten werken.

voor de zekerheid wel ff je cache legen zoals ik beschreven heb in de andere reactie.

Edited by frank de beer (see edit history)

Share this post


Link to post
Share on other sites

Nee. NIeuwe installatie, nieuwe database, en hetzelfde probleem in backend in 1.6.0.14.

 

Cache legen en bestanden verwijderen helpt niets.

 

Ik zal eens oudere versies installeren (1.6.0.9 t/m 1.6.0.13), eens kijken wat er dan gebeurd.

Share this post


Link to post
Share on other sites

in de url zit toch een fout 

als je naar je admin gaat krijg je een hele andere url dan de normale url moet zijn

wijzig / controleer deze in je bo

Share this post


Link to post
Share on other sites

in de url zit toch een fout 

als je naar je admin gaat krijg je een hele andere url dan de normale url moet zijn

wijzig / controleer deze in je bo

en lukt het niet in de BO, pas het dan met PHPmyadmin aan in je database bij ps_shop_url. 

als je backoffice niet werkt zoals het zou moeten, zal je het misschien alleen in de database kunnen aanpassen

 

Wat jij hier beschrijft, heb ik ook gehad na de update naar 1.6.0.14. Heb toen mijn oude site gekopieerd naar de testshop, alle modules en overrides weggehaald wat niet in een basis installatie zit en daarna een update gedaan. toen had ik eindelijk een redelijk werkende site. er was door een override wel het een en ander fout in de database, maar dat heb ik (bijna) helemaal kunnen corrigeren. nu werkt alles prima, op een enkele module na (MyParcel werkt nog niet. ze werken aan een update)

een van de overrides die problemen gaf was een verbeterde BTW-berekening, die aanpassingen in de database gemaakt had

Edited by frank de beer (see edit history)

Share this post


Link to post
Share on other sites

Hallo Frank,

 

Ik heb als test een 'verse' installatie versie 1.6.0.14 gemaakt, met een nieuwe database. Dus gewoon een basisinstallatie.

Frontend werkt, backend ook maar zonder template lijkt het zodat alle tekst door elkaar staat.

Share this post


Link to post
Share on other sites

Lijkt erop dat je server problemen heeft met de software, als zelfs een kale schone installatie niet werkt. controleer ff of je php-en sql-versie toereikend zijn voor prestashop. 

https://www.prestashop.com/nl/systeem-vereisten

 

probeer eens op je eigen pc wamp te installeren en daarop prestashop te installeren. (http://www.wampserver.com/ ) bij mij werkt het zo prima en heb ik lokaal mijn testversie draaien. kan zo rommelen zoveel ik wil, zonder dat het mijn server belast. als je dan lokaal een werkende site hebt, kun je die kopieeren naar je server.

Edited by frank de beer (see edit history)

Share this post


Link to post
Share on other sites

Even voor de zekerheid 

 

hoe installeer je prestashop ?

 

handmatig dus je hebt een download en upload zelf naar de server en installeert het 

 

of via een installer op je webhosting ? bv installatron oid ?

 

vaak met auto installers werkt het niet altijd vandaar

Share this post


Link to post
Share on other sites

Post Hidden By frank de beer Today, 04:37 PM.

fout antwoord

 

 

Wel blijven opletten Frank  :lol:

 

Buiten wat je zei : ben de laatste tijd heel veel fouten tegen gekomen met die auto installers

oa controllers waar die auto-installers code erbij zet , waardoor deze niet werken incomplete php scripts  enz 

Edited by maconl (see edit history)

Share this post


Link to post
Share on other sites

Ik heb een schone installatie (1.6.0.14) uitgevoerd vanuit mijn webhoster (Yourhosting), backend werkt niet.

Prestashop gedownload, geunzipped en geupload met Filezilla en geïnstalleerd, backend werkt niet.

 

Geprobeerd met versie 13, 12 en 11. Backend werkt niet.

Versie 1.6.0.9 geïnstalleerd, backend werkt wel.

 

Volgens mij voldoet mijn webhoster gewoon aan de eisen van Prestashop, zie onderstaande gegevens:

Servergegevens

Servergegevens Linux #1 SMP Debian 3.2.51-1 i686

Server softwareversie Apache

PHP versie 5.4.39-0+deb7u2

Geheugenlimiet 64M

Maximale uitvoeringstijd 30

Database informatie

MySQL versie 5.5.41-0+wheezy1-log

MySQL server localhost

MySQL naam gjdroogt-2

MySQL gebruiker gjdroogt

Tabellen voorvoegsel ps_

MySQL-engine InnoDB

Winkel informatie

Prestashop versie 1.6.0.14

Winkel-URL http://shop.gjdroogtechniek.nl/

Huidig gebruikte thema default-bootstrap

E-mail configuratie

Mail methode U gebruikt de PHP mail() functie.

Uw gegevens

Uw web browser Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.118 Safari/537.36

Controleer uw configuratie

Verplichte parameters Oké

Optionele parameters Oké

 

Share this post


Link to post
Share on other sites

zoals in een eerdere reactie 

heel vaak geven de auto installers diverse fouten (is wel handig als je wat wilt testen maar voor een echte life shop ..... )

 

het beste is handmatig een database aanmaken en de shop installeren 

 

je host moet idd goed zijn , dat de andere versies niet werken snap ik niet zou gewoon moeten kunnen

tenzij er iets met je ftp progje is 

je kan dit testen door een image naar je root te uploaden en dan via de url te bekijken 

is deze goed dan si je ftp in orde is de image beschadigd dan uiteraard niet 

Share this post


Link to post
Share on other sites

Ik zal maandag eens contact opnemen met mijn webhoster (Yourhosting).

Als ik vanuit hun Hostingmanager Prestashop 1.6.0.14 installeer, heb ik het probleem ook, dus mogen ze daar even verder zoeken.

 

Yourhosting is overigens een zeer professionele webhoster met een zeer snelle en kundige service, dus ik ga ervan uit dat ik maandag ook al een oplossing/antwoord heb.

 

Wordt vervolgd.

Share this post


Link to post
Share on other sites

Nog ff iets...

heb je eventuele 3-party modules gewist? niet alles werkt even lekker met 1.6.0.14, zoals de module van myparcel bv.

Ook templates die niet getest zijn voor deze versie kunnen problemen geven. zo had ik gedoe met de free templates van Leo en apollo templates.

maar je hebt een clean install gedaan, dus de default bootstrap. dus dat zal niet de reden zijn.

Heb je ook al geprobeerd local, dus op je eigen pc prestashop te installeren? Bij mij draait dat als een charm :)

dan weet je in ieder geval dat de problemen waarschijnlijk bij je hosting liggen. Als ze echt zo kundig zijn, moeten ze er wel uit komen daar. 

Misschien is er tijdens je eerste upgrade naar 1.6.0.14 ergens op de server iets fout gegaan.

Hou ons op de hoogte!! :)

Share this post


Link to post
Share on other sites

Mijn webhoster kon mij ook niet helpen met specifieke Prestashop problemen.

 

Het is gelukkig vandaag gelukt een werkende backup terug te zetten, gemaakt met 1-Click-Upgrade.

 

Het volgende uitgevoerd:

- uit de admin/autoupgrade/backup-folder het bestand auto-backupfiles gedownload

- uitgepakt

- geupload met Filezilla (alle bestanden overschrijven)

- en weer een normaal werkende Prestashop versie 1.6.0.9  :rolleyes:

Share this post


Link to post
Share on other sites

Ik via de webservices een koppeling maken tussen PrestaShop en ons orderadministratie systeem.

Omdat  er sprake is van meerder voorraadplaatsen (warehouses) hebben wij "geavanceerd voorraadbeheer" aangevinkt.

Het uitvragen van de actuele voorraad lukte na veel zoeken op het net via de tabel stock_availables.

Maar hoe zelf de voorraad per voorplaats te muteren heb ik nergens kunnen vinden.

Wie weet raad?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More