Jump to content
Sign in to follow this  
contrebasse39

transfert local serveur page blanche

Recommended Posts

Bonjour,

Cela fait plusieurs soirées que je cherche pourquoi lorsque je transfere les fichiers de mon ordi vers le serveur cela me donne une page blanche.Alors qu'il fonctionne parfaitement en local.

J'ai essayé de configurer le setting.inc qui m'a l'air juste ainsi que le .htaccess ???
Je fonctionne avec le dernier prestashop 1.3.0

Quelqu'un a une idée?

Merci

Fabrice

Share this post


Link to post
Share on other sites

Bonjour

Est-ce que l'url rewriting est activé ?
l'interface d'administration est accessible ?
Le poids des fichiers à part quelque kilooctet près correspond-il au poids sur le pc ?

Le setting.inc c'est juste pour accéder a la base de donnée de l'hébergement les informations doivent être juste.
Le site est-il à la racine ou dans un dossier ?
Si à la racine cette ligne doit être : define('__PS_BASE_URI__', '/'); juste avec le slash
Si dans un dossier : define('__PS_BASE_URI__', '/prestashop/');

Share this post


Link to post
Share on other sites

Juste une précision.

Concernant le PS_BASE_URI, je suis d'accord sur le principe mais il peut exister des exceptions.

Par exemple, j'ai créé un virtualhost qui pointe déjà sur mon répertoire toto, donc mon PS_BASE_URI est "/" et non "/toto/".

Voilà juste pour information.

Oggy

Share this post


Link to post
Share on other sites
Juste une précision.

Concernant le PS_BASE_URI, je suis d'accord sur le principe mais il peut exister des exceptions.

Par exemple, j'ai créé un virtualhost qui pointe déjà sur mon répertoire toto, donc mon PS_BASE_URI est "/" et non "/toto/".

Voilà juste pour information.

Oggy


Re:

:question: Je comprends rien du tout sur cette remarque, je vois même pas ce quelle viens faire ici :question:

Je pose une question vu que contrebasse39 ne donne pas de précision, et sans savoir comment est sa configuration
on ne peut pas aidé. Ne mélangeons pas les techniques merci.

Et je sais pas de quel manière il a configurer le .htaccess, s'il l'as fait manuellement copier coller ou générer avec le générateur pretashop.

Share this post


Link to post
Share on other sites

Oron,

je faisais juste une remarque par rapport à votre dernier paragraphe

Le setting.inc c’est juste pour accéder a la base de donnée de l’hébergement les informations doivent être juste.
Le site est-il à la racine ou dans un dossier ?
Si à la racine cette ligne doit être : define(’PS_BASE_URI‘, ‘/’); juste avec le slash
Si dans un dossier : define(’PS_BASE_URI‘, ‘/prestashop/’);


Je dis juste qu'il faut faire attention, c'est tout.

Pas besoin de sortir les griffes^^

Et pour répondre à la question posée (problème de page blanche), j'ai déjà fait plusieurs post sur le sujet.
1. Vérifier que vous êtes bien sous PHP5. Pour le savoir, faire un fichier php5test.php avec le code suivant :
<?php
phpinfo();
?>


2. lancer url http://monsite.com/php5test.php.
3. Vous serez si vous êtes en php5.
4. Si ce n'est pas le cas, regarder le post sur les installations en fonction des hébergeurs (soit paramètres à ajouter, soit demander à votre hébergeur de passer sous PHP5).

Oggy

Share this post


Link to post
Share on other sites
Oron,

je faisais juste une remarque par rapport à votre dernier paragraphe
Le setting.inc c’est juste pour accéder a la base de donnée de l’hébergement les informations doivent être juste.
Le site est-il à la racine ou dans un dossier ?
Si à la racine cette ligne doit être : define(’PS_BASE_URI‘, ‘/’); juste avec le slash
Si dans un dossier : define(’PS_BASE_URI‘, ‘/prestashop/’);


Je dis juste qu'il faut faire attention, c'est tout.

Pas besoin de sortir les griffes^^

Et pour répondre à la question posée (problème de page blanche), j'ai déjà fait plusieurs post sur le sujet.
1. Vérifier que vous êtes bien sous PHP5. Pour le savoir, faire un fichier php5test.php avec le code suivant :
<?php
phpinfo();
?>


2. lancer url http://monsite.com/php5test.php.
3. Vous serez si vous êtes en php5.
4. Si ce n'est pas le cas, regarder le post sur les installations en fonction des hébergeurs (soit paramètres à ajouter, soit demander à votre hébergeur de passer sous PHP5).

Si le problème ne vient pas de là, on cherchera ailleurs ;)

Oggy

Share this post


Link to post
Share on other sites

Merci de vos réponses,

Voici ce que j'ai tenté :

accéder à l'interface d'administration : oui
Pour define('__PS_BASE_URI__','/'); : j'avais une erreur
Pour le poids des fichiers, il y a quelques octets de différences sur les bases de donnée
Pour ce qui est de l'URL Rewriting : J'ai utilisé http://forum.ovh.com/showthread.php?t=45529

Et en effet ça bouge, je n'ai plus une page blanche mais :
Link to database cannot be established.

J'ai vérifié les noms de la base de donnée, l'utilisateur ... apparemment c'est bon. Juste que j'ai choisi le même nom pour la base de donnée et l'utilisateur.

Je fonctionne sur ovh mysql5.1 start

Je suis bien en php 5.2.12, je l'ai vérifié avec votre fichier phpinfo

je vous transmet une copie du setting.inc ainsi que du htaccess

setting.inc

<?php
define('_DB_SERVER_', 'mysql5-1.start');
define('_DB_TYPE_', 'MySQL');
define('_DB_NAME_', 'xxxxxx');
define('_DB_USER_', 'xxxxxx');
define('_DB_PASSWD_', 'xxxxxxx');
define('_DB_PREFIX_', 'ps_');
define('__PS_BASE_URI__','/');
define('_THEME_NAME_', 'prestashop');
define('_COOKIE_KEY_', 'YX7s9DzJjok6V5Huy0UqUGky3NqqWh1QSsqo2hNgKbVXEbhKfRnR2ZiL');
define('_COOKIE_IV_', 'oZ0A6U7h');
define('_PS_CREATION_DATE_', '2010-01-27');
define('_PS_VERSION_', '1.3.0.1');
?>

htaccess

SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0

# 1. URL rewriting module activation
RewriteEngine on

# 1. URL rewriting rules
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.)$ product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-])\.html(.)$ product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-])(.)$ category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-])(.)$ cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-])(.)$ supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-])(.*)$ manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]

# 1. Catch 404 errors
ErrorDocument 404 /404.php

Merci pour vos remarques

Share this post


Link to post
Share on other sites

Bonjour

Link to database cannot be established.

J’ai vérifié les noms de la base de donnée, l’utilisateur … apparemment c’est bon. Juste que j’ai choisi le même nom pour la base de donnée et l’utilisateur.


L'erreur est tout simple soit le nom de la base incorrecte ou l'utilisateur ou mot de passe
Eviter de prendre même nom pour base de donnée et utilisateur.

Share this post


Link to post
Share on other sites

Bonjour,

J'ai donc essayé de modifier les noms et OVH semble mettre le même nom pour la base et l'utilisateur.

J'ai donc tout effacé sur phpmyadmin pour repartir à zéro, ce que je n'aurais pas du faire .

- J'ai tenté d'importer mon fichier sql du local vers le serveur et j'ai l'erreur suivante :

requête SQL:

--
-- Base de données: `presta`
--
CREATE DATABASE `presta` DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci;

MySQL a répondu:Documentation
#1044 - Access denied for user 'michaelvopr'@'%' to database 'presta'

- J'ai tenté de créer une base de donnée vierge il me demande de préciser le nombre de champs
si je met 0 il refuse, si je met 1 il me demande de remplir un champ vierge !

Merci pour vos réponses

Fabrice

Share this post


Link to post
Share on other sites

Contrebasse,


Je ne comprends pas tout mais es-tu sur que tu crées une base de données ? J'ai l'impression qu'il te demande de créer une table dans une base de données.

Pas facile de te répondre avec si peu d'éléments mais vérifies si une base de données n'est pas installée par défaut avec ton hébergement.
Si une base est déjà créée, il faut que tu adaptes ton script sql en enlevant la partie liée à la création de la base de données (create database).

Dans tous les cas, tu devrais avoir une console d'administration avec ton hébergement. Une fois dedans, tu dois pouvoir trouver tous les noms que tu cherches (base de données, nom utilisateur base de données, etc)

Oggy

Share this post


Link to post
Share on other sites

Le coup de la page blanche c'est déprimant... mais en fait c'est pas une page blanche c'est juste que l'erreur PHP ne s'affiche pas...

Pour afficher l'erreur :
Dans config/config.inc.php : @ini_set('display_errors', 'on'); // au lieu de off

Ca devrait t'annoncer qu'un dossier n'est pas autorisé en écriture... pour moi c'était le dossier tools/smarty/compile/

Il faut donc le passer en CHMOD 777

et après ça marche (en tout cas pour moi...)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More