Jump to content
mademoisellepolish

Prestashop transfert de local en ligne

Recommended Posts

Bonjour à tous,

 

cela fait deux jours que je désespère à essayer de comprendre ce qui ne va pas.

 

J'ai crée il y a quelques temps ma boutique prestashop en local.

 

Depuis mardi matin, j'essaie de transférer ma boutique en ligne avec un hébergement basic et un nom de domaine sur (hebergement-discount). Cela à juste pour but de tester le site en ligne, il ne s'agit pas de l’hébergement que j'utiliserai par la suite.

 

J'ai donc suivi les différents tutos (comme celui de megavenue):

 

- utiliser filezilla pour transférer mon dossier prestashop sur mon hébergeur.

- créer une base SQL sur le nouveau serveur en important celle que j'avais en local.

- j'ai modifier mon fichier setting-inc dans "configure" et  je l'ai retransmis pour remplacer l'ancier (via Filezilla).

 

Et la je bloque. Je ne sais pas trop quelle URL dois-je utiliser maintenant pour avoir accès au back office, comment appliquer mon nom de domaine dans l'interface de l'hebergeur, dois-je modifier quelque chose dans la zone DNS? etc

 

Lorsque je vais sur l'adresse suivante http://www.NOMDEDOMAINE.BE/prestashop une erreur survient: Link to database cannot be established: SQLSTATE[HY000] [2003] Can't connect to MySQL server on 'ftp.NOMDUSERVEURFTP.be' (111).

 

Je sais que selon l’hébergeur, un tas de truc est différent, merci d'avance donc de votre aide. 

 

 

PS: Je pense être vraiment nul dans l'utilisation des termes, tout se mélange dans ma tête.

 

 

Share this post


Link to post
Share on other sites

Bonjour,

 

C'est un message d'erreur de connexion à la base de données.

 

Tu as bien modifié config/settings.inc.php

 

define('_DB_SERVER_', 'le_serveur_sql');
define('_DB_NAME_', 'le_nom_de_la_base');
define('_DB_USER_', 'le_nom_d_utilisateur');
define('_DB_PASSWD_', 'le_mot_de_passe');

 

ftp.NOMDUSERVEURFTP.be n'est pas le nom du serveur sql

Edited by Pilou.biz (see edit history)

Share this post


Link to post
Share on other sites

Merci de votre réponse.

 

En effet, j'ai bien modifier le setting.inc.php. Peut être ai-je fais une erreur? Déjà je pense au DB server, je vais le remplacer par localhost (si je ne me trompe pas).

 

define('_DB_SERVER_', 'ftp.*******.be'); A remplacer par define('_DB_SERVER_', 'localhost')
define('_DB_NAME_', 'NOMDELABASEPHP');
define('_DB_USER_', 'NOMDUTILISATEUR');
define('_DB_PASSWD_', '****');
define('_DB_PREFIX_', 'ps_');
define('__PS_BASE_URI__', '/prestashop/');
define('_MYSQL_ENGINE_', 'InnoDB');
define('_PS_CACHING_SYSTEM_', 'CacheMemcache');
define('_PS_CACHE_ENABLED_', '0');
define('_MEDIA_SERVER_1_', '');
define('_MEDIA_SERVER_2_', '');
define('_MEDIA_SERVER_3_', '');
Edited by mademoisellepolish (see edit history)

Share this post


Link to post
Share on other sites

En essayant d'accéder à mon back office (http://www.NOMDUDOMAINE.BE/admin3830 je me retrouve avec:

Non Trouvé

Le document demandé n'a pas été trouvé sur ce serveur.

 

 

 

Pour www.NOMDUDOMAINE/prestashop/

 

Link to database cannot be established: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

 

Ça devient vachement lourd. J'ai pourtant tout respecté au niveau des étapes :(

Share this post


Link to post
Share on other sites

Pour accéder à l'admin, tu dois taper www.nomdedomaine/prestashop/admin3830 mais de toutes façons, il faut d'abord régler le soucis d'accès à la base

 

L'adresse du serveur sql, tu as dû le recevoir de ton hébergeur.

Edited by Pilou.biz (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Pour accéder à l'admin, tu dois taper www.nomdedomaine/prestashop/admin3830 mais de toutes façons, il faut d'abord régler le soucis d'accès à la base

 

L'adresse du serveur sql, tu as dû le recevoir de ton hébergeur.

Mille mercis!!!!! Mon erreur était bien pour le serveur SQL je le voyais passer devant le bout de mon nez mais je ne pensais pas que c'était ça! Dire que j'ai perdu des heures pour une bétise ralalala 

 

En tout cas, merci de votre patience! :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More