Jump to content
mrbenek

PayU v2.1.6.6 - Problem po instalacji

Recommended Posts

Witam!

 

Zainstalowałem najnowszy moduł PayU ze strony https://github.com/PayU/plugin_prestashop

 

Mam umowę z PayU wszystko wygląda ok, wszystkie parametry sprawdzane kilkakrotnie. 

 

Niestety nie da się dokonać płatności, gdy klikam płace z payu wyskakuje coś takiego:

 

PODSUMOWANIE ZAMÓWIENIA

An error occurred while processing your order.

« Wróć

 

 

Zainstalowana presta 1.6.0.9

 

Proszę o pomoc

Share this post


Link to post
Share on other sites

Pisz do payU ich moduł jest chyba do v1.5, też go ostatnio instalowałem i były problemy.

Share this post


Link to post
Share on other sites

Już pisałem i dostałem taką odpowiedź:

 

Jeżeli Posiadają Państwo nasz najnowszy moduł i problem nadal wysteruje najprawdopodobniej oznacza to, że posiadają Państwo nie aktualne biblioteki Curl'a które nie obsługuje protokołu TLS.

 

napisałem potem żeby udzieli więcej informacji to dostałem coś takiego:

 

 

W tej sprawie prosimy się kontaktować z Pana administratorem/informatykiem.

Share this post


Link to post
Share on other sites

Moduł PayU version = '2.1.6.8' na pewno działa prawidłowo z prestashop 1.6.

 

1. Sprawdź działanie modułu na sadboxie.

Ustawienia środowiska

Id punktu płatności: 145227

Drugi klucz MD5: 13a980d4f851f3d9a1cfc792fb1f5e50

Jest to środowisko testowe, można płacić do woli. :)

 

2. Jeśli nadal jest lipa, sprawdź konfigurację serwera.

- W katalogu głównym sklepu stwórz plik phpinfo.php

- Wpisz mu zawartość:

<?php
phpinfo();
?>

- Wywołaj plik: http://domena_twojego_sklepu/phpinfo.php

- Sprawdż czy w Registered Stream Socket Transports jest wpis tls

- Sprawdź czy masz sekcję curl, a w niej cURL support: enabled

Share this post


Link to post
Share on other sites

Po wpisaniu idu i klucza co podałeś dalej to samo.

 

Wpisy które podałeś też są

 

Jakieś inne propozycje?

 

 

Może mam to źle ustawione:

Adres powrotu - błąd: www.smpelektro.com.pl/
Adres powrotu - poprawnie: www.smpelektro.com.pl/modules/payu/confirmation.php
Adres raportów: www.smpelektro.com.pl/modules/payu/transaction_status.php
 
nie ukrywam tych plików nie ma w katalogu modułu
Edited by mrbenek

Share this post


Link to post
Share on other sites

Masz zainstalowany moduł typu ship2pay, albo Payments2Carriers.

Odinstaluj ten moduł całkowicie z presty i zrób test płatności payu.

Share this post


Link to post
Share on other sites

Przeciez dla tej wersji modułu payU nie trzeba ustawiać adresów powrotu, trzeba mieć w PayU ustawiony  tryb pracy typu Checkout

Share this post


Link to post
Share on other sites

Spróbuj jeszcze przetestować zamówienie w 5 krokach.

Sporo modułów ma problemy z OPC.

Chociaż u mnie pauy działa poprawnie w opc.

 

I rozwiązanie radykalne do testu:

1. Wyłącz wszystkie moduły nie od presty i zostaw tylko payu.

2. Zrób test zamówienia i płatności.

3. Jeśli test wypadnie OK, szukaj winnego modułu :)

Share this post


Link to post
Share on other sites

Problem mam ten sam.

Yabber wyłączyłem moduł shipToPay teraz nigdzie mi się nie wyświetla PayU oprócz tego, że mogę go wysukać w Modułach i przejść do konfiguracji. W moduły --> Płatność nie ma tego PayU.

Mam wersję modułły PayU 2.1.6.8, ship to pay, Payments2Carriers

Share this post


Link to post
Share on other sites

Modul PayU dla Prestashop musi byc skonfigurowany jako opcja CHECKOUT. Tak skonfigurowane PayU bedzie dzialac prawidlowo. Przerabialem to kilka dni temu dla wersji 1.5.x

Share this post


Link to post
Share on other sites

Witam,

Piszę tutaj bo również mam problemy z uruchomieniem modułu PayU :( w związku ze zmianami protokołu na TLS.

Posiadamy PrestaShop w wersji 1.5.6. Odinstalowałem stary moduł PayU. Pobrałem i zainstalowałem moduł PayU w wersji 2.1.6.6. Po zainstalowaniu wpisałem Id punktu płatności oraz Drugi klucz MD5. Punkt płatności mam skonfigurowany w PayU jako: Checkout - Protected Payment.

Sprawdziłem plikiem phpinfo.php

- czy w Registered Stream Socket Transports jest wpis tls - jest OK

- czy masz sekcję curl, a w niej cURL support: enabled - jest OK

 

Nie mam zainstalowanych moduł typu ship2pay, albo Payments2Carriers

 

Przy próbie płatności na stronie sklepu pojawia mi się biała strona z błędem:

"Połączenie z serwerem zostało zresetowane podczas wczytywania strony.

    Witryna może być tymczasowo niedostępna lub zbyt obciążona. Spróbuj ponownie za kilka minut.
    Jeśli nie można otworzyć żadnej strony, należy sprawdzić swoje połączenie sieciowe.
    Jeśli ten komputer jest chroniony przez zaporę sieciową lub serwer proxy, należy sprawdzić, czy program Firefox jest uprawniony do łączenia się z Internetem."

 

Dodam, że nie jestem biegły w konfiguracji sklepu i instalacji modułów - sklep interentowy przejąłem w spadku po moim poprzedniku.

Prosze bardzo o pomoc.

Share this post


Link to post
Share on other sites

Modul PayU dla Prestashop musi byc skonfigurowany jako opcja CHECKOUT. Tak skonfigurowane PayU bedzie dzialac prawidlowo. Przerabialem to kilka dni temu dla wersji 1.5.x

 

możesz podać krok po kroku gdzie się checkout ustawia bo ja mam białą stronę jak wybieram formę płatności  PAYU - mam wersje modułu PayU v1.6 - by PageMaster.pl

 

wersja presty 1.6

 

o masakra

Share this post


Link to post
Share on other sites

Moduł PayU version = '2.1.6.8' na pewno działa prawidłowo z prestashop 1.6.

 

1. Sprawdź działanie modułu na sadboxie.

Ustawienia środowiska

Id punktu płatności: 145227

Drugi klucz MD5: 13a980d4f851f3d9a1cfc792fb1f5e50

Jest to środowisko testowe, można płacić do woli. :)

 

2. Jeśli nadal jest lipa, sprawdź konfigurację serwera.

- W katalogu głównym sklepu stwórz plik phpinfo.php

- Wpisz mu zawartość:

<?php
phpinfo();
?>

- Wywołaj plik: http://domena_twojego_sklepu/phpinfo.php

- Sprawdż czy w Registered Stream Socket Transports jest wpis tls

- Sprawdź czy masz sekcję curl, a w niej cURL support: enabled

 

 

skad ten modul mozna pobrac ?

Share this post


Link to post
Share on other sites

pobierz najnowszą z github.com/PayU/plugin_prestashop/releases

pobrałem 2.1.8 ale po dodaniu modulu nie widac go

Share this post


Link to post
Share on other sites

pobrałem 2.1.8 ale po dodaniu modulu nie widac go

Rozpakuj paczkę z githuba.

W środku jest katalog "payu". Spakuj go. I to instaluj.

  • Like 1

Share this post


Link to post
Share on other sites

Witam,

 

podbiję wątek. 

Mam problem z Presta 1.6.0.11 oraz PayU 2.1.8.

Mianowicie zakupy w PLN idą bez problemu - przekierowanie i jest ok.

W przypadku Euro mam problem jak w pierwszym poście.

Waluty obie zdefiniowane i dopuszczone, ceny produktów zdefiniowane. 

Wymagania PayU spełnione (cUrl, hash, XMLwriter i reader), gość dopuszczony.
 

Podsumowanie zamówienia

An error occurred while processing your order.

 

Pozdrawiam

Leszek

Edited by legrooch

Share this post


Link to post
Share on other sites

Podbiję temat. Mam Prestę 1.6.0.9., moduł Payu wersja 2.x. Wszystko hula dopóki presta operuje po polsku. Po przełączeniu języka na angielski przy próbie płatności wyrzuca błąd. Macie jakieś pomysły, gdzie szukać przyczyny?

Pozdrawiam

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More