Jump to content

Cambio de password update¡


Tecniloco
 Share

Recommended Posts

Bueno, pues hay quedado la puntualizacion, para futuros usuarios que vayan a usar el parche y antiguos usuarios que usaron el parche en el pasado.

 

Gracias por colaborar con la Comunidad de Prestashop.

Un afectuoso saludo Victor.

Gracias por tu labor.

Share this post


Link to post
Share on other sites

  • 4 weeks later...

Bueno, pues yo experimento un problema parecido.

La contraseña la restauro, pero no es problema porque es correcta la que usaba y el usuario también.

El problema es que, aún usando bien la contraseña, el usuario y habiendo limpiado correctamente la caché del navegador no logro avanzar de la pantalla de login para el back office.

No me da error, simplemente no entra incluso he llegado a renombrar la carpeta de administración, como alguien hizo, pero tampoco arreglo nada.

El front office no sé si funciona bien, porque como tengo la tienda inactiva sólo sale el mensaje de que está desactivada (pero eso funciona bien).

La cuestión viene que actualicé desde una versión 1.4.6.3 a una 1.4.1.0 automáticamente y todo bien, supongo, porque parecía funcionar todo. No actualicé módulos de terceros para evitar problemas (eso lo haré luego).

Hecho esto he querido pasar a la 1.5.4.1 automáticamente y me ha dado varios errores en la actualización, pero supongo que ese no es el problema (espero) porque se refería a módulos incompatibles y alguna cosa más que supongo que será lo normal en una actualización de dos sistemas a priori diferentes. (1.4 y 1.5)

En cuanto al módulo de actualización automático tengo la última versión (os ahorro la respuesta).

La tienda tiene activado '_PS_CACHING_SYSTEM_', 'MCached' y lo digo por si acaso, pues esto tiene algo que ver con caché supongo.

He habilitado la depuración de errores, pero no me sale ninguno cuando intento logearme.

Bueno, en resumen, que a ver si alguien arroja algo de luz en este entuerto.

Gracias.

Edited by Xeral (see edit history)

Share this post


Link to post
Share on other sites

Parece que he dado con una posible solución y el error.

La realidad es que en la base de datos en el campo PS_SHOP_DOMAIN aparecía el nombre del dominio de la tienda y entre restauraciones de bases de datos y otras acciones en algún momento restauré la base de datos y no le cambié ese campo.

Utilizaba el dominio sin www.------- y haciendo pruebas, en una de esas, con www.---- (tanto en la base de datos como en la barra de dirección del navegador) entró.

Al activar la tienda con el modo errores activado me salen mil errores en el front office, con lo cual, voy a actualizar todo otra vez desde el principio con la base de datos bien optimizada y veremos qué pasa y os lo cuento.

Share this post


Link to post
Share on other sites

Nada, esto no va ni a tiros.

He probado actualizando a mano, pero me da error de tiempo de ejecución, cosa que me esperaba.

Luego he intentado actualizar directamente desde la 1.4.6.3 a la 1.5.4.1 (vaya machada!) y claro, como que logro ver el BO y el FO de alguna manera rara y en alguna plantilla aunque curiosamente en la plantilla por defecto no.

Vamos, que esto de actualizar va siendo una odisea así que a lo mejor me quedo en la 1.4.1.0 y ya veremos.

Tengo varias instalaciones de la 1.5.3 y van muy bien pero siempre he hecho instalaciones puras, nunca actualizaciones por encima de la 1.4.1.0 y hasta ahí bien.

Share this post


Link to post
Share on other sites

Nada, esto no va ni a tiros.

He probado actualizando a mano, pero me da error de tiempo de ejecución, cosa que me esperaba.

Luego he intentado actualizar directamente desde la 1.4.6.3 a la 1.5.4.1 (vaya machada!) y claro, como que logro ver el BO y el FO de alguna manera rara y en alguna plantilla aunque curiosamente en la plantilla por defecto no.

Vamos, que esto de actualizar va siendo una odisea así que a lo mejor me quedo en la 1.4.1.0 y ya veremos.

Tengo varias instalaciones de la 1.5.3 y van muy bien pero siempre he hecho instalaciones puras, nunca actualizaciones por encima de la 1.4.1.0 y hasta ahí bien.

Has intentado convertir en MD5 como explico en el post - #26 -

Hola.

La verdad es que el procedimiento para cambiar la contraseña de acceso al BO. " cuantas veces querais " es bastante sencillo, yo tambien lo pasé mal cuando empezaba con Prestashop, y me ocurrió lo mismo.

Tuve la suerte de tener la asistencia de Patric Codron, miembro del Equipo Prestashop France quien me solucionó el problema inmediatamente, a quien agradezco desde aquí.

 

Lo primero es abrir con vuestro FTP, yo uso FILEZILLA, en el archivo CONFIG./seetings.inc.php , teneis esta linea ej.

 

define(’COOKIE_KEY‘, ‘stg2lmfgtGTuaK8JA6HjkKD5AHG00wyhcFbBy2tRjMrsFKmRFNEEhFes’);

 

Es la cookie que genera el password para el acceso al BO.

 

Abris vuestro explorer en esta pagina : http://www.md5.fr/

 

Y copiais el codigo entrecomillado agregando vuestra nueva contraseña ej.

 

stg2lmfgtGTuaK8JA6HjkKD5AHG00wyhcFbBy2tRjMrsFKmRFNEEhFesnuevacontraseña

y convertís el codigo en MD5.

 

Abrís vuestra base de datos y en la tabla PS_EMPLOYEE borrais el antiguo codigo y le pegais el nuevo que habreis obtenido con el MD5, actualizais, cerrais la BD. y accedeis a vuestra tienda con el nuevo PASSWORD GENERADO.

Así de facil, espero haber sido útil.

 

Cecilia, mira si tienes un Back-up de tu base de datos anterior al fallo, y cámbiala por la que tienes ahora, haciendo una copia de la actual evidentemente, haber si recuperas los productos.Tendrías que cambiar tambien en la tabla ps_employe, el codigo de contraseña.

Share this post


Link to post
Share on other sites

Os comento una manera, mas sencilla de recuperar la contraseña del back-office

 

Descomprime este fichero: http://www.prestasho...attach_id=57621 , y sube la carpeta /password/ a tu tienda, despues desde el navegador entras a tu url /password/ y hay podrás cambiar tu contraseña y restaurarla.

 

Un Saludo,

 

------------------------------------------------------------------------------------------------------------------

 

---- Edito mensaje y añado fuente de la modificación ---

 

http://www.webbax.ch/blog/

 

-----

 

Me acabo de registrar, y este aporte me parece muy útil.

 

Muchas Gracias Nadie !

Share this post


Link to post
Share on other sites

Me acabo de registrar, y este aporte me parece muy útil.

 

Muchas Gracias Nadie !

 

Un placer ayudarte y servirte!

 

Un saludo y recuerda que estaremos en el foro, para guiarte por este mundo oscuro y tenebroso.

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More