Jump to content
rv31

boucle de redirection sur le back office

Recommended Posts

Bonjour

 

Je viens de migrer mon site local vers le serveur. Pour cela j'ai copié tous mes fichiers local vers mon serveur, recopié les tables de la BDD via php my admin.

j'ai modifié les URL dans la table shop_url.

mais quand je me connecte à mon back office , chrome m'indique que le chargement est impossible car la page web présente une boucle de redirection.

au début j'avais page blanche sur le front, c'était lié a un paramètre des dossiers qui n'avait pas d'autorisation d'écriture.

Une fois ce souci régler j'ai maintenant accès à la home page mais aucun lien ne fonctionne.

Je n'ai pas coché l'option réécriture URL.

Je précise que je suis sur un serveur dédié d'OVH. Mais  avant d'alerter l'administrateur réseau et de lui dire de vérifier sa config, je voulais savoir si ces soucis venaient plutôt de la config prestashop.

Share this post


Link to post
Share on other sites

Bonjour

 

Faites un test en supprimant complètement le fichier .htaccess

Share this post


Link to post
Share on other sites

je n'ai pas de fichier .htaccess.Je ne l'avais pas transférer au départ.

J'ai tenté de le remettre après mais il n'apparait pas dans la liste une fois transférer.

Mon problème ne viendrait pas de là?

je créé mon site dans un sous répertoire d'un site existant.

Share this post


Link to post
Share on other sites

Ah, alors le problème vient de votre config serveur.

Votre domaine doit pointer vers ce sous-répertoire et votre config seo doit tenir compte aussi de ce dernier /repertoire/sous-repertoire/

A voir dans votre panel admin serveur, le problème vient de là

En règle générale il vaut mieux un répertoire par domaine, plutot que des sous-répertoires...

Share this post


Link to post
Share on other sites

la direction de mes repertoires sont bonnes.

J'ai créer un site boutique, dans un répertoire boutique du site (http://www.lelokalproduction.com/boutique).

J'ai changé l'URL directement dans la table shop_url, puisque je n'ai pas accès à mon backoffice.

Quand je pointe http://www.lelokalproduction.com/boutique j'ai bien la home page boutique qui s'affiche mais les liens ne fonctionnent pas.

Share this post


Link to post
Share on other sites

Oui curieux on dirait que les paramètres en GET ne sont pas pris en compte et que toute page est redirigée d'office vers boutique/index.php

Vous n'avez pas rajouté une redirection ?

Share this post


Link to post
Share on other sites

j'ai résolu mon problème. ceal venait du fait que le répertoire de presta était dans un CMS qui gérait le site.

J'ai mis presta dans un sous domaine donc en dehors du CMS et ça fonctionne.

Merci pour votre aide.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More