en Jump to content
  • 0
Brænde1

How to fix error in cache?

Question

Hi there,

 

I went to my modules menu to install a newly bought module. 

 

I experience this error line (repeated about 40 times) in top of the page which makes it hard work on the modules page.

 

Warning: xcache_set(): XCache var cache was not initialized properly. Check php log for actual reason in /home/braendes/public_html/classes/cache/CacheXcache.php on line 46

 

What can I do to fix it?

 

Best regards,

 

Christian

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Your problem is not with prestashop, but the runtime environment of your server / host.

I don't know what meebox is using for their web hosting - except that they say that they run PHP version 5.5.

xcache runs from PHP 5.1 and up, so thats OK.

 

You probably need someone with unix experience to help you. You need to find the location of the two php (log and ini) files, and to edit the ini file, and you need write access to the server.

 

Show this to meebox, and they may fix in in just a minute or two.

 

But I only give it at 50% chance that this alone will cure it. Ask the developers of the module in question, if they can give you some advice. What module is it?

 

​BTW: meebox updater fromPHP 5.4 to 5.5 on oct. 1. - that might have effected some of your modules. Check all modules on your prestashop for PHP 5.5 compatibility.  

Edited by TorbenRune

Share this post


Link to post
Share on other sites
  • 0

This is an error message from the PHP.

Take a look in the PHP error log file.

If you are on a standard ubuntu the php log file is here:  /var/log/apache2/error.log.

 

The PHP parameter file in standard ubuntu is here:  /etc/php5/apache2/php.ini

 

In the php.ini file, find this section:

 

; XCACHE
626 [xcache-common]
627 zend_extension=/usr/lib/php5/20060613/xcache.so
628 
629 [xcache-admin]
630 xcache.admin.enable_auth = On
631 xcache.admin.user = "user"
632 xcache.admin.password = "********"
633 
634 [xcache]
635 xcache.shm.scheme = "mmap"
636 xcache.size = 128M
637 xcache.count = 4
638 xcache.slots = 8K
639 xcache.ttl = 0
640 xcache.gc_interval = 0
 
And put in an adequate number for size as in the example in line 636. 
 
Check if your server meets the requirements for the module, especially the running version of PHP. 
 
PLEASE! You have posted this question also on the danish forum. It's ok to do that, but you should make a note of it in both fora.
 
Edited by TorbenRune

Share this post


Link to post
Share on other sites
  • 0

Hi Torben,

 

Ok, I shall remember to note if I post in more than one language.

 

I couldn't find php.ini...I have a 1.6.0.9 version and my control system is meebox cpanel.

 

I went to "Advanced Parameters", "performance" and unchecked the xcache and chose file system as cache and the error disappeared.

But I have a feeling that I am missing an opportunity by not using the xcache?

 

Best regards,

 

Christian

Share this post


Link to post
Share on other sites

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More