Jump to content
Sign in to follow this  
dakrcz

[SOLVED / VYRESENO] upgrade error 1.1.0.5 -> 1.2.5 -> svn (1.3.0.1)

Recommended Posts

Zdravim pokousim se o upgrade 1.1.0.5 na posledni 1.2.5 ale haze mi to 4x sql error.
Nikde jsem nenasel co stim. :(
Diky za radu.

---

INSERT INTO ps_tab_lang (id_lang, id_tab, name) ( SELECT id_lang, (SELECT id_tab FROM ps_tab t WHERE t.class_name = 'AdminMessages' LIMIT 1), 'Customer messages' FROM ps_lang)

(1062) Duplicate entry '59-3' for key 1

---

INSERT INTO ps_tab_lang (id_lang, id_tab, name) ( SELECT id_lang, (SELECT id_tab FROM ps_tab t WHERE t.class_name = 'AdminTracking' LIMIT 1), 'Tracking' FROM ps_lang)

(1062) Duplicate entry '60-3' for key 1

---

INSERT INTO ps_tab_lang (id_lang, id_tab, name) ( SELECT id_lang, (SELECT id_tab FROM ps_tab t WHERE t.class_name = 'AdminSearchEngines' LIMIT 1), 'Search Engines' FROM ps_lang)

(1062) Duplicate entry '61-3' for key 1

---

INSERT INTO ps_tab_lang (id_lang, id_tab, name) ( SELECT id_lang, (SELECT id_tab FROM ps_tab t WHERE t.class_name = 'AdminGroups' LIMIT 1), 'Groups' FROM ps_lang)

(1062) Duplicate entry '63-3' for key 1

---

Share this post


Link to post
Share on other sites

to pise kdyz je v databazi neco co uz tam je a ty to tam cpes znovu...tezko to opravovat je to primo ve skriptu pro instalaci, aktualne je doporucene vzit SVN verzi(a instalovat/updatovat ji) nebo aktualizovat na nekterou nizsi ktera ma v poradku instalator(a pak postupne to co nefunguje nahrazovat ze SVN-nicmene aktualne jsou uz v svn zmeny i v databazi...)

Share this post


Link to post
Share on other sites
SVN verze je vyvojova ne ? to se da normalne pozit ?



no "použít" se dá ale jak říkám minulý týden došlo k zásadní změně i v databázi takže pokud někdo použije svn verzi měl by ji použít komplet...údajně to má už i změny v db a je potřeba prestu možná komplet přeinstalovat...no pokud máš funkční 1.1final tak zatím neaktualizuj (nevim to jistě ale snad verze 1.2.1 nebo 1.2.3/4 maj opravený ten instalátor)

Share this post


Link to post
Share on other sites

neni to opraveny ani v 1.2.5

vyzkousel jsem i svn (1.3.0.1) dela to porad - neni to tim jak se tam rve cestina sql importem??

Ja potrebuju jen opravit poskozenou instalaci presty samozrejme se zachovanim zbozi lidi objednavek atd
co vsechno se musi zalohovat? jak sem se koukal tak skoro vsechno :)

Share this post


Link to post
Share on other sites
neni to opraveny ani v 1.2.5

vyzkousel jsem i svn (1.3.0.1) dela to porad - neni to tim jak se tam rve cestina sql importem??

Ja potrebuju jen opravit poskozenou instalaci presty samozrejme se zachovanim zbozi lidi objednavek atd
co vsechno se musi zalohovat? jak sem se koukal tak skoro vsechno :)



proste mas v databazi v tech tabulkach duplicitni zaznam nebo je v instalatoru ten prikaz dvojite(muzes zkusit tyhle insterty co ti to vyhodi odstranit ale samozrejme zalohuj!!!)Precti si navod na update!Je lepsi to zazalohovat vsechno...

Share this post


Link to post
Share on other sites

Uz vcera sem to vyresil staci kompletne odebrat cestinu a jede to bez chyb.

Ale objevil se mi problem ze se nemuze prihlasit zakaznik :)


edit:

Nemusi se odebirat cela cestina (odebrani jazyka zpusobi oderani vsech ceskych textu) pouze se odeberou z tabulky ps_tab_lang 4 radky s id ceskeho jazyka (cz vetsinou id 3) ktery tam sou navic.

Radky :
59 - Zákaznické zprávy
60 - Stopování (mapování)
61 - Vyhledávací engines
63 - Skupiny

Potom uz probehne upgrade bez problemu.

Share this post


Link to post
Share on other sites

hm no tak co takhle proste aby si vygenerovali novy heslo?...zkrat to v administraci na 1 minutu to generovani aby jim to prislo hned a mas to...

Share this post


Link to post
Share on other sites

To nic neresilo.

Chovalo se to tak ze kdyz si dal zbozi do kosiku a nasledne si dal ze ho chces koupit tak se zbozi z kosiku vymazalo a presmerovalo te to na prihlasovaci stranku kde se prihlasit neslo - kdyby to hodilo error tak nic nereknu ale nedelalo to nic :)

Vyresila to reinstalace modulu kosiku.

Share this post


Link to post
Share on other sites

tak to sem rád...podle nadpisu jste nakonec pouzil i svn verzi-vzhledem k tomu ze vydavaji spatny finalni balicky tak je to asi aktualne nejlepsi mozny reseni krome pouziti verze 1.1 ktera ma mouchy ale ne tak velky :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More