Jump to content
patrmich

Avertissements module - base de données, après mise à jour

Recommended Posts

Bonjour,

Ma boutique active est bâtie sous Prestahsop 1.4.7.0

J'ai fait une mise à jour vers 1.5.6.2, de la boutique (dans un sous dossier du serveur)

Je rencontre le problème suivant dans l'admin :
Administration > Permissions > Editer
Il y a 20 avertissements.

Les avertissements sont du type suivant :
 blockadhome : le module est installé dans la base de données, mais ses fichiers sont soit manquants, soit incompatibles.
blockcategoriestop : le module est installé dans la base de données, mais ses fichiers sont soit manquants, soit incompatibles.

etc..

Sauriez vous ce que signifient ces avertissements ?
Sont-ils gênants pour le fonctionnement de la boutique ?
Faut-il modifier quelque chose dans la base de données ou faut-il ré-installer des modules dans l'admin ?

Merci par avance pour toute aide.

Patrick

Share this post


Link to post
Share on other sites

Bonjour

 

Vous avez surement quelque module qui ne sont pas compatible la version 1.5, donc soit désinstaller complètement ces modules que l'erreur vous indique soit voir avec leur auteur respectif pour une mise à jour.

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci pour votre réponse.

1- Avant de faire la mise à jour (par le module autoupgrade) de la boutique 1.4.7.0 vers 1.5.6.2, j'avais supprimé certains modules

2- Depuis mon précédent post, j'ai ré-installé 4 modules. Cela a fait passer le nombre d’avertissements de 20 à 16 :
Administration > Permissions > Editer
Il y a 16 avertissements.

3- Pour les 16 avertissements restants, je n'ai pas l'intention de ré-installer les modules.

Les avertissemenst sont du type : le module est installé dans la base de données, mais ses fichiers sont soit manquants, soit incompatibles
Je suppose que les avertissements signifient que dans la base de données de la boutique 1.5, figurent des tables ou bien des colonnes créés par les 16 modules qui se trouvaient dans la base de la boutique 1.4.

Sauriez vous si cette supposition est juste ?


Merci à nouveau par avance,

Patrick

Share this post


Link to post
Share on other sites

Bonjour

 

Logiquement selon le message d'erreur (s'il est juste) :)  oui des informations sur les modules sont dans la base de donnée et ils ne les trouvent pas sur le serveur.

Il faudrait repéré les tables des ces modules et les supprimer, même si ça dérange pas niveau client ça va ralentir le fonctionnement vu que le système cherchera plusieurs fois les fichiers. Ce qui va entrainer l'utilisation accrue des ressources jusqu'au jour où votre hébergeur dira nous avons bloquer votre site pour abus de ressources.

 

A partir du moment qu'on a la moindre erreur il faut la corriger.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More