Jump to content
evastore

Page blanche depuis upgrade 1.5

Recommended Posts

Bonjour j'ai une page blanche depuis l'upgrade 1.5

 

j'ai fais afficher l'erreur avec : 

 

define('_PS_MODE_DEV_', true);

 

 

elle indique:

 

Warning: Function display() is deprecated in /homepages/45/d421314061/htdocs/shop/prestashop/classes/controller/Controller.php on line 198
in /homepages/45/d421314061/htdocs/shop/prestashop/classes/Tools.php on line 2280

Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template file '/homepages/45/d421314061/htdocs/shop/prestashop/themes/default-bootstrap/header.tpl'' in /homepages/45/d421314061/htdocs/shop/prestashop/tools/smarty/sysplugins/smarty_internal_templatebase.php:127 Stack trace: #0 /homepages/45/d421314061/htdocs/shop/prestashop/classes/controller/Controller.php(406): Smarty_Internal_TemplateBase->fetch('/homepages/45/d...') #1 /homepages/45/d421314061/htdocs/shop/prestashop/classes/controller/FrontController.php(569): ControllerCore->smartyOutputContent('/homepages/45/d...') #2 /homepages/45/d421314061/htdocs/shop/prestashop/classes/controller/Controller.php(198): FrontControllerCore->display() #3 /homepages/45/d421314061/htdocs/shop/prestashop/classes/Dispatcher.php(373): ControllerCore->run() #4 /homepages/45/d421314061/htdocs/shop/prestashop/index.php(28): DispatcherCore->dispatch() #5 {main} thrown in/homepages/45/d421314061/htdocs/shop/prestashop/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 127

 

 

merci de votre aide

Share this post


Link to post
Share on other sites

Ok c'est bon , mauvaise manip avec le theme par default 

 

merci

Share this post


Link to post
Share on other sites

Salut :)

 

Contente que tu aies résolu ton soucis. Peux-tu marquer ton topic comme résolu stp ? (Retour sur ton post d'origine > Edit > Editeur complet > Rajoute "résolu"dans le titre). Merci ! 

Share this post


Link to post
Share on other sites

J'allais mettre résolu, mais aprés quelque manips , je tombe sur une erreur du même style:

 

Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template file '/homepages/45/d421314061/htdocs/shop/prestashop/themes/autumn/./.tpl' in '/homepages/45/d421314061/htdocs/shop/prestashop/themes/autumn/./header.tpl'' in /homepages/45/d421314061/htdocs/shop/prestashop/tools/smarty/sysplugins/smarty_internal_templatebase.php:127 Stack trace: #0 /homepages/45/d421314061/htdocs/shop/prestashop/tools/smarty/sysplugins/smarty_internal_template.php(286): Smarty_Internal_TemplateBase->fetch(NULL, NULL, NULL, NULL, false, false, true) #1 /homepages/45/d421314061/htdocs/shop/prestashop/cache/smarty/compile/e8/26/51/e8265137125bd15b53d1fe5c05f32987a26f7512.file.header.tpl.php(203): Smarty_Internal_Template->getSubTemplate('/homepages/45/d...', NULL, NULL, NULL, NULL, Array, 0) #2 /homepages/45/d421314061/htdocs/shop/prestashop/tools/smarty/sysplugins/smarty_internal_templatebase.php(180): content_53b514ff574e50_60708732(Object(Smarty_Internal_Template)) #3 /homepages/45/d421314061/htdocs/shop/prestashop/t in/homepages/45/d421314061/htdocs/shop/prestashop/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 127

Share this post


Link to post
Share on other sites

J'ai essayer de le réinstaller à partir du module installateur, l'erreur est differente:

 

[PrestaShopException]

Votre thème n'est pas disponible : "Autumn.2.3.0". Veuillez vérifier le nom du répertoire du thème et ses permissions.
at line 176 in file classes/controller/FrontController.php

170.         if ($this->auth && !$this->context->customer->isLogged($this->guestAllowed))
171.             Tools::redirect('index.php?controller=authentication'.($this->authRedirection ? '&back='.$this->authRedirection : ''));
172.
173.         /* Theme is missing */
174.         if (!is_dir(_PS_THEME_DIR_))
175.             throw new PrestaShopException((sprintf(Tools::displayError('Current theme unavailable "%s". Please check your theme directory name and permissions.'), basename(rtrim(_PS_THEME_DIR_, '/\\')))));
176.
177.         if (Configuration::get('PS_GEOLOCATION_ENABLED'))
178.             if (($newDefault = $this->geolocationManagement($this->context->country)) && Validate::isLoadedObject($newDefault))
179.                 $this->context->country = $newDefault;
180.

Share this post


Link to post
Share on other sites

Tu as installé le thème par défaut ?

Share this post


Link to post
Share on other sites

il y était, puis je les supprimer ce qui a donner la premier erreur et le l'ai recopier par ftp ensuite

 

 

d'ou le possible problème de permission?

Que dois-je faire?

merci

Edited by evastore (see edit history)

Share this post


Link to post
Share on other sites

Pardon , je me suis trompé dans le titre , c'est depuis l'up en 1.6 le bug

 

Et la page blanche semble ne pas marcher avec un seul thémes,

 

Comment le réinstaller proprement, Sans perdre les images et modification des modules?

 

Est ce possible que cela soit du au fait que j'ai deux version du même thème? Autumn 1.6 et 2.3?

Share this post


Link to post
Share on other sites

Merci pour tes précisions. Je te conseille de tester tout ça avec le thème par défaut. Si le problème n'apparaît plus, c'est que cela vient du thème et qu'il faut que tu contactes directement le développeur de ce thème, car si tu as fais une mise à jour de 1.5 à 1.6, le thème n'est peut-être pas compatible avec la dernière version de PrestaShop.

 

Tiens nous au courant :)

Share this post


Link to post
Share on other sites

le theme est marqué comme compatible , mais je me dis qu'il y a un conflit entre les version du thème, existe il une solution pour le réinstaller proprement?

Share this post


Link to post
Share on other sites

Tu as essayé de supprimé complètement le dossier thème de la version 1.5 via ton ftp ? 

Share this post


Link to post
Share on other sites

oui et même les modules, mais quand je tente de le réinstaller il me dit qu'il est déja installer 

 

j'en suis au point mais je ne sais pas comment faire, de réinstaller prestashop à neuf , (en gardant la database)

 

Y a t'il un autre répertoire ou le thème s'installe?

Edited by evastore (see edit history)

Share this post


Link to post
Share on other sites

Tu avais fait beaucoup de modifications sur ton thème ? Car elles seront perdues.

Sinon ce que je te conseille de faire: supprime tous les thèmes + vide le cache PrestaShop et réinstalle celui par défaut pour voir si tout revient à la normal. Si oui, réinstalle le thème qui correspond à ta version. 

Share this post


Link to post
Share on other sites

j'ai tous supprimer du dossier théme et vider le cache mais dans l'installateur de thème il apparaisse toujours:

 

335791Capturedcran20140703182654.png

Share this post


Link to post
Share on other sites

j'aimerai je pense instaler un prestashop propre mais sans perdre mes produits , est ce possible?

Share this post


Link to post
Share on other sites

Bonjour,

 

Tu peux effectivement faire une installation à neuf, en prenant le soin quand même de faire un back up, puis un un export CSV de tes produits, clients, commandes etc :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More