Jump to content
Sign in to follow this  
denisjoalland

[résolut] erreur BDD mise à jour

Recommended Posts

Bonjour,
J'ai tenté une maj de la version 1.10.5 vers la version 1.2.5 et je rencontre plusieur problème.
1) La maj à rencontrer 3 euureur de maj de la BDD voici le rapport
===================
(`id_order_state`, `invoice`, `send_email`, `color`, `unremovable`, `logable`, `delivery`) VALUES (11, 0, 0, 'lightblue', 1, 0, 0)

(1062) Duplicate entry '11' for key 1
INSERT INTO `ps_order_state_lang` (`id_order_state`, `id_lang`, `name`, `template`) VALUES (11, 1, 'Awaiting PayPal payment', '')

(1062) Duplicate entry '11-1' for key 1
INSERT INTO `ps_order_state_lang` (`id_order_state`, `id_lang`, `name`, `template`) VALUES (11, 2, 'En attente du paiement par PayPal', '')

(1062) Duplicate entry '11-2' for key 1
===============================
2) Je ne peux pas acceder au back office mon adresse mail et mon de passe ne sont pas reconus (pas de message d'erreur). J'ai demander mon mot de pas par mail. Je l'ai reçu, mais il ne marche pas.

3) Le squellette de la boutique est inexistant http://www.partition.amafr.com/shop/

Merci pour vos conseils
Denis

Share this post


Link to post
Share on other sites

Salut,

même soucis pour moi au niveau des erreurs SQL (les même mis a par que j'en ai deux). Je ne sais pas si cela peut creer une incidence par la suite.

Par contre j'accede bien a mon BO.

TU as la solution de generer un mot de passe via Phpmyadmin sinon, il y a une astuce qui traine sur le forum je crois.

Pour ton problème de css, il fraudais que tu arrives a acceder a ton Bo pour cocher la case : theme compatible v1.1 (un truc du genre).

Je pense par contre que la meilleur solution serait d'editer ton ancien theme fichier par fichier pour avoir la meilleur compatibilité possible, mais c'est un travail laborieux ^^ (que je m'apprête a faire d'ailleurs :( ).

J'espère en tout cas que ces erreurs SQL n'ont pas d'effet secondaire ..

Share this post


Link to post
Share on other sites

Merci pour l'info.
J'ai réussis à régler tout les problèmes Sauf un, mais pas très grave. Dans le BO certaines infos, bouton eyc sont en anglais.
Cordialement
Denis

Share this post


Link to post
Share on other sites

Ca serait cool que tu me dise comment tu as géré les erreurs sql plz ^^

Share this post


Link to post
Share on other sites

Pour ne pas prendre de risque avec la MAJ entre le v1.1.05 à la 1.2.5 j'ai réinstallé dans un autre dossier ma premier version avec une copie de la bdd.
C'est sur cette copie de version que j'avais une erreur de de fichier mal trasmis. Je l'ai retélécharger et je n'avais plus qu'une seul erreur SQL, sur la traduction.
Après quelques retouche de mise en page et de permission chmod a mettre en 755 au lieu de 777 (pour le paiement par chèque par exemple) tout remarche. Sauf les petit défaut de traduction. Version 1.2.5 en ligne en fin d'après-midi.
Voila.
Denis

Share this post


Link to post
Share on other sites

Ouaip en faite ces erreurs sont du au statut des commandes. J'en est creer deux dans ma 1.1.0.5, dont une qui a l'ID 11 et la MAJ presta 1.2 en rajoute une dans la même id. (attente du paiement paypal je crois). Du coup cela crée un conflit..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More