Jump to content
Sign in to follow this  
Laurine

Installatation du module prestashop

Recommended Posts

Bonjour à tous !!

Je suis nouvelle sur prestashop.

Je viens d'installer le module prestashop disponible chez OVH.
J'ai lu pas mal de vos topics.

Pour le moment mon site ressemble a : www.site.com/prestashop

Au niveau de mon FT le dossier s'installe donc automatiquement comme ca
www/Prestashop/admin
www/Prestasop/config

ect..

Si je prend les dossiers présent dans mon dossier prestashop et que je les met sous mon "www" plus rien ne fonctionne.

Qu'est ce que j'ai fais de mal ?

Share this post


Link to post
Share on other sites

Bonjour,

Ton souhait serai de mettre la boutique PrestaShop accessible depuis la racine de ton domaine, et non depuis le sous-dossier www.site.com/Prestashop/ ?

Si tel est le cas, je ne te conseil pas d'installer la solution depuis OVH, car assure toi déjà qu'elle est bien la 1.2.5

L'installation normal de Prestashop est la plus judicieuse. Je suppose qu'OVH rend ses modules automatisés, et prend en compte le nom du sous dossier dans leur propre script d'installation (généralement script de mirroring).

Ne te préoccupe pas de ce module proposé par OVH et fait plutôt cette installation par tes soins directement.

A+

Share this post


Link to post
Share on other sites

Oui c'est tout à fais ça !

Bon ben je vais supprimer le module et essayer de faire une installation complète.
Est-il possible d'installer prestashop directement en ligne sur OVH sans avoir besoin de la mettre en local au préalable?

Merci pour votre réponse :)

Share this post


Link to post
Share on other sites

Merci !

Je vais prendre mon courage à deux mains et tenter de faire une installation alors lol.
Merci pour l'astuce :)

Share this post


Link to post
Share on other sites

Je reviens pour avoir vos conseils ..

J'ai réussi à installer prestashop.
Cependant j'ai juste accès à l'admin. Je n'arrive pas à aller sur ma boutique.
Voici le message d'erreur :

The server encountered an internal error or misconfiguration and was unable to complete your request.

Share this post


Link to post
Share on other sites

Oui tout est nouveau et vierge.
Je supprime tout et je relance histoire de voir si un fichier a peut etre ete oublie !

Share this post


Link to post
Share on other sites

J'ai réinstallé le tout. Et malheureusement j'ai toujours le même soucis.

Cela peut peut être provenir du fichier .htaccess ou settings?

Share this post


Link to post
Share on other sites

Voilà mon .htaccess :

SetEnv PHP_VER 5

# URL rewriting module activation
RewriteEngine on
RewriteBase /
SetEnv REGISTER_GLOBALS 0

# URL rewriting rules
RewriteRule ^([a-z0-9]+)\-([a-z0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/p/$1-$2$3.jpg [L,E]
RewriteRule ^([0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/c/$1$2.jpg [L,E]
RewriteRule ^lang-([a-z]{2})/([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$3&isolang;=$1$5 [L,E]
RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2&isolang;=$1$4 [L,E]
RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$2&isolang;=$1 [QSA,L,E]
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ /supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ /manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]
RewriteRule ^lang-([a-z]{2})/(.*)$ /$2?isolang=$1 [QSA,L,E]

# Catch 404 errors
ErrorDocument 404 /404.php

Share this post


Link to post
Share on other sites

Donc tu as utilisé le générateur pour le compléter. Mais avant, tu avais accès au FO ?

Fais-en une copie et supprime tout sauf :

SetEnv PHP_VER 5

Share this post


Link to post
Share on other sites

Non je n ai jamais eu accès à la boutique pour le moment.
J'ai simplement accès à la partie admin.

Je réésaye de le charger.

Share this post


Link to post
Share on other sites

J'ai supprimé et reinstaller tout ça normalement sans modifier quoi que ce soit.

Donc voici mon .htaccess :

# merci OVH

SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0

# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums

# URL rewriting module activation
RewriteEngine on

# URL rewriting rules
RewriteRule ^([0-9]+)\-([0-9]+)(\-[a-zA-Z0-9-]*)/([a-zA-Z0-9-]*)\.jpg$ /prestashop/img/p/$1-$2$3.jpg [L,E]
RewriteRule ^([0-9]+)(\-[a-zA-Z0-9-]*)/([a-zA-Z0-9-]*)\.jpg$ /prestashop/img/c/$1$2.jpg [L,E]
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /prestashop/product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /prestashop/product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /prestashop/category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /prestashop/cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ /prestashop/supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ /prestashop/manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]

# Catch 404 errors
ErrorDocument 404 /prestashop/404.php

Share this post


Link to post
Share on other sites

Heu oui OK, mais là tu utilises encore le module PrestaShop d'OVH. C'est pour ça qu'il est déjà rempli...

Je croyais que tu essayais l'installation manuelle.

Share this post


Link to post
Share on other sites

Oui j'me suis planté dans la copie.

J'ai désintaller le module Presta de chez OVH.
J'ai installé presta sur mon serveur. J'ai réussi l'installation. Puis envoie du login et mot de passe par e mail.
J'ai accès à la partie admin. Mais pas à la boutique.

Voici une copie de mon .htaccess :

SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0
RewriteBase /

Share this post


Link to post
Share on other sites

Si quelqu'un à le temps long lol.
Est ce qu'il pourrait vérifier les codes sur son FTP pour mon site ?
Là je bloque à la toute dernière étapes :-(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More