Jump to content

Recommended Posts

Bonjour à tous,

 

J'ai une boutique en 1.4 en production et comme beaucoup je suis en train de réfléchir à un passage en 1.6.

Avant cela je compte faire de nombreux tests. J'ai donc installé Prestashop 1.6 en local voir un peu à quoi ça ressemble et ça marche très bien.

Je suis sous Mac et j'utilise MAMP comme serveur local.

J'ai donc ensuite installé une copie de ma boutique (en 1.4) en local (et qui tourne bien), pour faire un test de mise à jour. 

Le problème que je rencontre c'est que j'ai systématiquement la même erreur lors de la mise à jour avec le module 1-click upgrade.

La mise à jour des fichiers se passe bien mais ça bloque lors de la mise à jour de de la BDD.

Le message d'erreur est 

[server Error] Timeout:La requête a dépassé le temps d"exécution maximum autorisé. Vous devez changer votre configuration serveur pour augmenter la durée de max_execution_time

 

J'ai bien évidement augmenté le paramètre max_execution_time dans mon php.ini en le passant carrément à 36000, mais rien y fait toujours la même erreur...

J'ai trouvé un topic recommandant de créer un my.cnf afin de renseigner le paramètre "max_allowed_packet=2400M" 

 

Je l'ai fait mais cela ne change rien...

 

Quelqu'un pour m'aider ?

 

Merci d'avance.

 

 

Share this post


Link to post
Share on other sites

Bonjour,

 

Peut etre le time out d'Apache aussi qu'il faut augmenté.

 

Coté PHP, pour autre chose que sur du Presta, j'avais aussi augmenté upload max file size & post max size

Share this post


Link to post
Share on other sites

Bonjour

 

Quelle taille la bdd ? sinon faire le ménage des log, connection, etc ... et normalement pas de time out

 

Bon courage

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci beaucoup pour vos réponses.

 

@2FR3 : Bonne idée d'augmenter le timeout d'Apache. Par défaut il était (en secondes) à 300 je l'ai mis à 900 (soit 30 min) mais toujours le même problème :-( J'ai chronométré ça plante toujours au alentours de 20 min donc à priori cela ne vient pas du Timeout Apache. J'ai aussi modifié les upload_max_file_size & post_max_size mais sans résultats.

 

@Easy Site : J'y ai pensé. Le problème c'est que je n'utilise pas le système de stat de Presta (pour ne pas avoir de BDD trop lourde justement). Ma BDD fait 66 Mo (j'ai vu largement pire pour du Presta). Ma table la plus lourde est la table ps_order_detail qui fait 9 Mo. Je ne pense pas pouvoir alléger la BDD du coup :-(

Je trouve ça bizarre qu'une BDD de 66 Mo ne passe pas...

 

Si vous avez d'autres idées n'hésitez pas. Je sèche grave là :-(

Share this post


Link to post
Share on other sites

@2FR3 Merci pour votre réponse.

Je connais bien BigDump pour l'avoir utilisé de nombreuses fois.

Mon problème n'est pas d'importer une grosse BDD. Mon problème c'est que la mise à jour de la BDD (via le module 1-Click Upgrade) plante systématiquement...

Du coup je pense que c'est un problème de config soit D'Apache ou plus probablement de PHP (config du php.ini) mais je ne vois pas quelle est la config qui pose problème.

 

Une idée ?

Share this post


Link to post
Share on other sites

Est tu sur de modifier le bon php.ini ? Avec WAMP il y en a un ou deux qui servent à rien il me semble.

 

Essaye de vérifier avec un phpinfo() si la bonne config est chargée.

Share this post


Link to post
Share on other sites

Houla oui, excusez moi, je devais être ailleurs !

 

Bon, 300/60 = 5, donc 900, votre time out est a 15 min, ce qui colle un peu près a vos 20 min. Par contre ce n'est pas normal que ce soit si long. L'ordi est un dinosaure ?

Share this post


Link to post
Share on other sites

Bonjour, prenez contact en mp si vous désirez, on va réglé cela et on mettra la soluce sur le forum

 

Cordialement

Nicolas

Share this post


Link to post
Share on other sites

@Eltius : Oui j'ai bien vérifié sur le phpinfo les changements sont bien pris en compte.

 

@2FR3 : Oui c'est bien 15 min. J'ai fait un test avec 3600 (60min donc) mais même problème plantage vers les 20 min. Je ne pense donc pas que ça viennent de là. 

Au niveau de l'ordi c'est pas de la 1ere fraicheur mais bon c'est pas non plus une antiquité :-) c'est un imac 3,06 Ghz Intel core 2 Duo avec 4Go de RAM. Ca devrait passer quand même...

 

@EasySite : Je prends contact avec vous.

Share this post


Link to post
Share on other sites

Bonjour j'ai eu le même problème sur mon serveur vps pro et idem au bout de 20 minutes plantage malgré les réglages du serveur.


 


Par contre pas de souci avec le dédié de la prod il traite la MAJ en 6 minutes sur une base de 2.6GO.


 


La solution n'a rien à voir avec la config serveur, elle est tout simplement dans le module autoupgrade lui même.


 


Il faut ouvrir le fichier AdminSelfUpgrade.php a la ligne 4894 et 4895 il y a une ligne qui parle d'elle même:


 


// set timeout to 20 minutes (before aborting an ajax request)


 


 $.ajaxSetup({timeout:1200000}); la valeur ici est en millisecondes (je pense). 


 


J'ai triplé la valeur et bingo au bout de 45 minutes mise a jour réussi (1.4.4.0 vers 1.6.0.9) et pas un seul warning  :).


 


Donc même si le post date un peu je laisse le message car le problème est à ce jour toujours d'actualité.


 


Cdt EZ


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More