Jump to content

Formularz kontaktowy i strona sypie się po wysłaniu wiadomości


Recommended Posts

Mam problem z formularzem...
Wszystko niby działa fajnie 

Wpisuje dane w formularzu kontaktowym wiadomość itd. Wysyłam.. Wiadomość dociera do odbiorcy w firmie i kopia do klienta..
ALE 

po wysłaniu wiadomości strona się odświeża i mam coś takiego :godeb7.jpg


Kod błędu to : 
 

Notice: Undefined property: ContactController::$context in /home/supron1/domains/supron1.pl/public_html/controllers/ContactController.php on line 187 

Notice: Trying to get property of non-object in /home/supron1/domains/supron1.pl/public_html/controllers/ContactController.php on line 187

Notice: Trying to get property of non-object in /home/supron1/domains/supron1.pl/public_html/controllers/ContactController.php on line 187 

KOD w którym występuje błąd (według debuga ) to : 

if ($contact->customer_service)
				{
					if ((int)$id_customer_thread)
					{
						$ct = new CustomerThread($id_customer_thread);
						$ct->status = 'open';
						$ct->id_lang = (int)$this->context->language->id;
						$ct->id_contact = (int)($id_contact);
						if ($id_order = (int)Tools::getValue('id_order'))
							$ct->id_order = $id_order;
						if ($id_product = (int)Tools::getValue('id_product'))
							$ct->id_product = $id_product;
						$ct->id_client = Tools::getValue('id_client');						
						$ct->id_adress = Tools::getValue('id_adress');						
						$ct->id_comp = Tools::getValue('id_comp');
						$ct->update();
					}

Przeszukałem forum ale mojego problemu nie znalazłem...

Share this post


Link to post
Share on other sites

 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More