Jump to content
marshom

problème, mélange de langue fr / en

Recommended Posts

Bonjour,

je me permet de vous poster cette image en exemple de mon problème, je ne comprend pas d'où vient le soucis, j'ai un mélange de language français et anglais sur mes pages, Prestashop vient juste d'etre installé sur un sous domaine en ligne, la configuration de la partie Localisation est tout en fr, malgré cela, du texte anglais apparait, et par exemple le formulaire de contact est en anglais
je remercie par avance pour toute piste ou conseil (peut être est ce quelque chose de simple, mais je dois passer à côté là...)
merci

 

post-304000-0-35019000-1391783889_thumb.jpg

Share this post


Link to post
Share on other sites

bonjour,
je me permet de up, toujours pas trouvé de quoi corriger ce problème .. je ne comprend pas

en local, cela fonctionne correctement, sur le serveur online c'est tout mélangé anglais/français..
aucune piste ??

 

merci encore par avance

 

 

post-304000-0-44592300-1392046184_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour,

 

Essayez dans LOCALISATION >  TRADUCTIONS >  AJOUTER / METTRE À JOUR UNE LANGUE de mettre à jour le pack de langue français ?

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour Gregory,
merci beaucoup de votre réponse, je viens d'essayer à l'instant,

la mise à jour se fait correctement, tout du moins j'ai un message qui le confirme "Traductions ajoutées avec succès",

mais cela ne change rien, l'affichage est toujours en anglais

à noter que cela à l'air de ne toucher que le contenu des pages, pas de problème dans l'entête ou le pied de page,

j'ai vérifié les droits d'écritures, cela à l'air correct, je me dis cela doit être un problème de configuration de serveur peut être ? puisque Prestashop fonctionne très bien en local sur ma machine..

merci encore par avance de vos conseils
bien à vous

Share this post


Link to post
Share on other sites

A priori dans ce cas il vous manque les traductions dans /themes/theme/lang/fr/fr.php ?

$_LANG['contact-form_bbaff12800505b22a853e8b7f4eb6a22'] = 'Contact';
$_LANG['contact-form_2273d1167a6212812d95dc8fadbae78e'] = 'Service client';
$_LANG['contact-form_d754a9e8cb640da12849a040f3ca8176'] = 'Votre réponse';
$_LANG['contact-form_02d4482d332e1aef3437cd61c9bcc624'] = 'Contactez-nous';
$_LANG['contact-form_4ec1c39345fe8820d68463eea8803b0f'] = 'Votre message a bien été envoyé à notre équipe.';
$_LANG['contact-form_8cf04a9734132302f96da8e113e80ce5'] = 'Accueil';
$_LANG['contact-form_7c9d4636fc5ed97bb78bc2aac486beab'] = 'Votre message a déjà été envoyé.';
$_LANG['contact-form_0880266daff3ed4c441adb888658c47c'] = 'Pour des questions à propos d\'une commande ou des informations sur nos produits';
$_LANG['contact-form_b3e4d8d61f99bac80e6aa1774d73445b'] = 'Envoyez un message';
$_LANG['contact-form_6c27c08f40e1b0d9901deb9ff5f722f7'] = 'Objet';
$_LANG['contact-form_7bc873cba11f035df692c3549366c722'] = '-- Choisir --';
$_LANG['contact-form_b357b524e740bc85b9790a0712d84a30'] = 'Votre adresse e-mail';
$_LANG['contact-form_5d4710f9a8250b13164a82c94d5b00d1'] = 'Référence de commande';
$_LANG['contact-form_deb10517653c255364175796ace3553f'] = 'Produit';
$_LANG['contact-form_13d6078da2e6592822ede083931d6826'] = 'Fichier';
$_LANG['contact-form_4c2a8fe7eaf24721cc7a9f0175115bd4'] = 'Message';
$_LANG['contact-form_94966d90747b97d1f0f206c98a8b1ac3'] = 'Envoyer';
$_LANG['contact-form_d79cf3f429596f77db95c65074663a54'] = 'Numéro de commande';
$_LANG['contact-form_cfe1b4b75fb8dc152b124f9305835a11'] = 'Votre message';

Re traduisible aussi en back office.

 

Cordialement

Share this post


Link to post
Share on other sites

Merci de cette piste Gregory,
effectivement le fichier est vide..
peut être j'ai manqué une étape, à l'installation j'ai copié le dossier theme "default" pour créer le thème de mon magasin qui est choisi en thème principal dans l'administration.
par contre, lorsque j'ajoute ou met à jour une langue dans Localisation > traduction, cela met à jour ou ajoute dans le dossier "default" plutot que dans le dossier "lang" de mon nouveau thème
j'ai regardé dans l'administration mais n'est rien vu où indiquer quel dossier "lang" à utiliser, je suppose que cela doit etre celui du thème par default, mais cela n'à pas l'air de fonctionner comme tel actuellement
je test en copiant le fichier, cela à l'air de fonctionner
merci beaucoup encore de votre support et réactivité

Share this post


Link to post
Share on other sites

Effectivement, cette mise ne touche pas aux thèmes personnalisés mais seulement aux dossiers de base, comme le thème default.

 

Cordialement

Share this post


Link to post
Share on other sites

ah ok, merci de l'info encore :)
mon problème est donc résolu
je vous renouvelle mes remerciements pour votre précieuse aide
bonne continuation à vous
merci

Share this post


Link to post
Share on other sites

Bonjour,

 

Je me permets de m'incruster sur ce post à priori résolu mais il ne l'est pas pour moi. Tout comme vous, mes pages sont à moitié fr/en. Merci de bien vouloir m'indiquer la marche à suivre pour que le problème soit résolu.

 

Merci

 

Cordialement,

 

Lily

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More