Jump to content

[Решено] Изображения для категорий не загружаются - белый экран


Recommended Posts

Все работало, как я думаю, до того момента пока не включил компрессию и кэширование..

Когда отключил - все равно изображения для категорий не загружаются, фаербаг при этом ничего не пишет..

 

Сейчас все так: при редактированни/добавлении категории, выбираю файл с изображением для картинки категории, и после нажатия кнопки сохранить у меня белый экран. Категории по факту создается, но изображение дефолтное.

 

Помогите советом -где искать ошибку, может не в кэшировании дело вообще, что-то другое искать?

 

 

Совсем забыл про режим отладки, при нем вот такая ошибка:

Warning: escapeshellarg() has been disabled for security reasons in /sata1/home/users/сайт/www/www.сайт/classes/ImageManager.php on line 221

 

 

Т.е. в настройках хостинга надо проверить включены ли следующие функции : escapeshellarg и exec.

 

После включения у меня все заработало, но тут возникает вопрос - а почему все работало до определенного момента и без них? :blink:

 

 

 

Edited by Koyot (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More