Jump to content
Semaphore

Erreur de doublon à l'importation d'une base PS1.5

Recommended Posts

Bonjour,

Mon client est sous PS 1.5.3.1.

Avant de lançer toutes les mises à jour sur le serveur de production je souhaite dupliquer le site/bdd dans un dossier et bdd séparé.

 

J'ai bien exporté la base avec l'option "create Table etc) mais à l'import dans la base vide depuis phpmyadmin j'obtiens :

Erreur

Requête SQL:

-- -- Contenu de la table `ps_access` -- INSERT INTO `ps_access` (`id_profile`, `id_tab`, `view`, `add`, `edit`, `delete`) VALUES (1, 1, 1, 1, 1, 1), (1, 5, 1, 1, 1, 1), (1, 7, 1, 1, 1, 1), (1, 9, 1, 1, 1, 1), (1, 10, 1, 1, 1, 1), (1, 11, 1, 1, 1, 1), (1, 13, 1, 1, 1, 1), (1, 14, 1, 1, 1, 1), (1, 15, 1, 1, 1, 1), (1, 16, 1, 1, 1, 1), (1, 19, 1, 1, 1, 1), (1, 20, 1, 1, 1, 1), (1, 21, 1, 1, 1, 1), (1, 22, 1, 1, 1, 1), (1, 23, 1, 1, 1, 1), (1, 24, 1, 1, 1, 1), (1, 25, 1, 1, 1, 1), (1, 26, 1, 1, 1, 1), (1, 27, 1, 1, 1, 1), (1, 28, 1, 1, 1, 1), (1, 29, 1, 1, 1, 1), (1, 30, 1, 1, 1, 1), (1, 32, 1, 1, 1, 1), (1, 33, 1, 1, 1, 1), (1, 34, 1, 1, 1, 1), (1, 35, 1, 1, 1, 1), (1, 36, 1, 1, 1, 1), (1, 37, 1, 1, 1, 1), (1, 39, 1, 1, 1, 1), (1, 40, 1, 1, 1, 1), (1, 41, 1, 1, 1, 1), (1, 42, 1, 1, 1, 1), (1, 43, 1, 1, 1, 1), (1, 45, 1, 1, 1, 1), (1, 46, 1, 1, 1, 1), (1, 49, 1, 1, 1, 1), (1, 50, 1, 1, 1, 1), (1, 51, 1, 1, 1, 1), (1, 53, 1, 1, 1, 1), (1, 54, 1, 1, 1, 1), (1, 55, 1, 1, 1, 1), (1, 56, 1,[...]

MySQL a répondu: Documentation
#1062 - Duplicate entry '1-1' for key 'PRIMARY' 

Une idée de ce que je fait mal ? Qu'est-ce qui fait qu'il trouve un doublon dans les entreés ?

 

Merci d'avance à la communauté ;-)

Share this post


Link to post
Share on other sites

Bonjour,

 

Cela signifie que les données que vous souhaitez insérer existent deja ou en partie.

 Je vois bien que vous avez marqué vide mais il doit y a voir un souci quelque part.

 

Remplacez INSERT par INSERT IGNORE mais sans garantie.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

Merci du coup de main car même si ce n'était pas cela, j'ai put m'apercevoir que l'attribut Create database était coché par défaut dans le phpmyadmin de mon client :blink:  Surement dut à une ancienne manip de notre part !

 

Merci en tout cas !

Share this post


Link to post
Share on other sites

Bonjour,

Merci du coup de main car même si ce n'était pas cela, j'ai put m'apercevoir que l'attribut Create database était coché par défaut dans le phpmyadmin de mon client :blink:  Surement dut à une ancienne manip de notre part !

 

Merci en tout cas !

Bonjour,

Pouvez vous expliquer le procédé a suivre svp j'ai besoin d'aide !!! help me :'(  

Share this post


Link to post
Share on other sites

Vous obtenez la même erreur ?

oui je deprime j'ai bien trouver la partie :

    • Au lieu d'énoncés INSERT, utiliser :

      • Énoncés INSERT DELAYED
      • Énoncés INSERT IGNORE
      • j'ai cocher insert ignore mais mon site affiche une page blanche

Share this post


Link to post
Share on other sites

Le mieux étant re-partir d'une base vierge et de partir d'un export où l'on aura coché create table mais pas create database

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More