Jump to content

[Résolu] module mailalert ne fonctionne plus


Recommended Posts

Voila depuis la mise a jour en 1.5.6 le module mailalert ne fonctionne plus. Voila ce que je reçoit comme erreur:

 

-------------------

A message that you sent contained one or more recipient addresses that were
incorrectly constructed:

  [email protected] <[email protected]>: malformed address: <[email protected]> may not follow [email protected]

This address has been ignored. There were no other addresses in your
message, and so no attempt at delivery was possible.

------ This is a copy of your message, including all the headers. ------

To: [email protected] <[email protected]>
Subject: [Ginkgo Computer Sarl] Nouvelle commande - #000355
Return-Path: <[email protected]>
From: Ginkgo Computer Sarl <[email protected]>
Reply-To: Ginkgo Computer Sarl <[email protected]computer.com>
Date: Thu, 17 Oct 2013 11:02:39 +0200
X-LibVersion: 3.3.2
MIME-Version: 1.0
Content-Type: multipart/related;
 boundary="_=_swift-1777071298525fa7af21ec45.16950447_=_"
Content-Transfer-Encoding: 7bit
Message-ID: <[email protected]>

This is a message in multipart MIME format.  Your mail client should not
be displaying this. Consider upgrading your mail client to view this
message correctly.
--_=_swift-1777071298525fa7af21ec45.16950447_=_
Content-Type: multipart/alternative;
 boundary="_=_swift-191957819525fa7af21f165.78622435_=_"
Content-Transfer-Encoding: 7bit

 

----------------------

J'ai essayé plusieurs adresses et toujours le même probleme
 

Edited by ENCRECOM (see edit history)

Share this post


Link to post
Share on other sites

Bonjour Encrecom,

 

-> Premièrement, voici le correctif pour passer dans la dernière version du module Mailalert (2.5) :

 

https://github.com/P...5bfa4388b063ba2

 

Uploadez ces deux fichiers

 

https://github.com/P...erts/config.xml et

https://github.com/P...install-2.5.php

 

et rechargez la page des modules, ce qui devrait mettre ce module à jour correctment.

 

La mise à jour ne devrait pas vous supprimer vos données ( ne réinstallez pas le module par contre, ni le réinitialiser).

 

 

-> Ensuite, pour corriger votre problème :

 

Réuploader ce fichier :

 

https://raw.github.com/PrestaShop/PrestaShop/789911184b72a2765a6faf39652506057350a021/classes/Mail.php

 

 

 

Bien cordialement,

Share this post


Link to post
Share on other sites

  • 2 weeks later...

… suite… j'ai remplacé le fichier Mail.php du dossier "classes" par celui proposé.

Le bug est mailtenant :

Le(s) module(s) suivant(s) ne peuvent pas être chargé.:
  1. [mailalerts] Erreur dans le fichier de configuration: xmlParsePI : no target name
  2. [mailalerts] Erreur dans le fichier de configuration: Start tag expected, '<' not found

Que faut-il faire ?

 

Merci.

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai remplacé les 2 fichiers comme expliqué dans votre post #2 puis comme expliqué j'ai re chargé la page des modules mais j'obtient sur cette page cet écran d'erreur ci-dessous.

Mon module est actuellement en version 2.4.

 

Pourriez vous m'aider ?

 

Le(s) module(s) suivant(s) ne peuvent pas être chargé.:
[

 

 

 

mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax-transient
[mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax-transient
[mailalerts] Erreur dans le fichier de configuration: attributes construct error
[mailalerts] Erreur dans le fichier de configuration: Couldn't find end of Start Tag link line 50
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: meta line 48 and head
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 136 and form
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 97 and div
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: form line 95 and div
[mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute itemscope
[mailalerts] Erreur dans le fichier de configuration: attributes construct error
[mailalerts] Erreur dans le fichier de configuration: Couldn't find end of Start Tag div line 148
[mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute itemscope
[mailalerts] Erreur dans le fichier de configuration: attributes construct error
[mailalerts] Erreur dans le fichier de configuration: Couldn't find end of Start Tag h1 line 181
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: div line 151 and h1
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 259 and div
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 273 and div
[mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax-container
[mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax
[mailalerts] Erreur dans le fichier de configuration: attributes construct error
[mailalerts] Erreur dans le fichier de configuration: Couldn't find end of Start Tag a line 315
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: div line 307 and a
[mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax
[mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 341 and div
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
[mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined

 

 

....

...

Edited by Gregory Roussac (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Pensez vous que mon logiciel FTP (Fillezila) n'a pas uploadé le fichier XML dans le répertoire du module ?

Je pense que FIlezilla upload correctement tous les fichiers.

Si cela n'avait pas été le cas et que le nouveau fichier config.xml n'avait pas été uploadé sur le serveur je n'aurais pas eu de message d'erreur en voulant acceder à la page module non?

Je me trompe ?

 

Je viens de ré uploadé dans le repertoire du module mailalert les fichiers en pièce jointe (je n'arrive pas a uploader le fichier config.xml sur le forum !!?? j'ai le message upload fail.).

 

Lorsque je tente d'acceder ensuite au BO de presta dans la section des modules j ai cela :

 

Le(s) module(s) suivant(s) ne peuvent pas être chargé.:
  1. [mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax-transient
  2. [mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax-transient
  3. [mailalerts] Erreur dans le fichier de configuration: attributes construct error
  4. [mailalerts] Erreur dans le fichier de configuration: Couldn't find end of Start Tag link line 50
  5. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: meta line 48 and head
  6. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 136 and form
  7. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 97 and div
  8. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: form line 95 and div
  9. [mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute itemscope
  10. [mailalerts] Erreur dans le fichier de configuration: attributes construct error
  11. [mailalerts] Erreur dans le fichier de configuration: Couldn't find end of Start Tag div line 148
  12. [mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute itemscope
  13. [mailalerts] Erreur dans le fichier de configuration: attributes construct error
  14. [mailalerts] Erreur dans le fichier de configuration: Couldn't find end of Start Tag h1 line 181
  15. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: div line 151 and h1
  16. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 259 and div
  17. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 273 and div
  18. [mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax-container
  19. [mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax
  20. [mailalerts] Erreur dans le fichier de configuration: attributes construct error
  21. [mailalerts] Erreur dans le fichier de configuration: Couldn't find end of Start Tag a line 315
  22. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: div line 307 and a
  23. [mailalerts] Erreur dans le fichier de configuration: Specification mandate value for attribute data-pjax
  24. [mailalerts] Erreur dans le fichier de configuration: Opening and ending tag mismatch: input line 341 and div
  25. [mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
  26. [mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined
  27. [mailalerts] Erreur dans le fichier de configuration: Entity 'nbsp' not defined

install-2.5.php

Edited by Mackens (see edit history)

Share this post


Link to post
Share on other sites

Bonsoir,

 

J'ai réussi à mettre à jour le module mailalerte en version 2.5 en éditant les fichiers à la main comme indiqué à la première étape de la procédure corrective ci-dessus.

 

Mais sue dois je donc faire des deux fichiers fournis dans les liens de la procédure après que j'ai réussi la mise à jour 2.5 en éditant les fichiers à la main ? Car ce sont les mêmes fichiers. Je dois écraser ceux que j'ai modifié à la main ?

 

Ensuite, le fichier mail.php, il n'est dit nul part ou je doit l'uploader ? Dans quel dossier de prestashop ? en remplacement du fichier qui porte le meme nom dans le dossier CLASSES  ?

 

Merci d'avance pour vos aides.

Share this post


Link to post
Share on other sites

Ensuite, le fichier mail.php, il n'est dit nul part ou je doit l'uploader ? Dans quel dossier de prestashop ? en remplacement du fichier qui porte le meme nom dans le dossier CLASSES  ?

 

Merci d'avance pour vos aides.

 

 

Oui c'est exact, en remplacement du fichier "classes/Mail.php"

 

 

Bien cordialement,

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Ce topic ets en résolu mais je tente ma chance malgré tout.

Si je suis vos recommandations, j'ai une page blanche lors de la demande de régénration de mot de passe.

Le module a bien été upgradé en 2.5, mais le changement de Mail.php provoque cette page blanche.

 

Auriez-vosu quelques conseils pour moi ?

 

MErci

Share this post


Link to post
Share on other sites

Bonjour Lilhouh,

 

Activez les erreurs, si ce n'est pas déjà fait, pour voir le message d'erreur suite à la page blanche.
    1.    Ouvrez config/defines.inc.php
    2.    À la line 28 (ou proche) vous trouverez
 define('_PS_MODE_DEV_', false);
    3.    Changez alors par
 define('_PS_MODE_DEV_', true);
 Vous aurez une idee plus precise de là ou ça coince.

 

Vous aurez une idée plus précise d'où vient le problème.

 

 

Bien cordialement,

Share this post


Link to post
Share on other sites

Bonjour Vincent, 

 

Merci de votre réactivité, et désolée du manque de la mienne =)

 

C'est vrai que je ne suis pas à l'aise avec ce debug... Mais force est de constater que ça aide.

Pour ma part il ne fallait pas uploadé le fichier Mail.php donné dans ce topic, c'est lui qui me donnait cette page blanche.

Le mien suffisait, donc plus de page blanche... par contre pas d'amélioration niveau reception de mail.

 

J'ai donc suivi le conseil trouvé sur ce forum de renseigner mes paramètres mail à la mano (dans Paramètres Avancés / Emails) bien que, quelques jours avant, la configuration par défaut fonctionnait très bien toute seule.

 

Qu'importe, cela fonctionne de nouveau ! 

Merci la communauté !

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Merci pour votre réponse aussi rapide.

 

J'ai récupéré les 2 fichiers et après tests ça ne fonctionne toujours pas. J'ai bien suivi la méthode donnée dans votre premier post, je ne comprends pas ce qui cloche chez moi  :unsure:

 

Pour info, j'ai migré de la 1.4.6 (où ça fonctionnait très bien) vers la 1.5.6

 

Si par hasard vous avez une idée, elle est la bienvenue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More