Jump to content
montres-en-silicone

pas d'images sprites css avec CCC pour les feuilles de style.

Recommended Posts

édit : ce post n'est peut êtres pas dans le bon forum il serait surement mieux dans rapport de bug si un modérateur passe par la merci de le déplacer si vous êtes d'accord avec moi

 

bonjour

je suis entrain de mettre en place sur ma homepage des sprites css jusque la rien de bien compliqué mais quand j'active Smart cache" pour les feuilles de style (admin>Paramètres avancés>Performances>CCC (Concaténation, Compression et mise en Cache)>Utiliser CCC pour les feuilles de style.

les images qui viennent du sprites ne s'affiche pas.

 

par exemple pour l'image du caddy dans le blockuserinfo

j'ai modifier le fichier blockuserinfo.css ligne 19

background: url("/img/sprite.png") no-repeat scroll 0 -572px; width: 40px; height: 40px #FFFFFF;

la pas de prob l'image s'affiche.

 

mais si j'active ccc pour les feuilles de style la l'image ne s'affiche plus et firebug me donne comme indication

background: url("http://www.mondomaine.com/modules/blockuserinfo/http://www.mondomaine.com/img/sprite.png") no-repeat scroll 0 -572px transparent

hum c pas très beau comme url

 

donc j'ai certainement pas fait ou mal fait quelques choses mais je ne vois pas quoi ou alors l'utilisation de sprite n'est pas possible avec le ccc pour les feuilles de styles.

 

j'ai chercher (peut êtres mal) sur le forum et sur Google et je n'ai trouvé aucune piste a croire que je suis le seul dans ce cas.

 

pourriez vous m'aider a régler ce problème merci d'avance

 

ah oui petite précision l'image sprites et dans le dossier img a la racine du serveur et ma version prestashop est la 1.5.4.1 avec thème par défaut sans grande modification hors mis un peu de css pour changer la couleur des textes ou des background et quelque bordure par ci par la.

Edited by montres-en-silicone (see edit history)

Share this post


Link to post
Share on other sites

Hello MES , 

 

Si jamais tu n'a pas trouvé la solution a ton problème voici la solution 

 

> Placer ton image Sprite dans le dossier img de ton thème.

> dans ton global.css écrire le lien vers ton sprite sous cette forme

 

{background-image: url("../img/sprite.png");background-repeat: no-repeat} 

 

Ce sont les Guillemets qui font la différence !  :-)

 

Bon Courage

Matias

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More