Jump to content
coraline

passer de presta 1.4.4.1 à 1.5.4.1

Recommended Posts

Bonjour, j'aimerai passer mon site du presta 1.4.4.1 au 1.5.4.1 comme la mise à jour automatique ne me propose que la version 1.4.4.11 je veux le faire manuellement.

 

J'ai sauvegardée ma base ainsi que mon site et télécharger la version 1.5.4.1 puis j'ai mis le dossier "prestashop" chez mon hebergeur "infomaniak" j'ai transféré les img et autre...

 

Mais voila au moment d'ouvrir mon site ici "http://www.laine-et-plus.com/prestashop/" voici mon erreur

 

"Fatal error: Uncaught Table 'laineetpluscom.ps_shop_url' doesn't exist<br /><br /><pre>SELECT s.id_shop, CONCAT(su.physical_uri, su.virtual_uri) AS uri, su.domain, su.main FROM ps_shop_url su LEFT JOIN ps_shop s ON (s.id_shop = su.id_shop) WHERE (su.domain = 'www.laine-et-plus.com' OR su.domain_ssl = 'www.laine-et-plus.com') AND s.active = 1 AND s.deleted = 0 ORDER BY LENGTH(CONCAT(su.physical_uri, su.virtual_uri)) DESC</pre> thrown in/home/www/ac38ad08c670ad60fe6dc7ede3abf90a/web/prestashop/classes/db/Db.php on line 607"

 

J'ai chercher la table "ps_shop_url", mais je ne l'ai pas.

 

Qu'est ce que je dois faire ?

 

Merci

Share this post


Link to post
Share on other sites

Bonjour,

 

Il est préférable de passer par la 1.4.11 avant de basculer en 1.5.

 

 

Share this post


Link to post
Share on other sites

Ok mais si je lance la mise à jour automatique que je viens de télécharger j'ai une erreur Erreur Javascript (parseJSON) détectée pour l'action"upgradeNow".Début de la restauration ..

 

qu'est ce que je peux faire ???

Share this post


Link to post
Share on other sites

Bon et bien comme je ne peux pas faire de mise à jour étant donner mon souci avec la mise à jour automatique "Erreur Javascript (parseJSON) détectée pour l'action"upgradeNow".Début de la restauration ..."

 

Est ce que je peux faire une installation standard en 1.5 et juste mettre mes clients, car je ne veux pas forcement récupérer mes ventes ???

Share this post


Link to post
Share on other sites

Hello,

 

Quelle version du module vous utilisez ? 1.0.26 ?

 

détectée pour l'action"upgradeNow". c'est une etape très tôt dans le processus et cela ressemble a un problème de droit.

 

Pouvez vous me faire des accès FTP et Back office temporaires que je je jette un œil ?

 

Sinon il est tout à fait possible de passer d'une 1.4.4 à une 1.5.4.1 sans étape intermédiaire. Une prochaine 1.5 sort sous peu et son installeur corrige la plupart des soucis qu'il avait pour les mises à jour venant d'une 1.4.

 

Cordialement

Share this post


Link to post
Share on other sites

Sinon il est tout à fait possible de passer d'une 1.4.4 à une 1.5.4 sans étape intermédiaire. Une prochaine 1.5 sort sous peu et son installeur corrige la plupart des soucis qu'il avait pour les mises à jour venant d'une 1.4.

 

Ben alors il y a des soucis ou il n'y en a pas, faudrait savoir.

 

Perso je dit juste que le script provoque des erreurs dans la base rien que par exemple des doublons ou "triplons" dans la table configuration sans que cela soit lié à des shop différents.

 

Dans tous les cas, même si le module fait une sauvegarde faite la votre de votre côté c’est une sécurité pas inutile.

Share this post


Link to post
Share on other sites

Bonjour,

 

Désolé je ne crois pas que cela soit la peine de s’énerver. La prochaine version 1.5.5 a un installeur qui soulèvera moins d'erreur que celui de la 1.5.4.1 en venant d'un 1.4, bien qu'il est tout à fait possible de ne pas en rencontrer non plus vers une 1.5.4.1.

Vous pouvez a tout moment le prendre et le tester à partir de github, https://github.com/P...ase/install-dev en faisant bien attention à changer le numéro de version https://github.com/P...all_version.php . N’hésitez pas à me soumettre vos remarques si vous rencontrez encore des erreurs sql avec cet installeur.

 

Je n'ai pas rencontré de "triplons" sur les différentes mises à jour que j'ai pu voir/faire. Il y' a bien un souci sur le logo en 1.5.4.1 qui créait un doublon dans cette table. Malheureusement un critère d'unicité sur des champs qui peuvent recevoir NULL n'est pas possible en mysql.

 

Si vous rencontrez des doublons dans cette table, il faudrait regarder du coté du module pscleaner qui je crois dédoublonne cette table. De quelles clés vous parlez précisément qui était en doublon chez vous ?

 

Enfin en cas d’impossibilité d'accéder au back office et qu'il faille faire une restauration manuelle, les dumps se trouvent dans /admin/autoupgrade/backup/ ainsi que les fichiers zippés. Il est fortement conseillé de backuper également votre site manuellement (surtout /config/settings.inc.php), et de dupliquer le site sur un serveur local puis de tester la mise à jour dessus avant de le faire en ligne.

 

Cordialement

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More