Jump to content
fast

Doppelte Steuerberechnung auf Rechnungs-PDF

Recommended Posts

Hallo,

 

Ich nutze PrestaShop 1.5.3.1 mit dem germanExt-Modul.

Leider schmeißt er mir jetzt falsche Steuerberechnungen in der PDF-Rechnung raus. Die Gesamtsumme stimmt, aber die Steuertabelle unten ist nicht korrekt. Es scheint so, dass die Steuer auch korrekt aufgeteilt wird (zwischen 7- und 19%-Artikeln), aber danach scheint noch einmal 7% für den gesamten Warenkorb addiert zu werden.

Hat irgendjemand eine Ahnung, welche Einstellung dafür verantwortlich sein könnte?

Ich habe einige Anpassungen am Template vorgenommen und vor dem Launch der Seite alle Testbestellungen in der Datenbank entfernt, aber wie könnte das die Ursache sein??

 

Danke für eure Ideen!

fast

post-582489-0-38737200-1370261915_thumb.png

Share this post


Link to post
Share on other sites

Hallo,

 

es gibt keine Einstellungen, die dafür verantwortlich sind.

Was die Berechnung angeht, ist diese in diesem Beispiel eindeutig falsch. Ich prüfe das umgehend und melde mich dann wieder hier.

Share this post


Link to post
Share on other sites

Dankeschön!

 

Ich kann wie gesagt nicht garantieren, dass es nicht vom Zurücksetzen der Rechnungs-ID oder so kommt, aber es scheint mir einfach nicht so, weil ich keine Alt-Daten irgendwo erkenne, die Werte scheinen sich nur aus den neuen Bestellungen zu speisen.

Wenn ich die Berechnung irgendwie sinnvoll debuggen kann, wäre ich für einen Hinweis dankbar.

 

fast

Share this post


Link to post
Share on other sites

Vielleicht muss ich das System einfach noch einmal sauber neu aufsetzen…

Schön wäre eine systeminterne Reset-Funktion, die einfach nur die Datenbank nullt (sodass die erste Bestellung auch eine entsprechende ID bekommt und so). Oder habe ich die Funktion übersehen?

 

fast

Edited by fast (see edit history)

Share this post


Link to post
Share on other sites

Hallo,

 

wir haben das noch mal genau geprüft und keinen Fehler in germaNext finden können. Also muss das an den manuellen Anpassungen liegen. Falls eine Analyse "vor Ort" gewünscht ist, bitte melden Sie sich per PM oder per Mail an kontakt@silbersaiten.de

 

Grüße

Share this post


Link to post
Share on other sites

Danke für die Prüfung! Ich habe das System inzwischen sauber neu aufgesetzt und es funktioniert (wieder) alles wie es soll. Wahrscheinlich also doch ein Fehler durch das Zurücksetzen der Testdaten.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More