Jump to content
bhenbe

Mise à jour 1.4.6 vers 1.5.4...

Recommended Posts

Bonjour à tous,

 

je viens d'avoir une demande plutôt exotique et j'aimerai avoir vos conseils quant à la démarche à suivre.

 

J'ai été contacté pour réparer une boutique en ligne qui ne fonctionne plus suite à une mise à jour effectuée par un autre développeur.

 

La boutique tourne avec une version 1.4.6. J'ai retrouvé dans un répertoire test une version 1.5.4. J'ai aussi 3 installations distinctes de prestashop dans la base de données, toutes sur une structure 1.5.4. L'une d'elle contient les données complètes du site, les deux autres sont vierges.

 

Premier problème, le thème se charge correctement mais il n'y a plus la moindre donnée qui s'affiche, comme si tous les hooks avaient été désactivés.

 

Second problème, la cliente désire préserver son thème actuel qui ne fonctionne pas sous les versions 1.5.x de Prestashop.

 

Pour faire vite, j'envisage plutôt de revenir sur la version 1.4.6. Après un retour à la normale, on pourra envisager l'adaptation du thème vers la 1.5.

 

C'est la première fois que je suis devant un tel cas de figure et j'aimerai votre avis sur la question.

 

Merci d'avance de votre aide.

 

Bonne journée

Share this post


Link to post
Share on other sites

Bonjour

 

Si la cliente veut garder le thème et qu'il est incompatible avec la 1.5 rester en 1.4.10

Au lieu d'importer toute la base de donnée importer uniquement les tables des produits, tables des clients, des employées.

 

Et transférer le dossiers /img/ sauf /img/admin/ qui doit rester celui de la 1.4.10.

 

Et les base de données de la 1.5 si elle n'est pas utilisé viré tout pour que ce soit propre.

Share this post


Link to post
Share on other sites

Un grand merci pour ta réponse.

 

Je ne comprends pas bien ton explication sur l'importation.

 

J'ai une structure de tables qui est en version 1.5.4. Si je dois repartir sur une version 1.4.x, je dois donc effectuer des exports csv via le phpmyadmin en ne sélectionnant que les champs spécifiques à cette version. C'est bien cela ?

Share this post


Link to post
Share on other sites

Premier problème, le thème se charge correctement mais il n'y a plus la moindre donnée qui s'affiche, comme si tous les hooks avaient été désactivés.

 

Hello,

 

Il peut y avoir beaucoup de causes, par exemple la version de php http://www.prestasho..._1#entry1162446, un problème de base, de classe. Tu as forcement des logs, as tu activé l'affichage des erreurs dans la config, que dis Apache ? tu as les données en back office ?

Share this post


Link to post
Share on other sites

 

Et les base de données de la 1.5 si elle n'est pas utilisé viré tout pour que ce soit propre.

 

Je pense qu'en théorie, une base 1.5 peut même fonctionner telle quelle avec un moteur 1.4.10 mais je n'ai pas testé.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More