Jump to content

Attention au bouton 'Mettre à jour!" dans la liste modules en BO


Broceliande
 Share

Recommended Posts

Personne n'a du louper ce fameux bouton qui apparait en face de certains modules natifs et surtout en face de tous les modules payants mis à jour sur addons et pas sur votre back office.

 

Du coup je dois vous mettre en garde contre un clique curieux et confiant sur ce bouton, si vous ne remplissez pas les conditions suivantes :

- Avoir rempli les champs "Identifiant et Password addons" dans votre l'onglet modules->modules

- Avoir le droit de télécharger la dernière versions (pour ça faut passer voir sur votre compte addons par ce que ça dépend de vos achats et options)

 

Dans le cas contraire, voici ce qui se passe dans l'ordre (après lecture du code correspondant dans AdminModulesController ligne 607)

 

Je prends ici l'exemple vécu d'un module atos officiel presta installé sur un site dans sa version 2.6...

- Une version 2.7 est dispo sur addons

- Le bouton"Mettre à jour!" est bel et bien là , bien tentant (je ne suis pourtant pas loggué)

- On clique sur le bouton , (rien n'indique de ne pas le faire si on a pas les prérequis... )

- Le dossier du module est avant toute chose supprimé, je le dis plus haut : ligne 607 d' AdminModulesController.

- Enfin , on va cherchre l'archive zip sur addons.

Sauf que là , si le module est payant , pour avoir l'archive il faut avoir rempli les conditions sus-nommées.

SI c'est pas ok pas de zip^et donc plus de module mais un message incitant à acheter les module à la place. (200€ dans le cas d'atos, des broutilles... )

 

Mais surtout aucun message d'erreur.

Or en front ce qui se passe c'est que là , bonnement et simplement vous n'avez plus de paiement atos, point barre.

Le dossier du module n'existe plus (a vos archives)

Le certificat pas plus (vous avez un backup hein ? )

 

Bref un clic qui peu coûter cher.

  • Like 2

Share this post


Link to post
Share on other sites

Magnifiiiiique !!!!!

Et quel est le sombre crétin qui a pensé la chose qu'on le pende par les couilles ? Parce que là c'est bien un mec qui a oublié de se payer un cerveau pour penser la fonctionnalité de cette façon !

*part chercher son pote Frankenstein pour le faire postuler chez prestashop*

Share this post


Link to post
Share on other sites

Le (ou les) chef de projet de la team Prestashop on de quoi se faire taper sur les doigts.. AIE AIE AIE

 

Merci Broceliande pour la mise en garde, ça peut faire éviter de gros ennuis à pas mal de monde !

Share this post


Link to post
Share on other sites

Je suis sur le cul devant une telle bêtise...

 

PS: Dites-donc Presta, vous pouvez nous indiquer le salaire de vos devs ? Soit ils sont sous-payés et veulent tuer le projet, soii trop payés et n'en n'ont plus rien à foutre.

 

En tout état de cause Merci à Brocéliande de toujours garder un oeil vif et aiguisé sur les fonctionnalités Prestashop et leurs bugs :)

Share this post


Link to post
Share on other sites

Merci Broceliande pour cet mise en garde.

 

J'avais bien vu ce bouton, mais sans dérouler tout le comportement.

La suppression du répertoire supprime t elle aussi les infos en base de données ?

 

Ce répertoire qui est supprimé, ça laisse penser que les modules n'ont pas de procédure d'upgrade.

Une "bonne" méthode de mise à jour voudrait que les données en BDD ne soit pas effacées, que le nouveau code soit copie à la place du précédent et que les données soient misés à jour.

 

Share this post


Link to post
Share on other sites

La suppression du répertoire supprime t elle aussi les infos en base de données ?

 

Ca ne supprime que le répertoire, pas de modification de la BDD : https://github.com/P.../Tools.php#L669

Par contre aucune vérification n'est faite sur les fichiers. Donc les fichiers ajoutés par le module ou autre après l'installation seront supprimés de toute facon :(

par exemple dans le module editorial, les fichiers homepage_logo_*.jpg (photos de l'éditorial) seront perdus à chaque mise à jour.

 

Donc dans le cas de Broceliande avec son certificat atos, il l'aurait eu dans le baba même en étant connecté à addons.

 

La bonne méthode serait juste de ne pas supprimer avant mise à jour, juste écraser l'existant. Comme d'hab quoi.

  • Like 1

Share this post


Link to post
Share on other sites

Ca ne supprime que le répertoire, pas de modification de la BDD : https://github.com/P.../Tools.php#L669

Par contre aucune vérification n'est faite sur les fichiers. Donc les fichiers ajoutés par le module ou autre après l'installation seront supprimés de toute facon :(

par exemple dans le module editorial, les fichiers homepage_logo_*.jpg (photos de l'éditorial) seront perdus à chaque mise à jour.

 

Donc dans le cas de Broceliande avec son certificat atos, il l'aurait eu dans le baba même en étant connecté à addons.

 

La bonne méthode serait juste de le pas supprimer avant mise à jour, juste écraser l'existant. Comme d'hab quoi.

 

Shag a tout dit oui . Pas de désinstall du module à proprement parler, juste une suppression sauvage.

Atos était un exemple, avec bien sûr la suppression du certificat , éditorial en est un autre : tout fichier uploadé depuis les modules sont irrémédiablement supprimés . On peut imaginer ce que ça peut donner avec un menu riche, par exemple , etc ...

Share this post


Link to post
Share on other sites

Atch et Brocelinde : des frères jumeaux?

Allez, je sors!

 

Non mais explique juste :D ?

Certes on fait pas mal de trucs ensemble mais on ne nous avait encore jamais confondu , je trouve ça marrant , mais je veux juste savoir si c'est un amalgame ou pas ;)

Share this post


Link to post
Share on other sites

La bonne méthode serait juste de le pas supprimer avant mise à jour, juste écraser l'existant. Comme d'hab quoi.

Ou prévoir d'externaliser dans un endroit prévu à cet effet les fichiers liés (autres que "module core") aux modules (/download/modules/xxx par exemple ?) et penser qu'une mise à jour commence TOUJOURS par une sauvegarde de l'existant pour prévoir un ROLLBACK en cas d'incident lors de la maj, vous savez, ce genre de précaution que prennent tous les professionnels un peu sérieux en fait...

Share this post


Link to post
Share on other sites

Certes on fait pas mal de trucs ensemble mais on ne nous avait encore jamais confondu , je trouve ça marrant , mais je veux juste savoir si c'est un amalgame ou pas ;)

 

Professionnellement Parlant, hein :)

 

 

Ca y est ! Dès qu'il y a un mec qui gueule, on l'appelle "Atch". Z'allez voir que ça va devenir un nom commun pour qualifier un mec qui râle ! :P

 

LOL meme quand je ne dis rien, j'suis dedans :unsure: !!!

Moi qui ait décidé de jeter l'éponge ...

 

V++

 

Atch

Edited by Atch (see edit history)

Share this post


Link to post
Share on other sites

La bonne méthode serait juste de le pas supprimer avant mise à jour, juste écraser l'existant. Comme d'hab quoi.

 

Clairement si , mais au minimum , avant de supprimer le dossier , on devrait au moins s'assurer que la maj est bien chargée.

Or ce download n'est pas garanti et on supprime avant ...

 

Merci au fait d'avoir posté le bug sur la forge ! quel courage ce Shaggy :) !

Share this post


Link to post
Share on other sites

Salut,

 

actuellement la procédure pour installer une nouvelle version d'un module par le BO n'efface pas les ancien fichiers mais simplement remplace par ceux contenu dans l'archive et fait un upgrade en fonction des éléments donnés dans upgrade donc pourquoi réinventer la roue encore une fois alors que la procédure existe déjà.

J'imagine que ce soucis vient juste du fait que les "ancien" de prestashop qui sont encore là ne sont plus dans le dur et seulement d'an le management donc personne pour expliquer au nouveaux comment ils doivent aborder la structure du code de Prestashop.

Trouvez moi 1 seul module natif de Prestashop qui respecte les nouvelles norme de codage des module en 1.5 ?

Share this post


Link to post
Share on other sites

  • 11 months later...

Bonjour

Merci pour l'info, dommage, c est trop tard pour moi

J ai mis a jour

Envoyer a un ami

Facebook

Commentaire

Du coup aucun ne marche, je pense que ça vient bien de la mise a jour

Savez vous ce qu il faut faire pour "réparer" tout ca

Merci par avance

Je suis en 1.5.6.2

 

Nathalie

Share this post


Link to post
Share on other sites

Bonjour

Merci pour l'info, dommage, c est trop tard pour moi

J ai mis a jour

Envoyer a un ami

Facebook

Commentaire

Du coup aucun ne marche, je pense que ça vient bien de la mise a jour

Savez vous ce qu il faut faire pour "réparer" tout ca

Merci par avance

Je suis en 1.5.6.2

 

Nathalie

Bonsoir,

 

Vos modules sont des "natifs" donc faciles à récupérer sur la version de base 1.5.2.0 (dans le zip d'origine).

Si vous ne l'avez plus il est disponible ici: http://www.prestashop.com/download/old/prestashop_1.5.2.0.zip

 

Bon ce n'est pas la meilleure version de la série 1.5, mais si votre boutique tourne bien avec... :)

Share this post


Link to post
Share on other sites

Bonjour

J ai desinstallé le module "envoyer a un ami" et reinstallé a partir de ma version de sauvegarde

Ca ne change rien

J ai laissé dans ma signature 1.5.2 alors que je suis en 1.5.6.2

C est peut etre pour ca

Je dois trouver la version 1.5.6.2

Alors c'est là: http://www.prestashop.com/download/old/prestashop_1.5.6.2.zip

Pensez à vider cache navigateur et Prestashop également

Share this post


Link to post
Share on other sites

en fait si j utilise "envoyer a un ami", ça marque que je n ai rempli les champs requis alors que oui

 

Si on veut me laisser un commentaire sur un produit,ca me marque

 

  • Le titre est incorrect
  • Le commentaire est incorrect
  • Le nom est incorrect
  • Le produit n'a pas été trouvé

Et si je veux partager un produit sur facebook, l image ne correspond pas au produit, c est toujours la même image de Fée

Share this post


Link to post
Share on other sites

Les erreurs dont vous parlez sont générées par les fichiers javascript contenus dans les fichier tpl de ces modules.

 

On va reprendre dans l'ordre, module par module.

 

Pour chacun, commencez par les désinstaller puis :

 

- Videz le cache, le cache smarty désactivez les diverses compressions CCC (js et css) et forcez la compilation.

Ces paramètres sont dans: onglet Paramètres avancés -> performances

 

- Reinstallez votre 1er module et testez-le, si ok continuez pour les autres

 

- Si tous re-fonctionne, rétablissez vos anciens paramètres (activation du cache, CCC, etc...)

 

Si toujours pas Ok tentez un appel téléphonique auprès de Prestashop...

Share this post


Link to post
Share on other sites

Merci pour l'info @Broceliande.

 

C'est un problème dans le même genre que la mise à jour obligatoire pour les modules gratuits (installé et modifié) si vous voulez les configurer!!

 

Ckarone

Share this post


Link to post
Share on other sites

Merci beaucoup de me consacrer votre temps

J ai tout fait comme vous me l'avez indiqué mais rien a faire

J ai fait uniquement avec "envoyer a un ami" mais je n ai pas continué vu que ca ne fonctionne pas

Je vais voir pour contacter presta

En tout cas merci pour tout

Je vous ai envoyé un module fonctionnel à l'adresse de votre boutique, vous me direz ce qu'il en est :)

Share this post


Link to post
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More