Jump to content
Frediteur

Consultez votre hébergeur /var/lib/php5 ?

Recommended Posts

Bonjour,

 

impossible d'installer la nouvelle version sur mon serveur dédié :(

 

Dommage...J'ai écrasé le site après l'upgrade qui avait apporté un joli backoffice en bilingue Anglais/francais.

 

Mon hébergeur me dit : "Si on met ce chemin en open basedir vous ne pourrez plus installer d'autre prestashop sur votre serveur."

 

Donc le Bug c'est http://forge.prestashop.com/browse/PSCFV-8517

 

QUESTION : ce problème va-t-il etre résolu ? OU faut il réinstaller la version précédente ?

 

:(

 

MERCI d'AVANCE

FR

Share this post


Link to post
Share on other sites

Aaaaah peut être pour les sessions de l'installeur ?

 

Essayer de demander à votre hebergeur de stocker les sessions de php dans un dossier de votre virtual host plutôt qu'en dehors de votre vhost donc

 

Normalement il faut régler les variables d'environnement de votre utilisateur

 

env[TMP] = /votrevhost/tmp

env[TMPDIR] = /votrevhost/tmp

env[TEMP] = /votrevhost/tmp

 

dans votre php.ini

 

session.save_path = /tmp

 

Je ne comprends pas la réponse de votre hébergeur mais en gros c'est juste que le serveur n'arrive pas à stocker les fichiers de sessions à priori. Ensuite je ne vois pas pourquoi rajouter ce path aurait un impact pour d'autre installations. Les sessions ne sont que pour les installations, pas la boutique en tant que telle.

Share this post


Link to post
Share on other sites

Bonjour

 

A l'installation de la dernière version de Prestashop j'ai ce message :

  • Le dossier de stockage n'est pas accessible en écriture - consultez votre hébergeur /var/lib/php5

Je suis chez Ikoula, pouvez vous s'il vous plait me dire comment regler ce problème ?

 

Merci d avance :)

Share this post


Link to post
Share on other sites

Hello,

 

Plusieurs fois que je vois ça ce soir et j'ai du mal à comprendre mais je ne suis pas expert la dessus. L'installeur a besoin de faire des sessions. Vous pouvez demander à Ikoula ou les sessions sont stockées chez eux ?

 

Merci.

Share this post


Link to post
Share on other sites

Malheureusement, cela ne fonctionne pas.

D'ailleurs, ce problème ne se pose qu'avec cette dernière version de PS

 

Les sessions php sont stockées dans chaque vhost. Chaque vhost à ses paramètres personnels

Par exemple pour monsite.be:

le home directory est /var/www/vhosts/monsite.be

et pour les variables d'environnement

env[TMP] = /var/www/vhosts/monsite.be/tmp

env[TMPDIR] = /var/www/vhosts/monsite.be/tmp

env[TEMP] = /var/www/vhosts/monsite.be/tmp

Fichier php.ini /var/www/vhosts/monsite.be/etc/php.ini

les commandes du vhost: /var/www/vhosts/monsite.be/bin

...

Share this post


Link to post
Share on other sites

Hello,

 

Et Apache peut écrire dans le dossier /var/www/vhosts/monsite.be/tmp ? quels sont les droits sur le dossier ?

 

J'essaye de me renseigner la dessus car effectivement je vois que cela coince pour plusieurs personnes.

Share this post


Link to post
Share on other sites

L'installeur ne teste pas /var/lib/php5 mais le session path. Si ce session path est inscriptible normalement il passe le check, il devrait pouvoir ecrire dans /var/www/vhosts/monsite.be/tmp votre Apache, j'ai du mal à comprendre.

 

 

 

Pour autant "Mon hébergeur me dit : "Si on met ce chemin en open basedir vous ne pourrez plus installer d'autre prestashop sur votre serveur." n'a pour moi pas trop de sens désolé ou alors il faut détailler ce point.

 

Est ce que vous pouvez greper 'session.save_path' dans votre your php.ini s'il vous plait ?

Edited by Gregory Roussac (see edit history)

Share this post


Link to post
Share on other sites

Idem en local.

 

En supprimant cette ligne normalement le check sur le dossier ne sera plus fait et l'installation devrait vous laisser passer.

 

Merci pour cette information, ça m'a permis de résoudre ce problème en 2 minutes.

Share this post


Link to post
Share on other sites

J'ai rencontré ce problème qui pour moi était dû à des droits d'écritures insuffisants sur /var/lib/php5/ (root) privant toute écriture de sessions, alors plutôt que de créer une faille de sécurité sur ce dossier sensible,

j'ai simplement édité mon php.ini en mentionnant

session.save_path = /tmp

 

pour les dédiés sous plesk

panel > home > subscriptions > (select your subscription) > websites & domains tab > show advanced options > website scripting and security > PHP setting tab > session.save_path > (et suivant votre version soit /tmp soit {TEMP} )

Edited by sebweb (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More