Jump to content
Sign in to follow this  
Fifileboss

Problème du passage de local à en ligne

Recommended Posts

Bonjour,
Après avoir testé PS en local et avoir réalisé la saisie de quelques produits, j'ai uploadé l'ensemble sur mon hébergement free. Malheureusement, lorsque j'essaie d'accéder à ma boutique j'obtiens toujours un message d'erreur du genre :
"Fatal error: Undefined class name 'configuration' in /mnt/142/sda/5/8/audeladesreves79/prestashop/config/config.inc.php on line 127" que ce soit avec l'admin ou l'install.
J'ai bien tenté de remettre la version d'origine mais ça ne change rien.
L'ensemble des fichiers ne se trouvent pas à la racine de l'hébergement mais dans le répertoire "prestahop". Cela peut-il venir de là ?

Share this post


Link to post
Share on other sites

Salut,

En local tu n'as pas eu besoin de fichier htaccess cela fonctionne nickel.

Par contre sur Free, il faut renseigner le serveur pour passer en PHP5.
Pour cela il te faut configurer ton htaccess pour free à la racine de ta boutique.

j'avais déposé le mien sur le forum il y a quelque temps :
Message #17

Normalement ça devrait le faire.

Pour le transfert de la boutique penses à bien configurer ton fichier config/setting-inc.php

V++

Atch

Share this post


Link to post
Share on other sites

Merci V.I.P.
Nickel ça fonctionne bien après avoir implanté ton htaccess.
Maintenant, il faut que je parvienne à transféré ma boutique...

Share this post


Link to post
Share on other sites

de rien "Beginner",


Par contre pour un transfert, il n'y avait pas besoin d'installer une nouvelle boutique sur Free.
Tu transfèrerais directement celle qui est en local, tu ajoutais le HTaccess, tu modifiais le setting-inc pour les parametres de connexions à la base et hop le tour est joué.

J'oubliais, tu sauvegardes la base de données qui est en local et bien évidemment tu la transferts sur Free ;)

v++

Atch

Share this post


Link to post
Share on other sites

Atch,
J'avais installé une nouvelle boutique pour voir si ça fonctionnait bien. J'ai fait une sauvegarde de ma base en local puis je l'ai uploadé sur mon hébergement. Malheureusement, ça ne fonctionne pas, je pense que c'est parce que je n'arrive pas à configurer le setting-inc. :-S
J'obtiens le message suivant : Bad SubDomain SQL query!
J'ai bien parcouru le forum et en général, ce message concerne ceux qui supprime le sous-domaine "www" au niveau de la config des cookies. Dans ma base en local je n'avais rien et en ligne je n'ai pas une adresse en www. N'ayant touché à rien, je ne vois donc pas pourquoi j'obtiens ce message...

Share this post


Link to post
Share on other sites

Bon ben, apparemment personne n'ayant de réponse à m'apporter, je repars sur une boutique à zéro...

Share this post


Link to post
Share on other sites

tu as mis quoi comme nom à ta base de données dans setting-inc?

Atch

Share this post


Link to post
Share on other sites

quand je l'ai réalisée en local, j'ai suivi l'exemple du tuto, soit "maboutique".
Par contre, j'ai constaté que sur Free, la base de données portait le nom de l'hébergement, soit "audeladesreves79".
J'ai essayé toutes les combinaisons dans setting-inc mais rien n'y fait.

Share this post


Link to post
Share on other sites

Je reçois aussi le même problème, mais ne sais comment le résoudre. My ... examens sont aussi très proche et je ne suis pas en mesure de se concentrer ....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More