Jump to content

block catégorie qui fait ce qu'il veut


Recommended Posts

Bonjour,

Je suis très embêté avec le bloc catégorie.

J'ai déjà fait deux sites sous prestashop avec des templates déjà fait, aucun problème.

Là j'ai créé mon template, pas de problème non plus sauf que j'ai après plusieurs heures d'utilisation un bug qui apparaît étrangement.

J'ai donc créé des catégories et sous catégories qui s'affichent parfaitement.

1er bug : une fois sur une fiche produit le bloc disparait complètement.

J'ai pensé qu'il y avait un problème lié a javascript ou ajax par rapport aux class css (div) que j'ai changé de nom pour mon template mais c'est là qu'intervient le second bug.

2er bug : en réinstallant une nouvelle installation de base de prestashop avec le template de base, je créer une catégorie, le bloc est bien là mais la catégorie ne s'affiche pas.

Je précise que je suis en localhost sous wamp (j'ai développé les autres sites sous cet environnement sans prob)

Voilà ce que j'ai essayé pensant régler le problème, mais non :
- vider le cache du navigateur
- vérifier si le problème est le même sous IE6 IE7 IE8 Firefox3 Chrome : idem
- installer le script sur un vrai serveur web LAMP (là où il y a déjà des sites prestashop qui tournent)

Pour préciser, j'utilise la version prestashop 1.1 et j'ai même voulu tester la dernière 2.0.5 en beta test, le problème reste le même haaaaaaaaaaaaaaaaaaaaa

Je sais plus quoi faire....

Une idée, une info ?

Merci

Share this post


Link to post
Share on other sites

Salut,

Avez vous essayé en vidant le répertoire compil de smarty.(sauf l'index)

tools/smarty/compile

Parfois, quand j'ai des problemes d'affichages, le fait de faire ça, cela fonctionne.

Sinon avec votre nouveau theme avez vous touché aux tpl catégories?

V++

Atch

Share this post


Link to post
Share on other sites

Bjr,

Merci pour la réponse et merci pour le dossier compile car je l'ai cherché longtemps le dossier cache.

Mais c'est pas ça.... :(

J'ai pas touché au tpl categorie du themes.

J'ai fini par installé un autre module categorie que j'ai trouvé sur ce forum. C'est celui qui s'affiche bien partout sauf lorsque l'on consulte un produit : http://armenligne.e-solutionswin.com/ regarde, va sur un produit, le bloc disparait. (il me reste un chouillat de css a modifier sous IE ^^)

Donc pour mes test, j'ai donc installé la dernière version sur ce lien http://arme.e-solutionswin.com/ sans aucun module en conservant le thème d'origine, et j'ai créé une catégorie, et regarde le bloc est là mais vide...

J'en perds mon latin..heu mon html..heu php...heu...........

Share this post


Link to post
Share on other sites

dans l'ordre....

1°/ la catégorie qui disparait dans la page produit.
J'ai remarqué que la catégorie est bien présente mais il y a un display: none dans la balise ul du module quand on est sur product.php
Il se peut que, pour une raison x, que l'option de désactiver le module catégorie dans la page "product.php" ait été sélectionnée.
( c'est une option que je n'ai jamais testé) mais regardez dans :
modules/position/ left column et cliquez sur éditez le bloc catégories (là il y a la possibilité de cacher le module sur une page spécifique).

2°/ sur le site de test, si vous avez installé la dernière version de presta (1.2) il faut créer un groupe de client par défaut. ensuite quand vous créez une catégorie, il faut indiquer que ce groupe de client peut voir la catégorie...


Je ne sais pas si je suis clair...

Bon courage

V++

Atch

Share this post


Link to post
Share on other sites

Salut,

Merci

2°/ ok ça fonctionne mieux comme ça, j'avais pas porté mon attention sur cette nouveauté, pas mal...

1°/ j'ai regardé le css avec le display none, j'ai changé le none par block et les catégories s'affichent bien mais sont toutes couchées, donc plus de dynamique.

oui pour le css car j'ai placer des class et id portant des nom de mots clefs.

donc toujours ce problème avec le 1°

Merci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More