Jump to content
JonathanC13

(Résolu) Mise à jour 1.3.5 vers 1.4.7

Recommended Posts

Bonjours à tous et à toutes :)

 

Tout dabord, avant de poster j'ai fait pas mal de recherche concernant mon problème, testé certaines solutions sans succés, retenté plusieurs fois la migration mais.... le problème persiste.

 

Je souhaite réalisé une migration d'un site en 1.3.5 vers la version 1.4.7, j'ai pour celà suivis le tuto vidéo posté assez fréquemment en réponse aux demandes de migration mais je me retrouve toujours confronté à la même erreur, je m'explique :

 

J'ai exporté la BDD du site en 1.3.5 puis je l'ai importé dans un phpmyadmin (j'utilise WAMP). Jusque là aucun problème la base remonte sans erreur.

 

C'est lorsque j'utilise la page d'installation via "localhost/monsite/install et que j'arrive à la vérification du système (tout est OK selon la vérif). Théoriquement en cliquant sur suivant la BDD doit être mise à jours pour être compatible avec la version 1.4.7 (si j'ai bien tout compris) mais l'update ne se fait pas et j'ai un .log qui se génère et que j'ai mis en PJ à ce post.

 

Ce que je ne comprends pas dans ces erreurs c'est que à priori le fait que la BDD ne soit pas vide, empèche la mise à jours :blink: . C'est pourtant le principe de la mise à jours non?

 

Je dois avouer que je suis un peu dépassé par tout ça et si l'un ou l'une d'entre vous pouvais me débloquer je lui en serais très reconnaissant :P

 

Merci d'avance !

20130309_installation.zip

Edited by JonathanC13 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Tu as vu tout en bas de ton log ?

 

*ERROR* 2013/03/09 - 16:56:03: You already have the 1.4.7.0 version.

 

A priori tu as fait la mise à jour plusieurs fois.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

Tout d'abord erci de prendre le temps de m'aider;

 

Effectivement cette erreur provient du fait que j'ai tenté la migration plusieurs fois (un oublie de modification du setting-inc avant de relancer une tentative).

 

les erreurs duplicate colum et already exist sont ressorties dès le premier essai..

 

 

Une idée?

 

J'ai oublié une précision importante : j'avais déjà réussi cette migration en octobre dernier pour pouvoir travailler sur une nouveau version graphique de mon site. actuellement j'ai donc la bdd d'octobre que je souhaite mettre à jours pour pouvoir le mettre en prod.

 

Merci d'avance à la communauté :)

Share this post


Link to post
Share on other sites

Hello,

 

La base est à jour, d'ou les duplicate et already exists. Rien de bloquant.

 

Attention en 1.5, l'installeur n'est pas vraiment un upgrader.

 

Là la base est à jour, si les fichiers sont à jours eux aussi, la maj est terminée.

 

As tu essayé le dernier AutoUpgrade ?

 

http://addons.presta...utoupgrade.html

Share this post


Link to post
Share on other sites

Pareil en 1.4, désolé j'ai mal lu. Sauf qu'en 1.4 tu peux passer par l'installeur effectivement.

 

Encore une fois si les fichiers sont a jour, que les erreurs renvoyées sont des duplicate. La mise à jour est terminée.

 

Passe en 1.4.10 !

Share this post


Link to post
Share on other sites

J'ai réussi à migrer en ne tenant pas compte des erreurs comme tu me l'a indiqué et effectivement j'ai pu remettre le service en fonction assez rapidement après ça donc merci à toi !

 

Concernant l'autoupgrade je ne m'y suis pas aventuré... le thème que j'ai est à priori compatible jusqu'en version 1.4.7 selon son créateur alors je n'ai pas osé ^_^

 

En tout cas merci encore

Share this post


Link to post
Share on other sites

Je vais probablement tester une mit sur la 1.4.10 en local histoire de valider mais je préfère encore tester directement avec la dernière version en date, quitte à devoir reprendre le thème...

 

Juste pour information, connais tu les spécificités du module top horizontale menu v1.0?

 

Lors de ma première migration j'avais réussi à personnaliser mon menu avec des listes déroulantes (liste de catégorie de produits mais aussi liste déroulante vers d'autres page de mon CMS), mais j'ai cherché jusqu'à 2h ce matin et impossible de me souvenir la manip.

 

A priori le module importe l'éxistant, ce qui est vrai puisque toutes mes pages apparaissent dans le module et je peux les ajouter ou supprimer à mon grès dans la barre de menu, sauf que celà ne fait pas de menu déroulant mais de simple ajout de lien supplémentaire dans ma barre.

 

Any idea? ^_^

Share this post


Link to post
Share on other sites

Hello,

 

Non désolé. Est ce que tu peux passer ce ticket en résolu et en ouvrir un autre dans la bonne section du forum conernant ta question.

 

Cordialement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More