Jump to content
sanamanel

Groupe Par Defaut Différent Selon Boutique En Multi Boutique (Résolu)

Recommended Posts

Bonjour à tous,

 

J'ai fais des recherches avant de poster mais je n'ai rien trouver pour faire face à mon problème :(

Je m'explique, j'ai créer une boutique sous 1.5.3.1 j'ai activer la multiboutique.

Donc j'ai une boutique pour pro et une boutique pour particulier.

Certain articles sont partagés sur les 2 boutiques mais pas tous.

Il y'a 3 groupes client par défaut à savoir : visiteur,invité et client.

Mais ce que j'aimerai c'est que pour le site particulier les prix pour ces différent groupes s'affichent avec TVA et pour la boutique pro que c'est même groupe s'affiche HTVA.

Je n'y arrive pas car c'est groupe ne ce configurent pas par boutique mais pour les 2 boutique en même temps. Je sais pas si j'arrive à être clair lool.

Y'aurait il une solutions ?

Merci d'avance à ceux qui pourront m'apporter leur aide ;)

Edited by sanamanel (see edit history)

Share this post


Link to post
Share on other sites

Personne??

Je sais même pas si mon post est compréhensible?

Ce que j'aimerai c'est que toute personne qui ce connecte sur la boutique pro qui est sur le sous domaine(grossiste.domaine.com) puisse être automatiquement sur un nouveau groupe par défaut qui serait :

"visiteur pro". J'ai bien crée le groupe "visiteur pro" et je l'ai configuré sur afficher les prix htva,

Mais je n'arrive pas à le mettre par défaut uniquement pour la boutique grossiste.

Le groupe par défaut qui ce met automatiquement est "visiteur" et ce sur la boutique public (domaine.com) ainsi que sur la pro (grossiste.domaine.com)

Je suppose qu'il faut voir du côté de la bdd mais je ne sais pas ou chercher, quelqu'un aurait une piste??

Edited by sanamanel (see edit history)

Share this post


Link to post
Share on other sites

Encore moi lool

Est ce que ce ne serait pas dans la table ps_configuration je vois qu'il y'a une ligne PS_UNIDENTIFIED_GROUP

qui est a 1 par défaut??

Share this post


Link to post
Share on other sites

ok résolu, c'était bien au niveaux de la BDD si cela intéresse quelqu'un ;)

Share this post


Link to post
Share on other sites

Salut,

Je viens de voir ton post, j'ai le meme soucis, tu pourrais m'en dire plus sur la solution ?

Merci d'avance de ton aide ;-)

Share this post


Link to post
Share on other sites

moi aussi j'ai le même soucis,

si vous voulez nous partage la solution :)

Share this post


Link to post
Share on other sites

Désolé mon post est vieux donc je ne me rappel pas du détail de ce projet .

 Mais comme j'ai mis que cela ce passait au niveau de la BDD et de la la table ps_configuration ou il y'a une ligne PS_UNIDENTIFIED_GROUP qui est a 1 par défaut. Donc je crois que j'avais changé le 1 par défaut avec Le numéro pour le nouveaux groupes crée mais désolé comme je n'ai plus accès à la boutique , je ne peux vérifier.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More