Jump to content

Не устанавливаются модули


Recommended Posts

Пытаюсь установить модули на PrestaShop 1.5.3.1 возникает ошибка:

 

Fatal error[PrestaShop] Fatal error in module head:

Undefined offset: 6

 

Вчера один модуль установился нормально...

 

С чем это может быть связано? Помогите пожалуйста.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Аналогично. Модули ставились хорошо. А сейчас ни один не ставится. Fatal error.

Denwer в качестве локального хоста, Prestashop 1.5.3.1

Подскажите, как пофиксить!

 

Блин, думал уже заливать на хостинг и избавиться наконец-то от джумлы и виртуемарта :(

Share this post


Link to post
Share on other sites

Подозреваю, что проблема не в Престашопе. При восстановлении БД и файлов из бекапа тоже не устанавливаются модули. При чистой установке ТОЖЕ перестали . Если мануально заливать в директорию, тоже не устанавливается. Эти же модули я ставил пару дней назад на эту же версию Престашопа и все было хорошо.

 

Переустановка денвера, очистка кук и истории, заход другим браузером не помогли. Подскажите, форумчане!

Share this post


Link to post
Share on other sites

Какие ошибки пишет если включить в config/defines.inc.php

define('_PS_MODE_DEV_', true); ?

Похоже, что просто выводит исполняемый код:

[1] => Array
    (
	    [file] => Z:\home\tonometr-presta.loc\www\controllers\admin\AdminModulesController.php
	    [line] => 320
	    [function] => getInstanceByName
	    [class] => ModuleCore
	    [type] => ::
	    [args] => Array
		    (
			    [0] => Address.php
		    )
    )

И дальше еще очень много кода с перечислением всех модулей, что установлены.

Кстати, модули, которые установлены по умолчанию инсталятся и удаляются без проблем.

Share this post


Link to post
Share on other sites

И дальше еще очень много кода с перечислением всех модулей, что установлены.

Кстати, модули, которые установлены по умолчанию инсталятся и удаляются без проблем.

Там где-то и ошибку должно вывести. Но если стандартные модули ставятся, так проблема с модулями стороннего производителя?

Edited by doubleD (see edit history)

Share this post


Link to post
Share on other sites

Тоже думал, что дело в самих модулях. Дело в том, что эти же самые модули на эту же версию я уже ставил. Потом стер, потом ставил другие. До этого, естественно, бекапил. Теперь вообще ничего не ставится. Все стер, базу данных залил бекапнутую, файлы тоже. Но эффекта никакого. От этого подозрения, что дело не в самом Престашопе. В коде я ошибку не нашел - не визуально, не поиском по тексту. Может это из-за отсутствия openSSL? На вкладке модулей появилось предупреждение, что его надо включить (я точно его не отключал в Денвере, может разве что устанавливая какую-то стороннюю программу)

Share this post


Link to post
Share on other sites

Вот еще одна подробность. Файлы устанавливаемого модуля копируются в директорию которая имеет название вида: 5c0c3744945a462114cd47dc9bf3ce47, берется оно из токена index.php?controller=AdminModules&token=5c0c3744945a462114cd47dc9bf3ce47. Может это кому-нибудь о чем-то говорит?

Share this post


Link to post
Share on other sites

Как-то туманно и запутано все... Работало и, бах, перестало работать... Можно вместо denwer попробовать XAMPP или WAMP...

Share this post


Link to post
Share on other sites

Попробовал OpenServer вместо Denwer. Не помогло. Нашел один совет на англоязычном сайте: "может не совпадать время файлов кеша и время сервера". Подскажите, как проверить!

Share this post


Link to post
Share on other sites

У меня совсем беда... Теперь, когда открываю страницу "Модули" вылезает эта ошибка и не могу изменять настройки модулей...

Share this post


Link to post
Share on other sites

У меня совсем беда... Теперь, когда открываю страницу "Модули" вылезает эта ошибка и не могу изменять настройки модулей...

Модули стандартные?

Установлена свежая Presta или обновление?

Share this post


Link to post
Share on other sites

Установка свежая с дистрибутива взятого с офф сайта.

 

Сейчас вообще список модулей не показывает!

Share this post


Link to post
Share on other sites

Установка свежая с дистрибутива взятого с офф сайта.

 

Сейчас вообще список модулей не показывает!

Получается только в Бэк Офисе проблема?

Share this post


Link to post
Share on other sites

Да сайт работает, а в бэк офисе список модулей не показывает.

Могу разве что посоветовать поставить чистую версию еще одну, в какой-то подкаталог /bugs например

Так можно будет узнать где проблема в живом магазине, или с сервером что...

+ можно будет показать/посмотреть вживую...

 

Так-то очень размытая ошибка...

 

Где-то встречал что отключение magic_quotes может помочь при похожей проблеме, но сейчас что-то не нахожу тот пост...

Share this post


Link to post
Share on other sites

Да сайт работает, а в бэк офисе список модулей не показывает.

Возможно поможет log, который выдает при define('_PS_MODE_DEV_', true); ? в modules/defines.inc.php

 

Только полный, а не 2 строчки ))))

Если очень большой можно в txt файлик положить...

Share this post


Link to post
Share on other sites

а где этот лог создаётся, а то я включал эту функцию, а где ошибки смотреть не знаю...

Ошибки должны вылазить в том месте, где что-то не работает. То есть, в данном случае, в модулях...

Share this post


Link to post
Share on other sites

а тогда всё совсем плохо. ошибки не показывает...

 

Попробуйте изменить настройки кеширования (Расширенные параметры - > Производительность), может поможет. Или покажет другую, более конкретную ошибку:)

Share this post


Link to post
Share on other sites

сбросил настройки кэша на дефолтные. теперь список модулей видно, но показывает в списке будто у меня 3833 модуля... и ошибка внизу страницы осталась.

Edited by MrVoF (see edit history)

Share this post


Link to post
Share on other sites

как сюда картинку загрузить я Вам покажу что у меня произошло с модулями.

Нужно нажать More Reply Options

Share this post


Link to post
Share on other sites

Установка свежая с дистрибутива взятого с офф сайта.

Что-то список модулей не похож на модули с офф сайта...

Share this post


Link to post
Share on other sites

Что-то список модулей не похож на модули с офф сайта...

 

У меня их не было! У меня вчера перестал отображаться список модулей. По Вашим рекомендациям поменял кэш и теперь вот такая вот ерунда...

 

Если нажать на иконку корзинки рядом с модулем отправляет на офф сайт:

http://addons.prestashop.com/ru/slideshows/4572-advanced-slideshow.html?utm_source=v1trunk_api&utm_content=slideshow

Share this post


Link to post
Share on other sites

У меня их не было! У меня вчера перестал отображаться список модулей. По Вашим рекомендациям поменял кэш и теперь вот такая вот ерунда...

 

Если нажать на иконку корзинки рядом с модулем отправляет на офф сайт:

http://addons.presta...ntent=slideshow

У меня нет account'a к prestashop addons, поэтому проверить не могу. Но выглядит так, словно введен логин и пароль

http://oi50.tinypic.com/312d8jp.jpg

и presta просто предлагает купить модули с prestashop.addons

Share this post


Link to post
Share on other sites

У меня нет account'a к prestashop addons, поэтому проверить не могу. Но выглядит так, словно введен логин и пароль

http://oi50.tinypic.com/312d8jp.jpg

и presta просто предлагает купить модули с prestashop.addons

 

Да нет не введено, но на самом сайте я был залогинен.

Share this post


Link to post
Share on other sites

Да нет не введено, но на самом сайте я был залогинен.

Залогинился, дело не в этом...

А что если полностью отключить все кэши, и залогинится с новой админ панели?

Тоесть скопировать заново папку admin с prestashop 1.5.3.1.zip, залить ее на сервер и зайти через нее

Share this post


Link to post
Share on other sites

Ответ от поддержки PrestaShop.

 

В файле config/alias.php нужно заменить 77 строку.

 

это: if ($error !== NULL)

на это: if ($error !== NULL && in_array($error['type'], array(E_ERROR, E_PARSE)))

Edited by MrVoF (see edit history)

Share this post


Link to post
Share on other sites

Ответ от поддержки PrestaShop.

 

В файле config/alias.php нужно заменить 77 строку.

 

это: if ($error !== NULL)

на это: if ($error !== NULL && in_array($error['type'], array(E_ERROR, E_PARSE)))

И все? ) Помогло?

Странно, почему у меня нет этой ошибки...

Share this post


Link to post
Share on other sites

И все? ) Помогло?

Странно, почему у меня нет этой ошибки...

 

Да ошибок больше нет, но огромное количество модулей осталось. страница грузится по 13 секунд...

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Несколько раз подступался к выпуску 1.5.3... Устанавливал, начинал что-то делать, всё сметал, возвращался к выпуску 1.5.2.

 

Не понимаю, как так, 1.5.2 работает стабильно, следующий глючит по-чёрному!.. У меня на него уже аллергия.

Share this post


Link to post
Share on other sites
  • 1 month later...

Добрый день!

При попытке установить модуль через загрузку, выбрасывает на пустую страницу с ошибкой:

 

Notice: Use of undefined constant _RIJNDAEL_KEY_ - assumed '_RIJNDAEL_KEY_' in /home/domen/public_html/classes/Cookie.php on line 78

 

Notice: Use of undefined constant _RIJNDAEL_IV_ - assumed '_RIJNDAEL_IV_' in /home/domen/public_html/classes/Cookie.php on line 78

Fatal error[PrestaShop] Fatal error in module Cookie:

Use of undefined constant _RIJNDAEL_IV_ - assumed '_RIJNDAEL_IV_'

 

Версия 1.5.2

Share this post


Link to post
Share on other sites

Вот, спрашивается, кто неволит участвовать в экспериментах на живых людях! В качестве подопытных добровольцев, разумеется... Конечно, есть и такие, кто готов пожертвовать собой ради прогресса. Кто-то ж должен испытывать все эти усовершенствования в движке. Но те, кто здесь вопит и плачет, явно не добровольцы. Думаю, большинство хотели бы просто сделать магазин и спокойно работать. Так почему бы не остановиться на более стабильной версии? 1.4.10 или 1.5.2...

Edited by Dimitri Yelquin (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More