Jump to content

Keresés funkció hiba


csaknoriss
 Share

Recommended Posts

Hello!

 

Ha a keresésnél a találatok közt böngészek, és beakarom állítani, hogy ne 10 db termék jelenjen meg egyszerre hanem mondjuk 20 vagy 50 akkor hibaüzenetet dob fel:

 

a keresés linkje:

oldalam.hu/search.php?search_query=ava&n=50&orderby=position&orderway=desc&submit_search=Keres%25C3%25A9s

 

 

Kép róla:

asd_www.kepfeltoltes.hu_.png

 

Viszont ha a likn végéről kiszedem ezt:

Keres%25C3%25A9s

 

Akkor tökéletese behozza az oldalt. De ez nem megoldás....

 

Valakinek ötlet?

Edited by csaknoriss (see edit history)

Share this post


Link to post
Share on other sites

ahogy gondoltam, karakterkódolási probléma.

Vagy ezzel kapcsolatos tpl-t szerkesztettél és nem jó karakterkódolásban mentetted el, vagy máshol keresendő a hiba.

Az admin felületen néznék körbe a fordításoknál. A lényeg: az url-be beveszi a keresés szót, de az "é" miatt szétbomlik a dolog.

Ergo: olyan helyen van a kódban "é" betű, ahol nem kellene, mivel valószínűleg az angol "search" volt helyette, ugye.

Ha ilyet csinálok akkor a kódban nem "é" betűt írok hanem az "é" betűnek megfelelő "é"-t, és ezt a böngésző már rendes "é" nek fogja fordítani.

Egyébként miért nem kapcsolod be a SEO barát URL-t? Az amúgy se jönne rosszul, és ez a hiba is kiküszöbölődne szerintem.

Valamint ha nem tudod megoldani akkor kellene egy ps verzió mert akkor reprodukálom a hibát magamnál.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More