Presta 1.5.3 nezobrazuje dodavatele - Hlavní diskuze - PrestaShop

Jump to content

Photo

Presta 1.5.3 nezobrazuje dodavatele

carrier presta 1.5.3 dodavatel není

#1

Posted 22 January 2013 - 03:38 PM

Vindork

    PrestaShop Apprentice

  • Members
  • PipPip
  • 78 Active Posts
Mám dva nové eshopy na presta 1.5.3. Jeden funguje bez problémů, ale u druhého z nějakého důvodu se nezobrazují dopravci. Nesetkal se s tím již někdo? Nějaké řešení? Dopravce i státy a všechno bych měl mít správně nastavené.

#2

Posted 22 January 2013 - 03:45 PM

JAKCRABBIT

    PrestaShop Fanatic

  • Members
  • PipPipPipPip
  • 2682 Active Posts
Limity? Oblasti? Povolené měny? Provázanost s platbami?

logosamolepkyprestashop.jpg


#3

Posted 22 January 2013 - 03:55 PM

Vindork

    PrestaShop Apprentice

  • Members
  • PipPip
  • 78 Active Posts

Limity? Oblasti? Povolené měny? Provázanost s platbami?


Všechno nastavené. Přijde mi to jak problém s databází. Hlavně mám jiný, který běží v pohodě a tento je nastaven stejně. Jedinej rozdíl je, že je v subdoméně.

#4

Posted 13 February 2013 - 01:05 AM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Mam stejny problem... vcera to fungovalo, nic jsem nenastavoval, nepredelaval a dnes se mi nezobrazuji dopravci v objednavce... Mam tam zatim jednoho zdarma.

Pise to: Chyba: Nejsou k dispozici žádní dopravci pro přepravu na tuto adresu

Jo a mam Prestu 1.5.3.1.

Edited by mello, 13 February 2013 - 01:07 AM.


#5

Posted 13 February 2013 - 05:13 AM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Uz jsem vyzkousel snad vsechno, sedim nad tim uz 22 hodin, zadne solved reseni nepomohlo. Vazne nikdo nema radu?

#6

Posted 13 February 2013 - 10:41 AM

JAKCRABBIT

    PrestaShop Fanatic

  • Members
  • PipPipPipPip
  • 2682 Active Posts
Máš u něj nastaveno dopravu 0 kč? Nastav tam 0,1

logosamolepkyprestashop.jpg


#7

Posted 13 February 2013 - 02:38 PM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Zkousel jsem u neho nastavit cenu, hmotnostni i cenove rozsahy, zony, zeme, defaultni zemi eshopu apod. Vyzkousel jsem nekolik navodu, aby byli na starsi verze Presty.

Je mi zahadou, ze mesic se mi v eshopu zobrazoval spravne a pak najednou nic.

Zkusim nainstalovat novy testovaci shop a zkusit v nem prijit jestli je chyba v databazy, upravene sablone... Nastaveni mam totiz v testovacim shopu stejne a tam se dopravce zobrazuje... Zajimave je, ze tam jsem zkousel vselico, je totalne rozsypanej ale vse funguje...

#8

Posted 13 February 2013 - 03:24 PM

JAKCRABBIT

    PrestaShop Fanatic

  • Members
  • PipPipPipPip
  • 2682 Active Posts
Jen tak náhodou, nepoužíváš ship2pay?

logosamolepkyprestashop.jpg


#9

Posted 13 February 2013 - 03:57 PM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Mam jiny, ale dela to same. Fungovalo to s nim. Pak jsem ho dal deaktivovat, protoze budu potrebovat az budu mit platby kreditni kartou. Ale i s tim mi to puvodne fungovalo a zkousel jsem jestli neni chyba v nem.

Proste jedine co jsem nastavoval, nebo upravoval od doby co vim, ze dopravce fungoval bylo:
- v CMS jsem pridal nekolik stranek do horni listy
- zadal 2 vyrobky a pridal k nim vlastnosti
- hrabal jsem se v Blocklayered
- nastavoval jsem omezeni IP v .htaccess
- nastavil sms modul
-.v globall.css jsem nastavil jen par veci u pisma
- pridal jsem modul na pinterest

Edited by mello, 13 February 2013 - 03:58 PM.


#10

Posted 13 February 2013 - 04:15 PM

JAKCRABBIT

    PrestaShop Fanatic

  • Members
  • PipPipPipPip
  • 2682 Active Posts
No, tam jde o to, že pokud máš nastavený ship2pay a pak něco změníš v dopravcích, tak se změní i ID dopravce a přestanou kompletně fungovat, protože se změna ID v ship2pay neprojeví sama. Musíš pak promazat ship2pay jak to máš provázané a nastavit to znova, pokud si ho dal deaktivovat, možná se stalo to samé.

logosamolepkyprestashop.jpg


#11

Posted 13 February 2013 - 04:51 PM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Konkretne mam payments2carriers, podle vybrane dopravy se zobrazi platebni moznosti. Takze dopravce to neschovava. Ale i tak jsem ho i odinstaloval a zadna zmena. Na testovacim obchodu kdyz pridam, nebo upravim dopravce, tak se zobrazi. A pokud neupravim nastaveni payments2carriers, tak se jen nezobrazi platebni metoda.

#12

Posted 14 February 2013 - 01:04 AM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Udelal jsem demo ucet, na nej cistou instalaci presty, nahral do toho databazy z chyboveho shopu, nahral jsem tam soubory, ktere jsem upravoval... A dopravci funguji...

Nevim, asi hold cely eshop smazu a znovu nainstaluju... 2 mesice prace v haji...

#13

Posted 14 February 2013 - 09:08 AM

JAKCRABBIT

    PrestaShop Fanatic

  • Members
  • PipPipPipPip
  • 2682 Active Posts
Ono se docela těžko radí takhle na slepo, může to být trilion problémů, ale taky úplná blbost.

logosamolepkyprestashop.jpg


#14

Posted 14 February 2013 - 08:23 PM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Tak mam vsechno zalohovane, tak se zkusim povrtat v databazy.

Vse co se tyka dopravcu je jen v tabulkach CARRIER a RANGE?
Recyklovany obal, ktery mi nejde vypnout vzdy u prvniho dopravce je v databazy v tabulce RECYCLABLE_PACK?
Kde mam nulu, ale stejne to nejde vypnout...

#15

Posted 16 February 2013 - 02:24 AM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Dekuju JAKCRABBITe za tvuj cas a pomoc.
Nakonec jsem tam nahral tyden starou databazy, kde se chyba nevyskytuje.

Pouze prepsani tabulek, na ktere jsem se ptal minuly prispevek nepomohlo, takze jsem ji bohuzel musel prepsal celou.
Dodelal jsem vse co ve stare databazy chybelo... chyba se objevila znovu...

Znovu jsem tedy nahral starou databazy, znovu dodelal vse co chybelo... chyba se zatim neobjevuje.

Je to naprosta zahada, nedokazal jsem prijit na to co to zpusobuje, a nejvtipnejsi se, ze jsem na strankach vlastne vubec nic nezmenil :)

Vyskytli se ale jine chyby, jako ze prvni dopravce (original osobni odber) se ve FO nezobrazuje, presto ze je zapnuty. To ale nakonec nicemu nevadi, protoze to resi chybu s recyklovanym obalem, ktery nejde vypnout u prvniho aktivniho dopravce v seznamu. Takze ted uz mi vsichni ostatni co se zobrazuji funguji :)

Pak se objevila chyba s adresou v objednavce. Zakaznik objedna a v administraci se neobjevi jeho adresa, ale s tim si snad poradim.

Edited by mello, 16 February 2013 - 02:25 AM.


#16

Posted 18 February 2013 - 09:06 AM

JAKCRABBIT

    PrestaShop Fanatic

  • Members
  • PipPipPipPip
  • 2682 Active Posts
No tak když tak pomalu doděláváš to co chybělo, tak to mezitím zkoušej, abys věděl u kterýho kroku se to zasekne, ne?

Já sem strašně skeptickej k týhle verzi, fakt doporučuji 1.4.9 a pak upgrade na 1.4.10... tahle verze je ještě stále v testovacím režimu, jen to někdo vydává za produkční model.

logosamolepkyprestashop.jpg


#17

Posted 18 February 2013 - 10:19 PM

mello

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 Active Posts
Nevim neprisel jsem na to co to delalo, zatim to porad funguje, radsi dopravce uz upravuju pouze pres databazy.

Mel jsem jednu tyden starou databazy (1),
pak original databazy jen s tabulkami CARRIER a RANGE (2)
a databazy jen se zmenenymi tabulkami za posledni tyden (3).

Nahral jsem 1, 3 a 2... nastavil dopravce v BO, az po tomhle kroku dopravci zmizeli.
Tak jsem znovu nahral 1, 3 a 2... uplne stejne nastavil dopravce, dopravci funguji... objevili se 2 jine chyby :)

Njn, ted uz to vim taky ze jsem mel radeji pouzit 1.4.9, uz jen kvuli tomu, ze pulku modulu bych si nemusel kupovat. Nezjistil jsem si informace a rikal si, novejsi je prece lepsi, vyladenejsi... kdyz jsem mel 75% obchodu hotovo, tak jsem zjistil, ze to tak neni :) Uz to nechci predelavat na 1.4.9.

#18

Posted 25 October 2013 - 12:13 AM

Vindork

    PrestaShop Apprentice

  • Members
  • PipPip
  • 78 Active Posts

Aktuálně, když jsem dělal jeden obchod na 1.5.6, tak mi vše fungovalo fungovalo až do chvíle, kdy spadli zase dopravci, pak si obchod nebyl schopný načíst ani produkty, kategorie nic. A nakonec spadl kompletně, že nešlo ani vlézt na stránku. Docela tomu nerozumím. Je to docela sranda, ale týden práce je v háji a mám dojem, že to asi zapálím. Todle fakt nejde..

 

Pak se to teda zas nachvíli spravilo a jediné, co neběželo byli dopravci a teď už to zas projistotu háže, že nemám oprávnění vlézt do jakkékoliv kategorie nebo produktu.


Edited by Vindork, 25 October 2013 - 12:15 AM.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Cookies help us deliver our services. By using our services, you agree to use our cookies.     Learn more