Jump to content
adser

Kan geen PDF documenten aanmaken

Recommended Posts

Sinds de upgrade naar 1.5.2 & .3 kan ik geen documenten, zoals een factuur en pakbon, meer aanmaken. De oude documenten kan ik wel nog altijd genereren, maar voor nieuwe orders is dat niet mogelijk.

 

Voor een factuur krijg ik een serverfout, voor een pakbon gebeurt er niks.

Heb net de update gedaan naar 1.5.3.1 met de gedachte hierin een uitweg te vinden .. maar niks :-(

 

Is er iemand met enige raad?

 

Peter

post-25143-0-43055000-1358799359_thumb.jpg

post-25143-0-52049200-1358799366_thumb.jpg

Edited by adser (see edit history)

Share this post


Link to post
Share on other sites

Ik heb precies hetzelfde. Het heeft wel gewerkt, maar nadat ik de footer had aangepast, krijg ik dezelfde melding, ook nu ik de footer weer heb teruggezet naar het oorspronkelijke bestand.

 

Wie weet een oplossing?

Share this post


Link to post
Share on other sites

Voor beiden geldt. Zet de shop even in maintenance mode en wijzig in /config/defines.inc.php

define('_PS_MODE_DEV_', false);

in

define('_PS_MODE_DEV_', true);

.

Na deze wijziging kun je proberen een uitgebreidere foutmelding te genereren. Server error 500 kan nl. van alles zijn.

Share this post


Link to post
Share on other sites

Bedankt voor je antwoord. Ik heb de wijziging doorgevoerd. Nu krijg ik geen foutmelding meer in de browser, maar een wit scherm, zonder melding.

Waar kan ik een uitgebreidere melding vinden?

Share this post


Link to post
Share on other sites

Ik heb hetzelfde probleem, er wordt na het aanzetten van de debug mode geen 500 fout meer gegeven maar een lege pagina.

Share this post


Link to post
Share on other sites

Ik heb een oplossing gevonden. Prestashop kijkt in een de cache en als daar een fout bestand in staat krijg je de foutmelding.

Ik heb in de define.inc.php in de config map de "define('_PS_MODE_DEV_', false)" en "define('_PS_DEBUG_PROFILING_', false);" op true gezet en toen kreeg ik het foute cache bestand te zien. Daarvan heb ik de extensie naar phpx gezet en toen werkte het weer.

  • Like 1

Share this post


Link to post
Share on other sites

Ik heb een oplossing gevonden. Prestashop kijkt in een de cache en als daar een fout bestand in staat krijg je de foutmelding.

Ik heb in de define.inc.php in de config map de "define('_PS_MODE_DEV_', false)" en "define('_PS_DEBUG_PROFILING_', false);" op true gezet en toen kreeg ik het foute cache bestand te zien. Daarvan heb ik de extensie naar phpx gezet en toen werkte het weer.

Goeie tip, thanks :D

Share this post


Link to post
Share on other sites

Bedankt voor de tip, maar krijg bij het instellen overal netjes een debug overzicht. Maar als ik een pdf laat genereren krijg ik weer een lege pagina terug.

 

Het vreemde is dat het gewoon gewerkt heeft, heb verder niks aan bestanden gewijzigd. Heb alleen instellingen in de backoffice gedaan, maar ook geen instellingen mbt de pdf's.

Share this post


Link to post
Share on other sites

Heb eindelijk de oplossing gevonden, je kan geen PNG afbeelding gebruiken als logo voor je invoice. Het moet een JPG zijn. (voorkeuren -> themas -> factuur logo)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More