Jump to content
marcoshirsch

(Solucionado) Problema con el Carrito "Su carrito está vacío"

Recommended Posts

Buen día,

 

El problema es el siguiente:

 

Cuando se agrega un producto al carrito lo permite, pero no permite agregar más productos. Solo permite agregar 1 producto al carrito.

cuando voy al carrito para seguir el proceso de compra, saca un letrero que dice " su carrito esta vacío"

 

Basicamente no se puede hacer la compra.

 

el link de la tienda es http://goo.gl/ZdExy

 

adjunto imagenes para clarificar un poco mas:

post-410014-0-26896500-1349870585_thumb.pngpost-410014-0-19522600-1349870600_thumb.png

 

 

Muchas gracias por la ayuda y espero haber sido claro

Edited by marcoshirsch (see edit history)

Share this post


Link to post
Share on other sites

Buen día,

 

El problema es el siguiente:

 

Cuando se agrega un producto al carrito lo permite, pero no permite agregar más productos. Solo permite agregar 1 producto al carrito.

cuando voy al carrito para seguir el proceso de compra, saca un letrero que dice " su carrito esta vacío"

 

Basicamente no se puede hacer la compra.

 

el link de la tienda es http://goo.gl/ZdExy

 

adjunto imagenes para clarificar un poco mas:

post-410014-0-26896500-1349870585_thumb.pngpost-410014-0-19522600-1349870600_thumb.png

 

 

Muchas gracias por la ayuda y espero haber sido claro

 

Prueba esto un segundo.

 

Pestaña Preferencias -> SEO/URLS donde dice:

 

www.adelgazame.com

 

Dejalo asi:

 

adelgazame.com

 

(sin las tres www)

 

(Aunque yo si puedo comprar y añadir al carrito)

 

¿Has probado limpiar la cache y cookies de tu navegador?

Share this post


Link to post
Share on other sites

Gracias por la ayuda,

ahora todos los links generan "error 404"

 

Desactiva las urls amigables y vuelve activarlas.

Share this post


Link to post
Share on other sites

perfecto, eres un genio.

 

muchas gracias

 

ahora en el carrito aparece esto Un artículo en su cesta ya no está disponible para esta cantidad, no se puede continuar con su pedido.

todos los productos tienen stock

Share this post


Link to post
Share on other sites

 

 

ahora en el carrito aparece esto Un artículo en su cesta ya no está disponible para esta cantidad, no se puede continuar con su pedido.

todos los productos tienen stock

 

¿Lo has arreglado? A mi me sale lo mismo.

Share this post


Link to post
Share on other sites

¿Lo has arreglado? A mi me sale lo mismo.

 

 

 

No he encontrado el error, voy a publicarlo como nuevo post a ver si alguien ya lo ha resuelto

Share this post


Link to post
Share on other sites

A mí también me pasa, pero añado algún otro dato para ver si entre todos lo encontramos. Lo primero es que he pedido a algunos compañeros que hagan un pedido en mi web, y ellos sí pueden. No lo tengo claro, pero creo que tiene que ver con el backoffice, si entras en el BO y te logueas, luego te da ese problema en el FrontOffice (esto es solo una intuición, pero no puedo demostrarlo).

 

Por otra parte, si cuando te está dando ese error, borras la caché y las cookies, ya te funciona el carrito perfectamente. Pero pruebas dentro de un par de días y estás otra vez igual.

 

La gran pregunta es, ¿les pasa lo mismo a todos los visitantes de nuestras tiendas? ¿o es solo a nosotros?

Share this post


Link to post
Share on other sites

Por lo que he visto en otros hilos similares sobre el tema, también puede tener que ver las www en el dominio. En mi caso particular con las versiones anteriores me funcionaba tanto con www como sin www, y al instalar la 1.5.1 solo me funcionaba si ponía las www. Por lo tanto tuve que poner una regla en el htaccess que añadiese las www si se entraba sin ellas y puede que tenga algo que ver.

 

No me cuadra mucho, porque cuando vacío la caché y las cookies funciona, y a otros usuarios les funciona bien, con lo cual no tiene mucho sentido, pero como lo he visto por otros hilos, lo pongo aquí por si a alguien se le enciende la bombillita al leerlo...

Share this post


Link to post
Share on other sites

El error sale y se permites venta sin stock.

Si pinchas Check Out with Paypal directo, sin pasar por direccion y forma de pago te lleva a Paypal sin problemas.

Share this post


Link to post
Share on other sites

A1b2, perdona, no entiendo muy bien qué quieres decir. Yo no permito venta sin stock y me da ese error.

Share this post


Link to post
Share on other sites

Por lo que he visto en otros hilos similares sobre el tema, también puede tener que ver las www en el dominio. En mi caso particular con las versiones anteriores me funcionaba tanto con www como sin www, y al instalar la 1.5.1 solo me funcionaba si ponía las www. Por lo tanto tuve que poner una regla en el htaccess que añadiese las www si se entraba sin ellas y puede que tenga algo que ver.

 

No me cuadra mucho, porque cuando vacío la caché y las cookies funciona, y a otros usuarios les funciona bien, con lo cual no tiene mucho sentido, pero como lo he visto por otros hilos, lo pongo aquí por si a alguien se le enciende la bombillita al leerlo...

 

>Hola: me puede indicar como poner lo da la www en el htaccess, me interesa mucho es linea

Share this post


Link to post
Share on other sites

Yo tuve ese mismo problema y al borrar las cookies se solucionaba con la 1.5.1 ya no me pasa

 

También cuando el error del carrito aparecía tampoco dejaba hacer el login

Share this post


Link to post
Share on other sites

Con una instalación nueva de 1.5.1 el carrito sólo funciona en firefox, ni Opera ni chrome ni epiphany ni android.

 

Cuando buscas por el problema en cuestión sólo llegas a "tienes que borrar las cookies" pero qué cookies si es una instalación desde cero y es la primera vez que visito la web.

 

También comentan que si con "www" o sin ellas, y si el dominio que se usa es pepito.tienda.com ?

 

En el Forge cierran los hilos con un "clean your cookies" :D

 

Será que quieren hacernos migrar a Magento ?

 

en fin...

Share this post


Link to post
Share on other sites

Yo tuve ese mismo problema y al borrar las cookies se solucionaba con la 1.5.1 ya no me pasa

 

También cuando el error del carrito aparecía tampoco dejaba hacer el login

 

Efectivamente, justo eso es lo que me pasa a mí, y me sigue pasando con la versión 1.5.1. Y cuando digo que me pasa a mí, no quiero decir que le pase a todo el mundo que entre en mi página, porque la mayoría entran y hacen pedidos bien, sino que me pasa a mí y a algunas pocas personas más. Sigo sin haberlo arreglado.

Share this post


Link to post
Share on other sites

Amigos, yo tuve el problema de "Carrito Vacío" con Prestashop 1.5.1. Les cuento que se me solucionó, eliminando todas las cookies y el historial de mi navegador. Uso Mozilla, y ya lo probé con Explorer y Chrome y va bien.

Share this post


Link to post
Share on other sites

Amigos, yo tuve el problema de "Carrito Vacío" con Prestashop 1.5.1. Les cuento que se me solucionó, eliminando todas las cookies y el historial de mi navegador. Uso Mozilla, y ya lo probé con Explorer y Chrome y va bien.

 

Sí, así se soluciona, ¿pero les pides a tus clientes que hagan lo mismo cuando les da ese error?

Share this post


Link to post
Share on other sites

Tengo el mismo problema y no se como solucionarlo, lanzo la pagina mañana www.vinotecalavia.com y la verdad es que me da miedo pensar que no funcionara. Como dato interesante, cree 4 módulos, uno para cada tienda... el cliente hace el pedido y lo recoge y paga en la tienda.

 

Si a alguien le interesa, creo un post para explicar como lo he hecho.

Share this post


Link to post
Share on other sites

Encontre un par problemas y explico las soluciones que por ahora funcionan... primero en Preferencia---> SEO URL --- Establecer URL tienda lo coloque sin las www. osea midominio.com

 

Luego en Configuración de las URL desactive las URL amigables y Automáticamente redirigifdos a la URL canónica ... guarde y luego las volvi a activar...

 

A todo esto descargue por FTP el archivo Cart.php que se ecuentra en la carpeta Classes y dentro modifique la linea número 446 que dice:

 

$sql->innerJoin('product_shop', 'product_shop', 'product_shop.id_shop='.$id_shop);

 

Por esta:

 

$sql->innerJoin('product_shop', 'product_shop', 'product_shop.id_product = p.id_product AND product_shop.id_shop = '.$id_shop );

 

Ahora puedo cargar productos al carrito y funciona "por ahora" bien...

Share this post


Link to post
Share on other sites

 

A todo esto descargue por FTP el archivo Cart.php que se ecuentra en la carpeta Classes y dentro modifique la linea número 446 que dice:

 

$sql->innerJoin('product_shop', 'product_shop', 'product_shop.id_shop='.$id_shop);

 

Por esta:

 

$sql->innerJoin('product_shop', 'product_shop', 'product_shop.id_product = p.id_product AND product_shop.id_shop = '.$id_shop );

 

Ahora puedo cargar productos al carrito y funciona "por ahora" bien...

 

Esto lo comente el otro día aquí: http://www.prestashop.com/forums/index.php?/topic/193731-solucionado-un-articulo-en-su-cesta-ya-no-esta-disponible-para-esta-cantidad/page__view__findpost__p__965057, http://www.prestashop.com/forums/index.php?/topic/193731-solucionado-un-articulo-en-su-cesta-ya-no-esta-disponible-para-esta-cantidad/page__view__findpost__p__965051

 

Encontre un par problemas y explico las soluciones que por ahora funcionan... primero en Preferencia---> SEO URL --- Establecer URL tienda lo coloque sin las www. osea midominio.com

 

 

 

Y esto esta comentado aquí: http://www.prestashop.com/forums/index.php?/topic/193570-solucionado-problema-con-el-carrito-su-carrito-esta-vacio/page__view__findpost__p__959225

  • Like 1

Share this post


Link to post
Share on other sites

Ok, disculpa pero no los había visto...

 

No pasa nada ))

Share this post


Link to post
Share on other sites

No se si valdrá o no, pero al poner las www. de mi tienda me pasó este mismo error, quitándolas se quita.

 

Al final me funciona bien teniendolo con:

 

URL amigable

Sin redirigir

Sin MultiViews

dominio: www.lachucheencasa.com

SSL:lachucheencasa.com

Base URi: /

Share this post


Link to post
Share on other sites

Nosotros tenemos una multitienda y seguimos con el problema del carrito de la compra..

 

El cart.php en SVN ya tiene aplicado ese cambio.

Hemos probado hacer todo tipo de cambios, tales como comentan, aqui, pero es imposible realizar cualquier pedido.

 

podeis ver la direccion aqui. www.electrocaraudio.com/shop/

 

 

De momento esta abierta, pero no es funcional, porque no se puede añadir pedidos al carrito.

Hemos hecho de todo y no hay manera, cosas curiosas como :

 

Solo se añaden

 

pinchando en los productos del listado del Home Featured

y dentro de la ficha de cada producto

Si se pincha en los listados, el producto no se añade.

 

(para mas ... el homefeature es el product-list. tpl cambiado de nombre) y el product_list no añade productos y el home feature si..

 

Cosas curiosas??

 

Alquien sabe como solucionar esto?

 

Gracias.

Share this post


Link to post
Share on other sites

Por si a alguien le sirve de ayuda. Yo lo solucioné de la siguiente forma.

 

en preferencias/seo/establecer url tienda.

 

prestashop pone por defecto lo siguiente

www.mitiendaweb.com/

 

hay que eliminar la / final

dejandolo asi

 

www.mitiendaweb.com

 

tanto en dominio tienda como en SSL

 

me di cuenta por que cuando me daba el error me fije en la direccion url y me aparecia asi: www.mitiendaweb.com//shop/

despues del .com// doble //

un saludo

Share this post


Link to post
Share on other sites

Prueba esto un segundo.

 

Pestaña Preferencias -> SEO/URLS donde dice:

 

www.adelgazame.com

 

Dejalo asi:

 

adelgazame.com

 

(sin las tres www)

 

(Aunque yo si puedo comprar y añadir al carrito)

 

¿Has probado limpiar la cache y cookies de tu navegador?

 

En el forge de Prestashop hay un reporte hablando sobre el tema de que la página de problemas con las www.

http://forge.prestas...owse/PSCFV-5573

Proponen la siguiente solución para poder colocar las www y no tener problemas:

https://github.com/P...2c2826fe701c916

 

Quien tenga este problema puede solucionarlo descargando el fichero que hay en adjunto. Hay que descomprimirlo en la carpeta raiz de la tienda.

PS-15-FIX-WWW.zip

Edited by cloder (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

En el forge de Prestashop hay un reporte hablando sobre el tema de que la página de problemas con las www.

http://forge.prestas...owse/PSCFV-5573

Proponen la siguiente solución para poder colocar las www y no tener problemas:

https://github.com/P...2c2826fe701c916

 

Quien tenga este problema puede solucionarlo descargando el fichero que hay en adjunto. Hay que descomprimirlo en la carpeta raiz de la tienda.

 

Por lo que veo la información de los reportes es posterior a cuando se inicio este post en el foro (era normal, que en ese momento hubiera panico), es una buena noticia que hayan sacado un parche con el error corregido.

 

Un Saludo,

Share this post


Link to post
Share on other sites

En el forge de Prestashop hay un reporte hablando sobre el tema de que la página de problemas con las www.

http://forge.prestas...owse/PSCFV-5573

Proponen la siguiente solución para poder colocar las www y no tener problemas:

https://github.com/P...2c2826fe701c916

 

Quien tenga este problema puede solucionarlo descargando el fichero que hay en adjunto. Hay que descomprimirlo en la carpeta raiz de la tienda.

 

Buenos días colegas, estoy ahora con el mismo problema. pero tengo una duda.

He descargado el parche, y lo descomprimí y veo que dentro tiene una carpeta classes -> shop -> shop.php, este sería el parche, pero el problema es que existe este archivo ya en el propio sistema por lo que si lo pongo lo remplazo, y por lo que veo, es mas pequeño este archivo que el que está.

Por lo que mi pregunta a esto es saber si realmente debo reemplazar el fichero o hay un paso que me estoy salteando o no me di cuenta....

 

por lo que lo único que hice fue quitarle en PREFERENCIAS -> SEO y URL -> Dominio de la tienda: el www.

guardé.

luego la web me dirigía directamente a "pagina no encontrada"

volví a poner el www. en el mismo sitio.

 

Y FUNCIONÓ!!! ----> 3 HORAS DESPUÉS DEJO DE FUNCIONAR (editado)

 

la verdad es que no se que es lo que realmente pasó.

igualmente si es un parche me interesa saber como aplicarlo.

 

 

muchas gracias!

Edited by Hugol (see edit history)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More