Jump to content
BoKr

Neueinsteiger: Presta 1.4.5.1/1.4.6.2 oder gleich 1.4.9?

Recommended Posts

Hallo

 

das Weihnachtsgeschäft werden wir dieses Jahr wohl nicht mehr mitmachen können, dennoch werde wir nun endlich unseren ersten shop eröffnen wollen.

Nach einem halben Jahr des Vergleichens (Shopware, MagentoGo, Oxid) wollen wir auf jeden Fall mit Prestashop starten in das große Abenteuer.

Wir haben auch so lange gewartet, da wir die kleine Hoffnung hatten, dass 1.5 rechtsicher sei in DE (so hatte man es uns auf einer kleinen Veranstaltung seitens PS in Hamburg mal signalisiert). Tja, das ist ja nun nicht der Fall und es wurde wohl eine Menge gemacht, jenen die Module anbieten gegen Geld zu dem Thema es schwerer zu machen. Schade eigentlich.

 

Daher werden wir nun PS 1.4.X aufsetzen.

Auch weil es wohl ein paar schöne freie templates zu 1.4 gibt wie auch dt. Module.

 

Aber das X ist nun die Frage.

Was sollen wir denn nun nehmen?

Presta 1.4.5.1/1.4.6.2 oder 1.4.9

 

Wir steigen da leider nicht so ganz durch. Hauptsache ist natürlich, dass wir es für Dt. anpassen können. Ich habe mich mit dem Thema nun noch nicht tiefer befasst, außer dass ich weiß, dass eine Agentur in Hanover (Silberseiten?) gibt, die ein Modul gegen Geld anbieten und dass hier im Forum einen thread gibt zur Button-Lösung.

Aber, ob das nun alles aktuell ist und ob und wie mit welcher Version'?

 

 

vielen Dank

Boris

Share this post


Link to post
Share on other sites

Entweder 1.4.5.1 oder 1.4.9 sind beide gleichwertig, wobei 1.4.9 noch einige Module mehr mit an Bord hat und einige kleine Bugs wurden beseitigt. Auf keinen Fall Versionen 1.4.6.2. bis 1.4.8.3. Diese enthalten noch nicht optimierte DB-queries, was zu einer fatalen Auswirkung in großen Shops mit über 2.000 Produkte führt. Diese Versionen sind extrem langsam, trotz bester Optimierung.

Man weiss ja leider am Anfang auch nie wie groß ein Projekt mit der Zeit wird.

 

Würde ich neu beginnen, dann auf jeden Fall 1.4.9. Für die Fixe Deutsches Recht musst du kein Geld ausgeben. Im Forum sind die Fixe leicht und für jeden verständlich selbst einbaubar dargelegt. Entscheidest du dich für das Modul um Zeit zu sparen, dann erlischt hiermit der Support in diesem Forum. Bei Probleme musst du dich an den Entwickler wenden, da das Modul den Core von Prestashop mit unzähligen override-Funktionen des Cores überschreibt.

Wenn du dann vorhast auf 1.5. umzusteigen, die bis Jahresende selbst die Fixe eingebaut haben soll, dann werden sicherlich gröbere Probleme damit auftauchen, weil Funktionen und Regeln nicht mehr auf Standard laufen, sondern anderen Regeln zugeordent wurden.

 

Ist deine Entscheidung. Dich jetzt von einem Drittanbieter abhängig zu machen und immer auf Fixe zu warten wenn Prestashop ugedatet wurde, oder selbst Hand anlegen (was wirklich jeder bis jetzt noch geschafft hat) aber dafür eine reine Originalsoftware zu fahren. Wie gesagt bis Jahresende ist es nicht mehr soweit und dann hast du alles aus einer Hand und zwar vom Softwarehersteller selbst ohne dass du da extra Geld oder extra Arbeit dann hast.

Share this post


Link to post
Share on other sites

Hallo

 

Leider konnte ich mich nicht eher melden, dennoch möchte ich es mir nicht nehmen lassen, mich bei dir herzlich zu bedanken für deine ausführlichen Erklärung. Unsere Entscheidung ist gefallen und sie werden 1.4.9 aufsetzen in Verbindung mit dem fix aus dieser Community (Blutiges, Du und andere).

 

Leider Gottes stehe ich Moment vor ein paar Problemen, die mich verunsichern. Der Hintergrund ist, dass ich ein theme benutzen möchte, dass offiziell nicht für 1.4.9 herausgegeben ist, sondern nur für Versionen bis 1.4.6 oder acht glaube ich. Ich konnte es auf jeden Fall problemlos installieren, wobei das problemlos relativ ist, da ich noch nicht weiß wie sich mögliche Probleme äußern können. Bisher habe ich nur festgestellt, dass nicht alle Blöcke bzw. Module Deutsch sind, aber dazu habe ich schon einen Beitrag eröffnet. Dennoch habe ich natürlich ein ungutes Gefühl, und ich vermute, dass es am besten ist, das Original 1.4.9 Theme zu nehmen und dieses dann optisch anzupassen.

 

Mit besten Grüßen

Boris

Share this post


Link to post
Share on other sites

Welches Theme soll es denn sein ? Ist es ein Kauftheme aus den Add-Ons ? Dann einfach den Entwickler kontaktieren. Bei allen Angeboten in den Kauf-Addons innerhalb von Presta, hast du eine gewisse Garantie. Auf jeden Fall wen es Hart auf Hart kommt, kannst du dein Geld zurückverlangen. Prestashop verwaltet es treuhänderisch. Also viel Risiko gehst du hier nicht ein. Aber besser vorab mit dem Entwickler klären. Evtl. ist es auch für 1.4.9 brauchbar. Der JS Sprung wo PS die Skripte auf neue Releases ausgetauscht hat war zwischen 1.4.5.1 und 1.4.7. Danach sind sie gleich geblieben. Daher einfach fragen. Kann auch sein, dass der Entwickler vergessen hat in den Add-ons die Version auszutauschen und es steht noch ein alter Hinweis. Einfach fragen.

 

Außerhalb von PS können wir wenig machen, es sei denn es kommt von einem Mitentwickler, der selbst verkauft (prestochange-o, rsi Argentina und noch einige andere). Die meisten sind selbst als Mod unterwegs und arbeiten sozusagen als ghost-Entwickler mit. Hier hast du auch keine Probleme. Bei ganz fremden Angeboten ist es halt schwer zu intervenieren, wenn es bröselt.

 

Ob gekaufte Themes dann auch für 1.5.1 sofort einseztbar sind, ist auch fraglich und hängt eben davon ab, wie alt diese sind... Eine Pauschale Antwort mit Nein oder Ja, wie du sie jetzt von mir erwartest, kann ich dir leider nicht geben.

Nenne uns doch das Theme. Ich werde sehen, was ich für dich in Erfahrung bringen kann.

Share this post


Link to post
Share on other sites

Hallo

 

 

das ist sehr nett, dass Du uns Deine Hilfe hier anbietest. Ich habe schon den Entwickler kontaktiert und die Antwort erhalten, dass man sich darum kümmern würde, es für 1.5 anzupassen. Aber das hatte ich auch schon beim 1. Kontakt mit geteilt, dass ich zur Zeit ausschließe auf 1.5.x zu gehen, da diese Version noch nicht fit sei für den dt. Markt und nicht fehlerfrei (so hatte ich es letzte Woche hier im Forum verstanden).

Auf den Punkt gebracht, ich wollte nur wissen, wie es mit 1.4.9 aussieht und die Antwort war, es gäbe dazu nichts und wenn dann 1.5.x.

 

Es handelt sich um:

http://addons.presta...-PRS030072.html

 

Aber je länger ich mich nun mit PS beschäftige, muss ich feststellen, dass dieses PRS30072 für mich sehr dem beigelegten Toptheme von PS 1.4.9 ähnelt.

Wir hatten uns nur wegen der Farben für dieses theme entschieden und der zentralen Suchleiste. Aber ich traue mir mittlerweile zu, all das im PS1.4.9 original theme selbst anzupassen. Ich hoffe mal, ich überschätze mich da nicht, aber was nun so ein Kauftheme wirklich so aussmacht gegen über dem Original? Klar, ich als Anfänger brauche meine Zeit für Anpassungen und wenn man so 30-50€ Stundenlohn ansetzt, dann sollte man sofort ein optisch passendes theme kaufen. Nur dann hoffe ich natürlich, dass ich gleich damit arbeiten kann und es den Funktionen des Originals entspricht. Klar, kann natürlich sein, dass es themes sogar mit neuen tollen Modulen gibt, aber die könnte man ja dann auch nachrüsten. Z.b. die horizontale Kategorienleiste.

 

Ich hoffe, ich habe nun nicht zu viel Dummes geschrieben, da ich noch ziemlich frisch bin in der Materie und wirklich am Anfang stehe. Eigentlich geht es ja nur für uns darum zur Zeit, PS rechtsicher zu haben (1.4.9) und ohne Fehler in PS und selbiges mit einem für uns netten Design. Und da stehe ich halt zur Zeit auf Klarheit und bin auch sehr glücklich, dass PS das mobiltheme umsonst rausgibt.

Share this post


Link to post
Share on other sites

Also es ist von mela. Na ja der ist sogar ein Deutscher USER hier im Forum.

 

Allerdings sehe ich gerade, dass es bis 1.4.8.3 angegeben ist. Dann kannst du es auch beruhigt für 1.4.9 nehmen. Die Version 1.4.9 wurde eigentlich für mich eingeschoben, weil die DB queries in den Versionen 1.4.6.2. - 1.4.8.3 schlecht programmiert waren. Es fand eine Bereinigung der Datenbanabfragen statt und auch wurde an einigen Modulen vorbereitet für 1.5. hier weitergearbeitet und teils freigegeben. So das Modul Paypal evolution z.B.

 

Als Gegenbeispiel: Ich verwende Prestashop alternative selbst eingefärbt mit keinen Änderungen. Es wurde für Version 1.4.0.1 erstellt. Ich kann es noch unter 1.5. verwenden, ohne Probleme.

 

Das Theme was du kaufen möchtest hat aber auch noch einige extra Module eingepackt. Ehrlich Meinung ? Wenn es dir gefällt und passt, dann kaufe es. Upgrade ist ja mit dabei, oder ?

 

Kleiner Hinweis nur: Wenn du Multishop verwenden solltest, dann kann es sein, dass einige Themes Probleme machen. Aber es muss nicht sein. Hier gibt es leider noch sehr wenig Erfahrungswerte... Aber sicher nichts, dass sich nicht fixen lässt und mela weisst du ja wo du finden kannst.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More