Jump to content

Confusion affichage prix TTC / HT


Recommended Posts

Bonjour à tous,

 

D'abord désolée de poster à ce sujet qui a été maintes fois traité, mais poster dans un topic [RESOLU] ne va pas me servir

 

J'ai suivi les nombreux conseils que j'ai pu lire au fil de ce forum et d'autres sites. Rien n'y fait, je ne comprends pas, j'y ai déjà passé des heures, je bloque...

 

Je travaille sur une V1.4.8 et mes prix s'affichent en HT (même si c'est écrit ttc en bout de ligne... le calcul ne se fait pas, seul l'affichage en FO feint le faire).

D'après mes observations, c'est le cas :

- que je sois visiteur lambda ou membre connecté

- la bonne création d'une taxe 5.5 % et de sa règle de taxe

- malgré que que groupe clients 'Défaut ' ait bien cette taxe d'enregistrée

- sur les produits qui ont des déclinaisons, seulement.

 

J'veux bien un bon gros conseil pour me sortir de là coté product.tpl, je me débrouillerai du reste des affichages, mais là, franchement, je désespère.

 

MErci !!

Share this post


Link to post
Share on other sites

  • 4 weeks later...

Bonjour,

 

Je me permets de relancer ce topic même si visiblement il a du être résolu pour la personne qui en est à l'origine : aujourd'hui je me retrouve face au même problème! Jusqu'à hier tout était nikel, et depuis ce midi les prix sont affichés en HT avec la mention 'TTC' derrière :/

 

Concrètement ce matin j'ai créé de nouveaux pays, affectés à des zones et de nouveaux transporteurs affectés à ces zones mais c'est toujours la France métropolitaine mon pays principal et je n'ai rien changé d'autre

 

A quoi cela peut-îl être du?

Share this post


Link to post
Share on other sites

J'ai fait quelques tests et le problème ne survient que quand j'entre une adresse en Corse... Pour créer le pays Corse j'ai repris les mêmes infos que pour la France sauf que j'ai changé le nom (sinon le reste est similaire).

 

Mais par exemple lorsque j'entre une adresse en Allemagne les prix restent en TTC... Je continue mes recherche mais si vous avez une piste n'hésitez pas!

Share this post


Link to post
Share on other sites

Bon après avoir testé tous les pays que je dessers il s'avère que les pays déjà existants sur Presta à l'origine, la distinction TTC/HT fonctionne parfaitement, mais pour tous les pays que j'ai créé (Corse, différents Dom et Tom) les prix s'affichent en HT (avec mention TTC) malgré le fait que les réglages soient identiques :/

 

Je continue de regarder mais c'est quand même très curieux!

Share this post


Link to post
Share on other sites

  • 2 years later...

Bonsoir

J'ai un problème qui ressemble au tien.

Je suis sur 1.6.0.9 et pour des questions de TVA à 10% sur la Corse, j'ai créé une TVA spéciale à 10% pour les codes postal commençant par 20XXX.

J'ai créé une Zone qui s'appelle France Corse, puis un pays qui s'appelle France (Corse), j'ai créé une taxe FR TVA Corse 10%, et j'ai appliqué une règle de taxe qui s'applique à la Corse code postal commençant par 20.

Mais ça ne marche pas, le programme doit considérer que c'est une vente internationale.

SI quelqu'un sait où j'ai oublié quelque chose, il est le bienvenu

Share this post


Link to post
Share on other sites

Les taxes sont bien sélectionnées pour chaque produit :

yVKz.jpeg

 

Bonjour,

 

J'ai le même problème sur le prix affiché, c'est indiqué prix ht, sur le produit il est bien indiqué le prix ttc

merci de votre aide

A+

JF

Share this post


Link to post
Share on other sites

Bonjour

En ce qui concerne la zone Corse, j'ai finalement annulé le groupe Pro que j'avais créé et j'ai tout recommencé. Maintenant ça marche. Je ne sais pas d'où venait le bug mais il s'est corrigé de lui-même.

Pour le HT et le TTC, idem, ça ne marche pas. Je voulais proposer un prix HT aux clients professionnels afin que la différence entre le prix TTC public et le prix HT pro soit plus important mais ça ne marche pas.

Le programme marche bien mais il me parait assez sensible, alors je préfère ne pas trop le chahuter et en rester la.

Bonne chance dans ta recherche

Claude

Share this post


Link to post
Share on other sites

Bonjour

En ce qui concerne la zone Corse, j'ai finalement annulé le groupe Pro que j'avais créé et j'ai tout recommencé. Maintenant ça marche. Je ne sais pas d'où venait le bug mais il s'est corrigé de lui-même.

Pour le HT et le TTC, idem, ça ne marche pas. Je voulais proposer un prix HT aux clients professionnels afin que la différence entre le prix TTC public et le prix HT pro soit plus important mais ça ne marche pas.

Le programme marche bien mais il me parait assez sensible, alors je préfère ne pas trop le chahuter et en rester la.

Bonne chance dans ta recherche

Claude

 

Bonjour Claude,

 

Merci pour la réponse, mais je comprends rien. je dois faire un groupe pour définir si il y a une tva à afficher?

MECI

JF

Share this post


Link to post
Share on other sites

Non ! pas du tout. Il n'y a pas besoin de créer un nouveau groupe.

L'affichage mentionnant HT ou TTC après le prix, c'est un autre problème que je ne sais pas résoudre.

Mais si, en France métropolitaine tu veux proposer un prix ht, c'est au niveau de >>localisation >> règles de taxes qu'il faut intervenir.

Share this post


Link to post
Share on other sites

Non ! pas du tout. Il n'y a pas besoin de créer un nouveau groupe.

L'affichage mentionnant HT ou TTC après le prix, c'est un autre problème que je ne sais pas résoudre.

Mais si, en France métropolitaine tu veux proposer un prix ht, c'est au niveau de >>localisation >> règles de taxes qu'il faut intervenir.

 

Merci Claude

Bon week-end

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More