Jump to content

Recommended Posts

Bonjour,

 

Je n'ai plus accès aux catégories sur la partie public !!

 

Voici le message que je reçois :

 

Unknown column 'id_shop' in 'where clause'

 

SELECT * FROM ps_layered_category

WHERE id_category = 17

AND id_shop = 0

GROUP BY `type`, id_value ORDER BY position ASC

 

Merci d'avance pour votre aide

 

 

Marc

 

www.distri-group.com

Share this post


Link to post
Share on other sites

Bonjour,

 

avez-vous résolu votre problème ?

 

J'ai exactement le même depuis 24 heures ?

 

( un conflit avec modules nouvellement installés, c'est possible ?)

 

Merci

 

Philoua

Share this post


Link to post
Share on other sites

non, impossible à résoudre !! il y a conflit avec certains modules de l'ancienne version.

Il fallait écraser l'ancienne version (après backup) avant d'installer la nouvelle.

 

J'ai donc du tout virer et je suis occupé à tout réinstallé.

 

J'ai posté plusieurs posts ici avec les différents problèmes mais personne n'a pris la peine de m'aider. Je me suis donc tourner vers mon hébergeur (planethoster).

5 minutes après avoir posté, j'avais déjà une réponse cohérente. un technicien de chez planethoster et un modérateur du forum ont passé plus de 2 heures à essayer de réparer les erreurs sans y parvenir.

 

Donc, pas de solution miracle !

 

Bon courage

Share this post


Link to post
Share on other sites

...Je n'arrive pas à le croire. Mais le fait est que j'ai installé un certains nombre de modules avant-hier...(et que je viens de désinstaller !).

Et pour info, la dernière manip en cours avant de m'apercevoir du problème était d'essayer d'utiliser le module "avant-page"...

 

quand vous parlez de l'ancienne version, il s'agit de quelle version prestashop svp. Pour ma part, je suis sur la 1.4.6.2.

 

Mais je pensais qu'il s'agissait plutôt d'un problème de base de données.

 

Merci

 

Philoua

Share this post


Link to post
Share on other sites

j'avais aussi la 1.4.6.2 !!

Parmi les modules en conflit il y a Mondial Relay car le module à changer dans la nouvelle version.

Oui c'est un problème dans les bases de données. Les erreurs renvoyée par le système indiquent que des BDD sont manquantes alors qu'elles n'existent même pas (dans aucune versions).

 

Voici ce que le modérateur de Planet hoster ma indiqué :

Pour ma part j'ai regardé dans mon presta et ta table "ps_layered_category" je ne l'ai pas dans la base de données...... (et j'ai aussi la dernière version)

 

Il m'a aussi conseillé de vider la cache

Share this post


Link to post
Share on other sites

Bonjour,

 

quels modules j'avais installés ? En temps normal, j'aurais eu du mal à répondre à cette question car je passe énormement (beaucoup trop) de temps sur mon site. Mais cette fois-ci j'ai fait peu de choses depuis le moment où cela fonctionnait correctement:

 

donc, tout juste avant de m'apercevoir du problème : le module "avant page"

et la veille : j'ai essayé de régler les problèmes de bons de réduction et promotions ( le prix "discount" n'apparait pas sur mes pages produits), j'ai donc installé puis désintallé des modules comme : "vente et promotions v1.4" et "Soldes et promotions v0.1". J'ai le sentiment que le problème vient de "vente et promotions v1.4"...( responsable de la toute dernière panne avant celle dont nous parlons)

 

Je viens de desinstallé mondial relay : pas de changement

 

Philoua

 

www.la-boutique-innovation-santé.com

www.earlydoctors.com

Share this post


Link to post
Share on other sites

RE-bonjour Distri-group,

 

ça y est , je viens de trouver !! J'ai supprimé le module blocklayered / navigation à facettes ( qui soit dit en passant, n'a jamais fonctionné pour moi) et l'erreur "category id-shop" a disparu et les pages catégories sont maintenant parfaitement visibles en FO ( pour être clair, je parle de toutes les pages de mon site, telles que ventes aux professionnels , ventes aux particuliers, etc qui présentent les produits ou encore les sous-catégories d'une même catégorie).

 

Je m'en suis rendu compte, en faisant la manip suivante : j'ai d'abord crée une nouvelle catégorie en BO puis je l'ai supprimé, le debug confi.inc.php "on" m'a révéle un problème avec blocklayered...que j'ai supprimé : tout marche !

 

Peut-être cela peut-il encore être utile pour toi ...ou pour d'autres

 

Philoua

 

http://www.la-boutiq...ation-santé.com

http://www.earlydoctors.com

 

PS: donc RESOLU

Share this post


Link to post
Share on other sites

RE-bonjour Distri-group,

 

ça y est , je viens de trouver !! J'ai supprimé le module blocklayered / navigation à facettes ( qui soit dit en passant, n'a jamais fonctionné pour moi) et l'erreur "category id-shop" a disparu et les pages catégories sont maintenant parfaitement visibles en FO ( pour être clair, je parle de toutes les pages de mon site, telles que ventes aux professionnels , ventes aux particuliers, etc qui présentent les produits ou encore les sous-catégories d'une même catégorie).

 

Je m'en suis rendu compte, en faisant la manip suivante : j'ai d'abord crée une nouvelle catégorie en BO puis je l'ai supprimé, le debug confi.inc.php "on" m'a révéle un problème avec blocklayered...que j'ai supprimé : tout marche !

 

Peut-être cela peut-il encore être utile pour toi ...ou pour d'autres

 

Philoua

 

http://www.la-boutiq...ation-santé.com

http://www.earlydoctors.com

 

PS: donc RESOLU

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More