Jump to content

SSL et prestashop


Recommended Posts

Bonjour à tous,

 

Je rencontre des problèmes de liaison SSL sur ma boutique. Depuis la mise en place de cette boutique, je n'arrive pas à lier les certificats.

 

Après plusieurs jours de recherche c'est le point mort, j'ai plus qu'à croire en la force de la communauté.

 

Voici toutes les informations que je puisse fournir :

 

Mon hébergeur : o2switch

(A priori pas de problème à ce niveau car il accepte la création et la gestion de certificat)

J'ai donc créer des clés SSL chez mon hébergeur avec succès sous l’hôte :

www.yanaavenue.com et ssl.yanaavenue.com (clé en 2048 bits)

 

Préférence -> adresse SSL : ssl.yanaavenue.com

 

Générateur -> htaccess. :

SetEnv PHP_VER 5

RewriteEngine On

 

RewriteCond %{SERVER_PORT} 2082

RewriteRule ^(.*)$ http://ssl.yanaavenue.com/$1 [R,L]

 

 

Mais voila je résultant lors que je me rends dans :

Préférence --> Activité le SLL - Cliquez ici pour utiliser le protocole HTTPS avant d'activer le mode SSL :

 

 

 

 

 

 

 

 

Page Web inaccessible

 

Impossible de trouver le serveur de ssl.yanaavenue.com, car la résolution DNS a échoué. DNS est le service Web qui convertit les noms de sites Web en adresses Internet. Cette erreur est généralement due à l'absence de connexion Internet ou à une configuration incorrecte du réseau. Elle peut également être causée par un serveur DNS qui ne répond pas ou par un pare-feu qui interdit l'accès de Google Chrome au réseau.

Voici quelques suggestions :

  • Actualisez cette page Web ultérieurement.
  • Vérifiez votre connexion Internet. Redémarrez votre routeur, votre modem ou tout autre périphérique réseau que vous utilisez.
  • Vérifiez vos paramètres DNS. Contactez votre administrateur réseau si vous n'êtes pas sûr de vous.
  • Désactivez les prédictions d'actions du réseau en procédant comme suit : accédez au menu Clé à molette > Options >Options avancées et désélectionnez "Prédire les actions du réseau pour améliorer les performances de chargement des pages". Si le problème persiste, nous vous conseillons de sélectionner de nouveau cette option pour améliorer les performances.
  • Ajoutez Google Chrome aux programmes autorisés dans les paramètres de votre pare-feu ou de votre antivirus. S'il est déjà autorisé, supprimez-le de la liste des programmes autorisés et ajoutez-le à nouveau.
  • Si vous utilisez un serveur proxy, vérifiez vos paramètres de proxy ou contactez votre administrateur réseau pour vérifier que le serveur proxy fonctionne. Si vous ne pensez pas devoir utiliser de serveur proxy, réglez vos paramètres de proxy : Accédez au menu Clé à molette > Options > Options avancées > Modifier les paramètres du proxy... > Paramètres réseau et désélectionnez l'option "Utiliser un serveur proxy pour votre réseau local"..

Erreur 105 (net::ERR_NAME_NOT_RESOLVED) : Impossible de résoudre l'adresse DNS du serveur.

 

 

 

Si vous avez déjà rencontrer ce problème, je vous remercie par avance pour votre aide.

 

Adeline

Edited by Adeline38 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Vous n'avez pas besoin de redirection pour activer SSL (sauf pour forcer HTTPS sur tout votre site mais pas de cette manière), vous devez placer votre certificat dans les fichiers de config de votre serveur rien de plus et activer la fonction SLL dans PS.

 

Le Port SSL est normalement le 443 et pas 2082 il me semble.

 

Donc retirez votre redirection et si votre certificat est bien installé via votre hosting panel, activé simplement SSL dans PS.

Share this post


Link to post
Share on other sites

  • 2 months later...

SSL is an encryption technology that ensures a secure exchange of your web server and a foreign browser. It allows for the exchange to happen without the possibility of other external users tampering with the information or meandering through messages that are not meant for them.Even if you do not come face to face with an actual warning that the site you are visiting is not SSL certified, you can still distinguish between a one that is and another that is not. In the URL, you can check how the web addresses start. If the address starts with an “http”, it means that the site does not have an SSL Certificate.Web vulnerability scanning

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More