Jump to content
Sign in to follow this  
Peha

[Résolu] MAJ 1.1 > 1.2 Alpha

Recommended Posts

Bonjour,

voici le souci :
je suis chez OVH, ma boutique est dans un sous dossier /maboutique/
lorsque je vais là : www.monsite/maboutique/
je suis redirigé vers www.monsite/

alors que la partie admin fonctionne www.monsite/maboutique/admin

...

j'ai bien ceci dans settings.inc.php

define('__PS_BASE_URI__', '/maboutique/');

et mon .htacess est comme ça :
(j'ai essayé plusieurs trucs mais ça n'a rien changé)


SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0

RewriteEngine on

RewriteBase /maboutique

RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.)$ product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-])\.html(.)$ product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-])(.)$ category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-])(.)$ cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-])(.)$ supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-])(.*)$ manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]

ErrorDocument 404 /404.php





bref
je ne vois pas...

Share this post


Link to post
Share on other sites

Salut Peha,

Je suis dans la meme config que toi... mais moi ça fonctionne sur ovh ;)

La seule différence que je constate avec ton htaccess c'est :

RewriteBase /boutique



J'ai pas de / à la fin.

Sinon tout pareil...

Puis au passage rajoute ça :

deny from all
allow from localhost



ça protègera les fichiers de ton template.

V++

Atch

Share this post


Link to post
Share on other sites

J'ai réussi à m'en sortir...

_j'ai simplement re-uploadé la 1.2 dans un nouveau dossier : maboutique-1
_remis les thèmes et les images au bon endroit (et les mails..etc)
_j'ai adapté le fichier settings.inc.php :
define(’PS_BASE_URI‘, ‘/maboutique-1/’);
_désactivé les urls simplifiés dans la partie admin (qui marchait)
_fait un .htaccess minimum pour que ça marche sur ovh :

# merci OVH
SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0



bon...

Ensuite j'ai réactivé les URL simplifiés, et fait générer automatiquement le .htaccess
(sans oublier de re-rajouter les 3 lignes pour OVH --- note : le RewriteBase semble ne servir à rien... )


Changé le nom du dossier par le nom d'origine /maboutique/
Et j'ai re-adapté settings.inc.php :
define(’PS_BASE_URI‘, ‘/maboutique/’);

Ouf, on est revenu au point de départ...
j'ai pas compris ce qui a fait la différence mais bon tant mieux

merci Atch pour ta réponse (et pour l'astuce de protection des tpl ;)

Share this post


Link to post
Share on other sites

Je confirme le Rewite Base chez OVh ne sers absolument à rien ca marche très bien sans !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More