Jump to content
Sign in to follow this  
nico46

[Résolu] Bug d’affichage

Recommended Posts

Bonjour à tous, j'ai actuellement un bug peux esthétique sur ma boutique en ligne (en construction) que je n'arrive pas à comprendre et encore moins à régler.
J'en appelle donc à vos lumières éclairées pour m'aider à résoudre ce disgracieux soucis.
Sur la première image que je joint, on vois un gros blanc entre le footer et les catégories qui n'existe pas sur les autres pages, ce problème n'apparait que sur la page d'accueil pas sur les autres pages qui sont elles parfaites
Place au images.
La première image à gauche montre que tous va bien le footer est bien coller au reste de la boutique sans un énorme espace, la deuxième à droite montre que le footer créer un espace peut flatteur pour ma boutique et que je souhaiterais supprimer, mais je n'ai pas la solution malheureusement.
En espérant que vous puissiez m'aider, je vous remercie par avance.

5941_pRJpDClP2zY28FMysgZx_t

5942_UM4750NOAhRhqnvoYiic_t

Share this post


Link to post
Share on other sites

Déplacé depuis section Discussion générale.

Share this post


Link to post
Share on other sites
Déplacé depuis section Discussion générale.

Excuse moi pour ce désagrément.

Share this post


Link to post
Share on other sites

Personne pour me donner un petit coup de pouce?.

Share this post


Link to post
Share on other sites
Guest

dans "module", "produits phare" & "configurer" t'as quoi comme chiffre pour "nombre de produits" ? T'as pas touché aux fichiers du module "homefeature" par hasard ?

Share this post


Link to post
Share on other sites

Salut, j'ai 8 produits affichable sur le module "produits phares", et je n'ai toucher à aucun fichier autre que le footer pour le remplir et au images pour les remplacer et au css global.

Share this post


Link to post
Share on other sites
Guest

Et t'as bien 8 produits sur ta page d'accueil ? parce que sur le screen, et si j'me fie au template par défault, j'en vois que 4 ! Essaye de mettre le nombre de produits à 4 ou bien 8 produits en page d'accueil (histoire de tester) !

Share this post


Link to post
Share on other sites

Bonjour,

je te conseille d'utiliser le formidable plugin Firebug pour firefox.
c'est un outil indispensable pour l'integrateur html/css qui veut comprendre ce qu'il se passe sur sa page.

Grace à lui, regarde quelles sont les regles css qui s'appliquent au bloc footer, et au bloc produits phares (qui est surement en cause car le bug n'apparait que lorsqu'il est au dessus.)

en trafiquant les margin, padding de ces deux blocs, ou meme d'autres parametres, tu devrais trouver le fautif et résoudre ton pblm.

Share this post


Link to post
Share on other sites

Bonsoir, oui j'ai bien 8 produits phares sur ma page d'accueil je joint la capture le montrant pour vous en donner la preuve.
J'utilise le plugins Firefox "Webdevelloper" que je préfère et dont je me sert depuis pas mal de temps mais je ne trouve pas ce foutu bug d'affichage.
Le thème utilisé et le thème par défaut de Prestashop modifié par mes soins au niveau du global.css et des boutons ainsi que de quelques modules pour améliorer la qualité d'affichage de ma boutique.
Merci d'ailleurs au développeurs qui ont fait ces modules et surtout à Prestashop pour cette formidable solution e-commerce.

6011_ZwVyID30fvB3HQHWqZ16_t

Share this post


Link to post
Share on other sites
Le module webdevelloper n'est d'aucune utilité dans ce cas, ils sont plutôt complémentaire avec firebug. Je réitère donc mon conseil.

pa.


ps : sous réserve que tu parles bien ce cet addOn : https://addons.mozilla.org/en-US/firefox/addon/60


Oui je parle bien de ce module que je vais de ce pas désinstaller pour suivre ton conseil, je vous tiens donc au courant pour la suite des événements.

Share this post


Link to post
Share on other sites

Hé bien j'aurais trouver le problème en moins de 3mn grâce à ton plugin, donc merci beaucoup à toi voilà d'où venait le soucis.

produits phares




  • le 820 pixels à remplacer par 520 et tout vas bien du moins dans le plugins, maintenant reste à savoir ou changer ça et dans quel fichier.

Share this post


Link to post
Share on other sites
Guest

dans /modules/homefeatured/homefeature.tpl et tu changes ton 410 par 260 ;)
le module dont je faisais allusion plus haut... :coolgrin:

Share this post


Link to post
Share on other sites
dans /modules/homefeatured/homefeature.tpl et tu changes ton 410 par 260 ;)
le module dont je faisais allusion plus haut... :coolgrin:


:red: :red: :red: :red: Excuse moi j'avais pas fais attention :down: :-/ .
Merci à vous deux en tout cas et promis la prochaine fois je relirais 44 fois avant de reposter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More