Jump to content

[megoldva] Termék képek lapozása, megjelenítése nem működik


E.D.
 Share

Recommended Posts

Adott egy 1.4.3-as prestashop, amit más csinált eredetileg és jó néhány dolog el volt benne állítva. Elvileg már csak a címben szereplő probléma maradt javítatlanul, de nem jövök rá, hogy hol a hiba.

 

Már az probléma, hogy a termék oldalon a termék képére kattintva nem thickbox-al jelenik meg a kép, hanem új oldalon. Header-be beszúrtam a thickbox css és js elérését, így már működésbe lép a thickbox: elsötétül a kép és megjelenik a betöltőcsík, de sosem tölti be a képet...

 

A komolyabb probléma az, hogy ha több mint négy kép van, akkor ugye csak hármat jelenít meg az oldal, plusz van egy jobbra mutató nyíl, amivel elvileg lapozni lehet, de nem lehet... Nem működik. Forrásban ez van:

 

href="javascript:{ldelim}{rdelim}"

Oldalon forráskódban már csak ez jelenik meg: href="javascript:{}"

 

Merre keressem a hibát? Próbáltam a product tpl-t lecserélni az eredetire, de nem oldódott meg a probléma...

(természetesen minden módosítás után ürítem a smarty compile mappa tartalmát...)

 

Néztem, mintha ezt a {ldelim}-t a smarty kezelné, gyorsan össze is hasonlítottam a smarty fájljait az eredetivel, hátha azok lettek módosítva, de egyeznek...

Share this post


Link to post
Share on other sites

ööö....

 

hát most nem tudom megnézni de nekem is volt hasonló problémám - mondjuk ott csak annyi volt átállás után hogy nem ment a kép kinagyítása, a többi működött. Természetesen egy javascript-ről van szó, de nem emlékszem hogy melyik volt. Lényeg az volt hogy vagy hiányzott, vagy hibás volt (jaa, megvan: más témát telepítettem amibe nem volt benne a nagyítós script), beletettem és jó is volt. Tehát akkor: themes/tetemad/js => itt minden megvan ami kell? természetesen el vannak nevezve a js-ek így sok választás nem maradt, ha a nagyításról van szó...

jut eszembe, ez fontos: ha visszalépsz az eredeti témára ott okés a megjelenítés? Így ki lehet szűrni hogy hol a hiba.

Share this post


Link to post
Share on other sites

Végül meglett. Tényleg egy js hiányzott, de nem volt egyszerű megtalálni, mert annyira át lett szabva a téma, annyi mindent behúz, illetve annyi minden módosítva lett ezekben... De így, hogy csak a js-ek ellenőrzésére koncentráltam, meglett nagy nehezen...

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More