Jump to content
Sign in to follow this  
bott-in

URL simplifiées soucis avec les CMS demande d'aide Merci

Recommended Posts

Bonjour à tout le monde,

Petit soucis, j'ai configuré ma boutique avec la réécriture d'url (soucis avec google pour le référencement), et depuis toutes mes mentions obligatoires arrivent sur une erreur 404.
Toutes les pages sont ok, sauf donc les fameuses CMS (C.G.V Transport...)
Je suis sur OVH avec un Plan 90
Mon fichier htaccess est le suivant

SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0

# URL rewriting module activation
RewriteEngine on

# URL rewriting rules
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]

RewriteBase /

# Catch 404 errors
ErrorDocument 404 /404.php

Quelqu'un pourrait-il me venir en aide, car là je suis larguée
Bonne journée à tout le monde
GERALDINE

Share this post


Link to post
Share on other sites

Bonjour Geraldine,

As-tu réussi a regler ton probleme ?

J'ai moi même un probleme similaire depuis le passage vers la version 1.1, avec les liens de CMS dans le back office (delivery, legal-notice, terms-and-conditions-of-use, about-us, secure-payment), qui m'amenent a des pages au format www.monsite.com/content/1-delivery etc. lesquelles pages n'existent pas, d'ou... erreur 404 (j'ai meme pas de dossier "content" dans mon site)

Par contre dans le front office (le site en ligne), les liens présents dans mon infoblocs sont au format www.monsite.com/delivery.php et ainsi de suite.

Je ne suis pas expert... et si tu as reglé ton problème ca m'intéresserait beaucoup de savoir comment...

Merci,

Share this post


Link to post
Share on other sites

Bonjour,

as tu essayé de mettre à jour ton .htaccess en allant dans ton back office, Préférences, ligne URL simplifiée générer un fichier .htaccess puis générer le fichier .htaccess ?

Share this post


Link to post
Share on other sites

Mikaela,

Actuellement url rewriting est a "on" et mon fichier est nommé "htaccess" (sans le point devant)

Par contre je ne vois pas l'option "générer un fichier .htaccess" dans preferences de back office... Est-ce normal ou ai-je mal compris ?

Merci d'avance Mikaela,


J'inclus ci-dessous le contenu du fichier htaccess pour info:


# URL rewriting module activation
RewriteEngine on

# URL rewriting rules
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]

# Catch 404 errors
ErrorDocument 404 /404.php

Share this post


Link to post
Share on other sites

Désolé pour le typo dans ton nom Mikael ;-)

Share this post


Link to post
Share on other sites

J'ai résolu une partie de mon probleme concernant les pages d'erreurs dans les liens relatifs au CMS, l'erreur de URL rewriting venait de moi:

Je m'explique, apres l'installation de la v.1.1, je n'ai pas dû effacer le fichier .htaccess qui est invisible (sous mac du moins). Je ne savais pas comment montrer les fichiers invisibles dans mon client ftp, je l'ai maintenant trouvé.
Alors que mon URL rewriting était a "on", j'éditais le fichier htaccess sans succes alors que le fichier actif etait le fichier caché .htaccess (datant de la v.1.0)

Ayant réalisé ceci, j'ai effacé htaccess et ajouté les 2 lignes manquantes a .htaccess pour que le CMS fonctionne, tel qu'expliqué dans ce thread:
http://www.prestashop.com/forums/viewthread/13585/developpement_et_modules/resolupages_derreur_avec_livraisonmentions_legales_conditions_generales_de_ventes_a_propos_dot__dot__dot_


Pour la deuxieme partie du probleme qui persiste toujours (les liens présents dans mon infoblocs sont au format http://www.monsite.com/delivery.php au lieu de www.monsite.com/content/1-delivery et ne fonctionnent pas avec le contenu CMS)... je pense que je devrai créer un nouveau thread... ?

Share this post


Link to post
Share on other sites
Bonjour,

as tu essayé de mettre à jour ton .htaccess en allant dans ton back office, Préférences, ligne URL simplifiée générer un fichier .htaccess puis générer le fichier .htaccess ?


Mikael est en avance sur son temps... :)

Cette option est (sera) dispo dans la 1.2.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More