Jump to content
Sign in to follow this  
Invasion

[Résolu] Incapable de relier la base de donnée

Recommended Posts

Bonjour à tous.

Je crois vraiment avoir modifié tout ce qui devait être modifié, mais je suis toujours incapable de faire fonctionner mon magasin en ligne.

J'ai toujours le message: Link to database cannot be established.

Voici le contenu de mon fichier settings.inc

<?php

define('__PS_BASE_URI__', 'www/prestashop');
define('_THEME_NAME_', 'et-clean-blue');
define('_DB_NAME_', 'pres1098_prestashop');
define('_DB_SERVER_', '127.0.0.1');
define('_DB_USER_', 'presta');
define('_DB_PREFIX_', 'ps_');
define('_DB_PASSWD_', '*');
define('_DB_TYPE_', 'MySQL');
define('_COOKIE_KEY_', 'kdPTfQ3C2wUMnHMUmCnL8ZrPZ1Zn87nZDF5HULNFvvIzG4pDQDfDaOWh');
define('_COOKIE_IV_', 'IZ9P1Z60');
define('_PS_VERSION_', '1.1.0.5');

?>

Merci de votre aide.

Share this post


Link to post
Share on other sites

Salut

Enlève les www ça fonctionnera aprés :) en principe .

bye
define(’PS_BASE_URI‘, ‘/prestashop/’);

Yannick

Share this post


Link to post
Share on other sites
Enlève les www ça fonctionnera aprés :) en principe .


C'est pas faux, mais la source du message d'erreur vient plutôt de la ligne :
define(’DB_SERVER‘, ’127.0.0.1’);
Ton hébergeur a dû te donner le nom de ton serveur de base de données. C'est sûrement pas 127.0.0.1.
A vérifier aussi le nom de ta base de données et de l'utilisateur.
define(’DB_NAME‘, ‘pres1098_prestashop’);
define(’DB_USER‘, ‘presta’);

Et voir si c'est normal que le mot de passe soit si court.

Share this post


Link to post
Share on other sites
Guest

Bizarre effectivement, as-tu importer ta base de données en local chez OVH ? via phpMyAdmin ?

parce que si c'est le cas, faut mettre les mêmes identifiants et mot de passe dans le fichier settinc.inc... sachant que "db_name" et "db_user" est la même chose chez ovh ;)

Share this post


Link to post
Share on other sites

Bonjour

ah oui pour le 127.0.0.1 je me suis dis qu'il devait être en local,j'avais pas bien lu

mais je suis toujours incapable de faire fonctionner mon magasin en ligne


je rajoute une Couche :) faite bien Attention à

define('_DB_SERVER_', 'mysql5-7');

sur OVH suivant les plans à bien le définir aussi

Bye
Yannick

Share this post


Link to post
Share on other sites

Merci pour votre aide, mais ca ne résou pas le problème.

Je ne suis pas en local. Mon hébergeur m'a aussi donné le nom du serveur de la base de donnée, j'ai essayé avec le nom et finalement il m'ont dit de prendre le ip que j'ai mis dans mon post. Mon mot de passe n'est pas court je l'ai juste effacé pour le poster ici.

Au secours! ahah

Share this post


Link to post
Share on other sites
Guest

essaye ça :

define('_DB_SERVER_', 'localhost');



au lieu de 127.0.0.1

Share this post


Link to post
Share on other sites

Ca ne fontionne toujours pas malheureusement.

Je ne comprends pas je semble avoir les données complètes...

Y-a-t-il une façon plus simple pour régler le problème? Du genre ... je ne sais pas, ne pas mettre de mot de passe ou etc...

Share this post


Link to post
Share on other sites

Voici ce que dit mon hébergeur sur le problème. J'ai essayé tout ca sans succès...il doit y avoir quelque chose que je fait mal!

Here is what you need to connect to your database:

1) Database name
2) Database usernaame
3) Database password
4) Connection settings

The hostname to connect to is "localhost" if connecting from a script on the server, or your domain name for connecting remotely. The database name and username need to be entered exactly as they appear in the MySQL manager in your control panel (CPanel) i.e., cpanelusername_dbname, etc. The password is the one you specified when creating the username.

localhost should work, but if you have trouble, you can also try 127.0.0.1, which is same as localhost.

When you create a username in cpanel, please be aware that there is an 8 character limit. Extra characters will be dropped.

Also, you can have more than one username for a database. If you forget your user password, you may either find it in the script's config file or add a new user to the database and edit the script's config file.

Please make sure you have added the database user to the database. You must select the user and the database from the drop-down lists and then click on the "Add User to DB" button. You should see connection code provided if you have done this.

For best results, if connecting remotely and if you do not have a static ip address, you need to add a single % sign to the access host list in the MySQL manager of your cpanel.

The port is 3306.

Share this post


Link to post
Share on other sites

Bon, j'ai trouvé le problème. Mon hébergeur a changé mon user automatiquement. Par contre... maintenant ca me dit:

The database selection cannot be made.

Share this post


Link to post
Share on other sites

Cette boutique, tu l'as installé de zéro directement sur le serveur ou bien elle était en local et tu l'as transférée ?

Si tu l'as transférée, tu as bien importé la base de données ?

Share this post


Link to post
Share on other sites
Bon, j'ai trouvé le problème. Mon hébergeur a changé mon user automatiquement. Par contre... maintenant ca me dit:

The database selection cannot be made.


Oups, on s'est croisé.

Ben là ça doit vouloir dire que le nom du serveur et le login/password sont bons, mais peut-être pas le nom de la BDD ou le préfixe.

Share this post


Link to post
Share on other sites

Je l'ai transférée et j'ai importé la base de donnée oui. Par contre elle ne veut pas garder le même nom car mon hébergeur ajoute automatiquement "pres1098" devant. J'ai par contre modifié mon fichier settings en conséquence.

Voici a quoi il ressemble maintenant.

<?php

define('__PS_BASE_URI__', '/www/prestashop');
define('_THEME_NAME_', 'et-clean-blue');
define('_DB_NAME_', 'pres1098_prestashop');
define('_DB_SERVER_', 'localhost');
define('_DB_USER_', 'pres1098_presta');
define('_DB_PREFIX_', 'ps_');
define('_DB_PASSWD_', 'adminweb');
define('_DB_TYPE_', 'MySQL');
define('_COOKIE_KEY_', 'kdPTfQ3C2wUMnHMUmCnL8ZrPZ1Zn87nZDF5HULNFvvIzG4pDQDfDaOWh');
define('_COOKIE_IV_', 'IZ9P1Z60');
define('_PS_VERSION_', '1.1.0.5');

?>

Share this post


Link to post
Share on other sites

Je n'ai pas changé le préfixe (ps_) mais comment je fais pour voir si il a été changé, au cas?

Share this post


Link to post
Share on other sites

C'est sympa de nous donner ton mot de passe. Si j'avais eu l'URL je serais allé vérifié moi-même. :P

Tu dois disposer d'un outil (genre phpMyAdmin) pour accéder à ta base. Regarde dedans si les tables sont précédées du préfixe ("ps_" dans ton cas).

Et je pense que tu devrais modifier le PS_BASE_URI avec '/prestashop/'.

Share this post


Link to post
Share on other sites

Ca ne fonctionne toujours pas, même en changant ce que tu m'as suggéré...

Share this post


Link to post
Share on other sites

Il faut dire que c'était vicieux. Le panneau d'admin des BDD MySQL affichait un username bidon... phpMyAdmin affichait le bon...

Share this post


Link to post
Share on other sites

Bonjour,

Cette boutique, tu l'as installé de zéro directement sur le serveur ou bien elle était en local et tu l'as transférée ?

Si tu l'as transférée, tu as bien importé la base de données ?


A quoi correspond en général la base de données,

A savoir que j'ai transférée ma boutique qui était en local et j'obtiens le message suivant:
"The database selection cannot be made." et je ne suis pas vraiment sur d'avoir importé la base de données.

Merci pour votre aide. salutations.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More