Jump to content
Sign in to follow this  
Ann

Lenteur du site après transfert à la racine

Recommended Posts

Bonjour,

J'ai fait évoluer mon site en le faisant passer de l'url: http://www.ann-secrets.com/prestashop/'>http://www.ann-secrets.com/prestashop/

à l'url : http://www.ann-secrets.com/

Je suis surprise par le net ralentissement de fonctionnement général et le temps de chargement. J'analyse avec Firebug et Yslow, mais je ne suis pas parvenue à trouver l'explication du dysfonctionnement. Quelqu'un aurait il une piste à me proposer ?

Merci d'avance

Ann

Share this post


Link to post
Share on other sites

Il semble que ce soit le temps de connexion qui soit très long. Une fois la connexion faite tout va très vite.

Cette boutique est EXACTEMENT la même que celle qui était dans un sous dossier ou bien tu as ajouté quelque chose (un script par exemple, j'ai vu PHPMyVisits) ?

Faudrait peut-être faire l'essai en désactivant ce script...

Share this post


Link to post
Share on other sites

Bonjour et merci pour ta réponse rapide.

Je n'ai rien touché par rapport au site précédent, le script phpmyvisites y figurait déjà. Auparavant le temps d'accès était correct, mais là, je constate vraiment du délai et je me demande quelle mauvaise manip j'aurais pu faire pendant le transfert qui pourrait expliquer ceci. Juste pour info, je suis chez ovh 90plan, mais cela ne posait pas de souci majeur .

Share this post


Link to post
Share on other sites

Est-ce que notamment la ligne PS_BASE_URI a bien été modifiée en conséquence dans le fichier :
/config/settings.inc.php
C'est à dire remplacer /prestashop/ en /
Je pense que si c'était pas le cas la boutique ne s'afficherait pas mais bon...

Même question pour le .htaccess, par exemple pour une éventuelle instruction RewriteBase :
RewriteBase /
au lieu de
RewriteBase /prestashop/

C'est vrai que dans le code source, il y a de nombreuses références à un dossier prestashop1

Share this post


Link to post
Share on other sites

Merci pour tous ces précieux renseignements ! En effet , je n'avais pas songé à modifier mon.htaccess. J'espère que tout va rouler maintenant !

Encore merci !

Ann

Share this post


Link to post
Share on other sites
as tu fait les modifs dans la base de données ? j'ai remarqué qu'il conservait des liens du genre http://www.ann-secrets.com/prestashop/'>http://www.ann-secrets.com/prestashop/
(sont ils remplacés par http://www.ann-secrets.com/ ?)


Je n'ai fait aucune modif dans ma base, pour la bonne raison que je suis loin de tout comprendre à Mysql et j'ai beaucoup de mal déjà à me promener dans phpmyadmin ! Je ne sais même pas à quel endroit faire ces modif !

Share this post


Link to post
Share on other sites
as tu fait les modifs dans la base de données ? j'ai remarqué qu'il conservait des liens du genre http://www.ann-secrets.com/prestashop/'>http://www.ann-secrets.com/prestashop/
(sont ils remplacés par http://www.ann-secrets.com/ ?)


Je n'ai fait aucune modif dans ma base, pour la bonne raison que je suis loin de tout comprendre à Mysql et j'ai beaucoup de mal déjà à me promener dans phpmyadmin ! Je ne sais même pas à quel endroit faire ces modif !


Je ne suis pas sûr que pour un déplacement de boutique il y ait des modif à faire dans la base.

Ann, tu as fait les modif ? Parce que ça rame toujours là...

Share this post


Link to post
Share on other sites

J'ai juste modifié le htaccess.... je sais que ça rame toujours... sniff

Share this post


Link to post
Share on other sites
Guest
as tu fait les modifs dans la base de données ? j'ai remarqué qu'il conservait des liens du genre http://www.ann-secrets.com/prestashop/'>http://www.ann-secrets.com/prestashop/
(sont ils remplacés par http://www.ann-secrets.com/ ?)


Je n'ai fait aucune modif dans ma base, pour la bonne raison que je suis loin de tout comprendre à Mysql et j'ai beaucoup de mal déjà à me promener dans phpmyadmin ! Je ne sais même pas à quel endroit faire ces modif !


Je ne suis pas sûr que pour un déplacement de boutique il y ait des modif à faire dans la base.

Ann, tu as fait les modif ? Parce que ça rame toujours là...


Dans la table "`ps_pagenotfound`" ! Elle va retrouver beaucoup de lien sous forme de http://www.ann-secrets.com/prestashop/'>http://www.ann-secrets.com/prestashop/... (enfin c'est ce que je vois quand j'exporte ma base de données) !

Et plutot de faire une requete MySQL, j'récupere les infos de la base de données, sous forme de fichier mabase.sql ensuite je l'ouvre avec un éditeur de texte et je fais "Remplacer", pour l'exemple d'ici, je fais rechercher sur "http://www.ann-secrets.com/prestashop/'>http://www.ann-secrets.com/prestashop/" et remplacer par "http://www.ann-secrets.com/") ! En général, j'ai plus de 500 modifications !!

Après, il se peut que je dise des conneries, mais pour moi il me semble logique de corriger ces liens !

Share this post


Link to post
Share on other sites

Merci pour toutes ces infos...à l'attention de Zendik, je suis chez ovh avec un 90 plan , j'ai en effet lu le post du monsieur. Il est vrai qu'ovh mutualisé n'est pas l'idéal au niveau compatibilité avec Presta, du moins à partir d'un certain poids de site et d'images traitées ( près de 8000 pour le cas de mon site )

Serait il possible de m'expliquer la démarche à faire sur la base pas à pas, car cette soluce me semble intéressante, mais je ne sais comment l'entreprendre. Merci d'avance

Ann

Share this post


Link to post
Share on other sites

Tu as essayé les modif du .htaccess dont je t'ai parlé hier en PM ?

Share this post


Link to post
Share on other sites

OVH vient de suspendre le serveur à cause du trop grand nombre de redirections et de sollicitation du serveur... super

Share this post


Link to post
Share on other sites
OVH vient de suspendre le serveur à cause du trop grand nombre de redirections et de sollicitation du serveur... super


Pour quelle raison ? A cause de ton site ?

Suspendre le serveur ou ton site ?

Share this post


Link to post
Share on other sites

J'ai moi aussi beaucoup de problème de lenteur!!! je suis aussi chez ovh, mais je ne sais pas si il y a un rapport, car sur ce même serveur j'était sous oscommerce avant, et ca allait très bien!
Par contre en suppriment le contenu du dossier tools/smarty/compile (sauf l'index.php) cela à forcé la création d'un nouveau cache. Car mon site était en local puis une fois passé sur le serveur, lenteur.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More