Jump to content
stephforum

fenetre d'alerte lors de changement d'adresse

Recommended Posts

Bonjour,

Venant de faire ma mise à jour de 1.3.1.1 vers 1.4.4.0 qui dans l'ensemble c'est bien passé :P , j'ai quand meme des petits détails génant visuellement :)

Lorsqu'un client a plusieurs adresses à son carnet, si il change son choix, cela se passe bien mais, une fenetre indiquant :

 

TECHNICAL ERROR: unable to save adresses

Detail:

Error thrown:[objet XMLHttpRequest]

Text status: parseerror

 

Cela n'empeche pas le chargement de l'adresse souhaitée mais, ca peu faire peur au client.

Vous avez une idée de ce qui provoque cet etat ?

Merci d'avance pour vos sugestions ?

Bonne soirée :) .

steph

Share this post


Link to post
Share on other sites

Personne n'a ce probleme ? Une idée ?

La Team peut-etre ?

Merci d'avance pour votre retour :)

Share this post


Link to post
Share on other sites

Bonjour,

 

La solution a été trouvé sur se site. J'ai fait la modif du fichier "FrontController.php" dans le dossier "classes" et tout fonctionne.

 

http://scm.prestashop.com/viewrep/PrestaShop_v.1.4.x/classes/FrontController.php?r1=7588&r2=7840

 

A la ligne 347, vous devriez avoir ce code :

 

if (!preg_match('/^'.Tools::pRegexp($canonicalURL, '/').'([&?].*)?$/', (($this->ssl AND Configuration::get('PS_SSL_ENABLED')) ? 'https://' : 'http://').$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']))

 

Il suffit de le remplacer par :

 

if (!Tools::getValue('ajax') && !preg_match('/^'.Tools::pRegexp($canonicalURL, '/').'([&?].*)?$/', (($this->ssl AND Configuration::get('PS_SSL_ENABLED')) ? 'https://' : 'http://').$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']))

 

Et le tour est joué. Penser à forcer la complilation de smarty !

 

Cordialement,

Marc.

  • Like 1

Share this post


Link to post
Share on other sites

Pour aider d'autres utilisateurs susceptibles de rencontrer le même souci, je te propose de passer le sujet en résolu.

  • Like 1

Share this post


Link to post
Share on other sites

Pour aider d'autres utilisateurs susceptibles de rencontrer le même souci, je te propose de passer le sujet en résolu.

 

Pour cela il faudrait que le créateur du topic vienne confirmer que ça a résolu son problème.

Share this post


Link to post
Share on other sites
Pour aider d'autres utilisateurs susceptibles de rencontrer le même souci, je te propose de passer le sujet en résolu.

 

J'ai eu peur que c'était à moi de le faire.... hehe !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More