Jump to content

[Solved] No hay transportista disponible para esta dirección


Recommended Posts

Sé que este asunto ha sido tratado en otros temas, pero por más que siga al pie de la letra las instrucciones no logro configurar satisfactoriamente el envío y me sigue apareciendo el mensaje "No hay transportista disponible para esta dirección".

He intentado creando franjas de precio y peso y nada. He reinstalado Prestashop dos veces y nada. He creado varios transportistas y nada.

Estoy ubicado en Caracas, Venezuela, y la zona que le corresponde es Sudamérica, he desactivado todas las demás zonas, todos los demás países, he intentado creando una zona sólo para Venezuela, y nada.

Por favor, ¿alguien me podría explicar cómo solucionar o cómo han solucionado este problema que tan frustrante es?

Gracias a quien pueda darme una solución.

Share this post


Link to post
Share on other sites

Sé que este asunto ha sido tratado en otros temas, pero por más que siga al pie de la letra las instrucciones no logro configurar satisfactoriamente el envío y me sigue apareciendo el mensaje "No hay transportista disponible para esta dirección".

He intentado creando franjas de precio y peso y nada. He reinstalado Prestashop dos veces y nada. He creado varios transportistas y nada.

Estoy ubicado en Caracas, Venezuela, y la zona que le corresponde es Sudamérica, he desactivado todas las demás zonas, todos los demás países, he intentado creando una zona sólo para Venezuela, y nada.

Por favor, ¿alguien me podría explicar cómo solucionar o cómo han solucionado este problema que tan frustrante es?

Gracias a quien pueda darme una solución.


Hola, a veces resulta frustrante, a mi me costo....Si me das un acceso a tu BO, te lo puedo mirar.
Mandame un privado si quieres
RODOLFO

Share this post


Link to post
Share on other sites

Yo también borre my carrier que viene por defecto en la versión 1.4 y no he tenido que tocar nada de MySQL, ya te digo, me bastó con añadir franja de precios asignada al transportista.

Share this post


Link to post
Share on other sites

Hola, con la ayuda de este foro logré solventar el problema. La solución era más sencilla de lo que parecía, y la doy por pasos:

1. Crear un transportista y luego:

2. Asignarle un valor a la franja de precios que vaya de 0 a 999999 (los valores pueden ser cualquiera).

3. Asignarle un valor a la franja de pesos que vaya de 0 a 999999 (los valores pueden ser cualquiera).

4. Volver a la pestaña transportista y entonces allí se le asignará el valor por las zonas al transportista.

Esos son los pasos para activar el transportista. Me ha servido.

Gracias por el aporte de todos.

  • Like 2

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Yo estoy con 1.4.2.5 y he querido meter Correos y mje ha costado tiempo.

Después de seguir estos pasos no me acababa de funcionar, al final lo he logrado y explico como:
. Opción1: No dando de alta ninguna nueva zona y asignado el transportista a la zona Europa
Esto tiene el inconveniente de que se van a aplicar los mismos precios para envíar a Alcalá (vivo en Madrid) que para enviar a Berlin.
. Opción 2: Dando de alta nuevas zonas (p.e. las típicas que aparecen en los desgloses de precios de Correos: Península, Baleares, Canarias, Ceuta y Melilla), pero entonces para que PrestaShop conozca qué zona tiene que usar para un envio es necesario editar el país España y decir que tiene Estados (luego en unos casos aparece como Estados y en otros como provincias, problema de la Traducción probablemente) y asignar cada provincia a una de las zonas así dadas de alta; esto obliga a que el usuario inique la provincia en la que se encuentra la localidad de envío (no vale sólo el Codigo Postal, se podría modificar el sw de alta de usuario/cambio de localidad para no tener que indicar la provincia, pues el códico postal ya la idintifica, pero....)
. Opción 3: (esta no la he probado). Si no se quiere pedir Provincia, solo se var a permitir pedidos de España y se van a aplicar las mismas tarifas a envíos a Península e islas, entonces se deberían dar de baja todos los paises (salvo España) para así no admitir usuarios con dirección fuera de España, se podría mantener la Zona Europa (o cambiarla por otra con nombre más adecuado para no confundir) y asiganar el transportista a dicha zona.
Espero que ayude.

Share this post


Link to post
Share on other sites

Hola, con la ayuda de este foro logré solventar el problema. La solución era más sencilla de lo que parecía, y la doy por pasos:

1. Crear un transportista y luego:

2. Asignarle un valor a la franja de precios que vaya de 0 a 999999 (los valores pueden ser cualquiera).

3. Asignarle un valor a la franja de pesos que vaya de 0 a 999999 (los valores pueden ser cualquiera).

4. Volver a la pestaña transportista y entonces allí se le asignará el valor por las zonas al transportista.

Esos son los pasos para activar el transportista. Me ha servido.

Gracias por el aporte de todos.

Aver si me puedes dar una mano. Tengo la tienda 1.4 y resulta que el envío solo cuesta $20 para cualquier producto y para cualquier lugar. El tema es que cuando hago una compra me suma el costo del producto + el envío pero cuando compro otro producto vuelve a sumar el envío. O sea que un cliente que mete varias cosas en la canasta por cada una de ellas le suma $20. Sabes como arreglarlo o como tengo que ponerlo?

Share this post


Link to post
Share on other sites

Hola, con la ayuda de este foro logré solventar el problema. La solución era más sencilla de lo que parecía, y la doy por pasos:

1. Crear un transportista y luego:

2. Asignarle un valor a la franja de precios que vaya de 0 a 999999 (los valores pueden ser cualquiera).

3. Asignarle un valor a la franja de pesos que vaya de 0 a 999999 (los valores pueden ser cualquiera).

4. Volver a la pestaña transportista y entonces allí se le asignará el valor por las zonas al transportista.

Esos son los pasos para activar el transportista. Me ha servido.

Gracias por el aporte de todos.


Me sigue saliendo el mismo cartel. No hay transportista disponible para esta dirección, estoy comenzando a desesperar. Ojo que hasta hace un rato andaba lo que pasa que estuve haciendo unos cambios, y ahora no me anda. Podrías chequear que ademas de estos pasos que pones aca no hay algunos extras?

Share this post


Link to post
Share on other sites

Hola,
a mi solo me salía uno y no había manera de habilitar el resto despues de actualizar a 1.4...
hasta que he entrado a Transporte >Tasas y en la opción Todo (si hay varias zonas) he puesto 0 he actualizado y ya me aparecen!
Saludos

Share this post


Link to post
Share on other sites

  • 3 months later...

El rollo de hacer cambios y que no vaya es porque aunque estes "editando" un transportista, al guardarlo este ser guarda con el siguiente id incremental en vez de mantener el que tenia. (Mi no comprender pero asi es como va... ps 1.4.4.1)

 

Yo lo solucione entrando en la base de datos via phpmyadmin, tabla "carrier_zone" y asignando los valores a mano, fijandome en mis ids (1,2,3) y mis zonas (9,10,11) para no alterarlos.

 

Recomiendo a quien no quiera romperse mucho los cohones con esto que borre todos los carriers y las zonas, que primero se las plantee bien ( incluyendo nombre, imagen, zonas de pertenencia y demas....) y que despues se las cree a la primera y sin fallo.

 

Una vez hecho, te vas a la pestaña padre "transporte" y abajo del todo tienes un desplegable para la franja que hayas designado, ya sea precio o peso. NO es necesario crear franjas de ambas. Yo por ejemplo puse de 0 a 1 kg porque siquiera he establecido peso en articulos. SOLO con crear una franja y definir los precios se activa todo.

 

Insisto, el que se vuelve loco que se fije bien en que cada vez que guarda se cambian los ids.

Si lo consigues dejar bien... tambien recomiendo que te hagas un backup desde phpmyadmin de las tablas "carrier", "carrier_x" ( las que empiezen por carrier), tambien la tabla "delivery" que es la que contiene los precios y por ultimo las "range_price" ó "range_weight" (ambas si procede) que contienen los rangos definidos y asi evitas sustos posteriores. (EJ el que monte varias tiendas bajo el mismo transportista y precios o el que toca y cada 2 por 3 tiene que restaurar sin querer y bingo, otra vez a meter el rollo macabeo)

 

:) Por lo demas... una vez puesto va de perlas.

Share this post


Link to post
Share on other sites

solucion :rolleyes:

 

1- clic en pestaña "Transporte"

2- clic en "Transportistas"

3- Clic en el icono para editar transportista , por ejemplo My Carrier

una vez alli tildar la zona de su pais en mi caso:

South America

presionar guardar .

 

4- hacer clic nuevamente en la Pestaña "Transporte"

vamos justo casi al final de la pagina donde estan las Tasas.

usamos el selector para cargar el transportista que editamos antes,

 

al seleccionarlo apareceran los valores para Zona/Rango, agregamos el valor para nuestra zona y listo!!

 

eso era todo :wub:

 

saludos!!!

Share this post


Link to post
Share on other sites

  • 1 month later...

Hola a todos, es la primera vez que escribo en un foro, bueno mi problema es que no puedo añadir transportistas y no puedo configurar nada relacionado con los transportes, estoy loco ahora me aparece No hay transportista disponible para esta dirección cuando se realiza algun pedido, por favor necesito ayuda urgente he provado un monton de cosas y nada.

¿se podria reinstalar de alguna manera sin perder mis productos y configuraciones?

Tambien cuando intento actualizar algo me pone ha sido imposible crear el objeto carrier o algo así.

Tmapoco me sale la opcion de tasas.

 

GRACIAS

Share this post


Link to post
Share on other sites

  • 1 month later...
  • 3 weeks later...

Charly, reintalar todo sin perder configuraciones.

 

Instalate un PS en localhost u otro host, y luego te exportas sólo las tablas country,zone,carrier_*,state.

 

Antes de reinstalar, revisa que no hayas editado un transportista (nombre,imagen o lo que sea) ya que se guarda con ID incremental, por lo que siempre se debe ir de nuevo y seleccionar transportista por defecto.

 

Dentro de cada transportista debes indicar las zonas donde está disponible.

Asegurate que el pais "contiene estados" y que en la ficha del cliente de pruebas se selecciona alguna.

Share this post


Link to post
Share on other sites

  • 4 weeks later...

Buenas

Yo he experimentado este problema y después de seguir todas las indicaciones que comentáis no pude solucionarlo.

(el transportista nuevo que he creado no aparece en ninguna parte).

He accedido a la base de datos y he puesto todos los registros de mi transportista exactamente igual que como estaba el transportista por defecto (My carrier) y no ha servido de nada.

Al final he vuelto a activar el transportista my carrier (campo deleted=0) y si que ha aparecido, con lo que he combiado el nombre y he utilizado este por defecto para las operaciones de venta.

Supongo que es un error que en la próxima versión estará reparado, pero de momento esta solución a mí me ha valido.

Saludos

Juan

Share this post


Link to post
Share on other sites

1.Tu transportista se tiene que ver. (Sin necesidad de editar "is_deleted". Empezando por esto, algo ya no está bien...)

2. Y además funcionar...

 

Lee atentamente los pasos y escríbelos en un notepad o lokesea para repasar que no te dejas las opciones a boleo.

 

A mi parecer, si los demás han podido arreglarlo, algo te dejas... o tu problema no es el mismo.

Share this post


Link to post
Share on other sites

  • 1 month later...

Buenas,

Estoy teniendo el mismo problema, todo parece ir bien con los parámetros del transportista:

se guardan bien mis 2 transportistas (correos y chronoexpres) las franjas de precios, los países, pero luego a la hora de hacer una compra sale este mensaje: NO HAY TRANSPORTISTA DISPONIBLE PARA ESTA DIRECCIÓN

He borrado y vuelto a hacerlo todo 2 veces.... no se por donde buscar.

Tengo que decir que borre el transportista que viene por defecto: my carrier y puesto correos de España.

Lo siento no entiendo nada de programación.

Gracias por la ayuda que me podrán brindar.

Saludos

Claire

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 3 months later...

Habiendo seguido TODOS los pasos aconsejados, aun me salía el dichoso mensaje.

En mi caso necesito despachar a diferentes paises de Europa, y cada transportista atiende diferentes paises con diferentes costos por tramo de pesos. Por esto no podía usar la zona "Europa", y necesitaba una zona por cada pais a servir.

 

Cree entonces por ejemplo Francia y España. Pero al hacer las pruebas de compra con una dirección en Francia me salia el mensaje de error.

 

La confusión esta en que la base de datos no relaciona la zona "Francia" con el pais "Francia", por lo que este ultimo, en la BD, no tiene transportistas.

 

Solución: Ir a la lista de países, entrar a su configuración, y asignarlo a una zona.

Problema resuelto. :D

Edited by sbm (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

  • 2 months later...
  • 2 weeks later...

pnieto.

 

Te aconsejo que intentes una cosa más. Haz donde sea una nueva instalación y juega con ellos.

El problema no es del prestashop. O bien instalas algo raro, o bien no has comprendido/marcado bien las opciones y sus relaciones.

 

Por ejemplo, puedes crear 1000 zonas si quieres, 20 en españa, 7 en el japón y el resto más lejos.

Con esto quiero decirte, que el sistema no falla. Es cuestión de revisar los detalles y aplicarlos de 0.

 

Te aseguro que lo puedes arreglar con 0 conocimientos de programación ;) animo.

Share this post


Link to post
Share on other sites

  • 2 weeks later...
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More