en Jump to content
atarli

[LØST]Test shop under subdomain

Recommended Posts

Jeg har oprettet et subdomain og ftp hele min shop under den folder.

Men når jeg tilgår den bliver jeg redirected til mit "hovede" domain.

Hvad er det som jeg mangler at gøre.

På forhånd tak

Mvh Morten

Share this post


Link to post
Share on other sites

Har nu prøvet at installere xampp på min maskine og kopieret hele shoppen der til... Men når jeg går ind shoppen via xampp bliver jeg stadig redirected til mit "hovede" domæne.

Nogen der kan guide mig den rigtige vej mod en løsning.

Share this post


Link to post
Share on other sites

Hvor er du hostet? (hastighedsmæssigt ligner det Gigahost). Hvis det er hos dem, ville jeg kontakte dem, for et eller andet er der sat op på dit domæne.

Al trafik peges videre til dit hoveddomænet, det er ligegyldigt, hvad jeg skriver før dit domænenavn - al trafik sendes videre.

P.S. Din shops indhold er rykket ned fordi dit logo er for stort.

Share this post


Link to post
Share on other sites

Gigahost siger at alt står som det skal.
Men som jeg lige kom i tanke om har jeg jo også prøvet at lægge det hele ind i xampp hvor den også sender mig videre til hovede domænet.. Så der må være et sted jeg skal ind og ændre at det ligger lokalt eller ?

Share this post


Link to post
Share on other sites

Jeg har nu installeret prestashop forfra på min lokale computer.
Men lige så snart jeg laver en import af min database, så begynder den at Redirecte mig til et hovede domæne igen.

Hvor i databasen kan den lave denne henvisning ?

mvh Morten

Share this post


Link to post
Share on other sites

Jeg har ingen .htaccess fil, det har jeg vist også skrevet et sted.

Men ved en helt frisk installation burde den vel heller ikke blive oprettet ?

Share this post


Link to post
Share on other sites

Så er vi tilbage ved din DNS-opsætning, som redirecter al din trafik til hoveddomænet. Hvad har du af DNS-indstillinger?

Jeg må indrømme, at jeg ikke ved noget om en lokal installation. Jeg installarer altid mine testhops på et subdomæne hos mine hosts og så deaktiverer jeg blot shoppen. Jeg tror, Gigahost som standard laver en *-forward på domænerne, så når du ikke har et subdomæne, så vil den sende alt trafik videre.

Men som sagt, jeg ved det ikke med sikkerhed - jeg har haft to shops kørende på to forskellige domæner samt diverse testshops på subdomæner også hos Gigahost, og jeg har ikke oplevet disse problemer.

Share this post


Link to post
Share on other sites

Fandt løsningen.

I databasen under table "ps_configuration"

ændre record PS_SHOP_DOMAIN til subdomæne

 

mvh Morten

 

Hmm.. jeg kan ikke finde PS_SHOP_DOMAIN i _configuration.. måske de har lavet det om PS 1.4.8.5 Er der nogen der kan hjælp ??

Share this post


Link to post
Share on other sites

Du bør starte en ny tråd om dette, da tråden du skriver i, er løst (det bliver lidt noget rod, når man genåbner en lukket tråd med nye problemer, specielt fordi versionerne af PrestaShop ændrer sig undervejs - og koden flyttes/ændres ofte i nye versioner)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More